1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AC-68U with Shibby v121: Bandwidth limiter not limiting upload speed [conflict with Captive Portal]

Discussion in 'Tomato Firmware' started by alllexx, Aug 27, 2014.

  1. alllexx

    alllexx Reformed Router Member

    I'm trying to limit bandwidth for a guest network on br1. While download speed limit works fine, upload limit doesn't seem to have any effect at all: I'm getting the same upload speed test results as on my private network. I read somewhere on the net that creating a virtual lan for that bridge fixes it, but it didn't help in my case.

    Here are some relevant screenshots:
    Bandwidth Limiter.png VLAN.png

    Any help is greatly appreciated.
    Alex
     
  2. shibby20

    shibby20 Network Guru Member

    RT-N18U + v121 = bw limit works correct. Maybe you have enabled CTF or QoS?
     
    alllexx likes this.
  3. alllexx

    alllexx Reformed Router Member

    Thank you for your reply, Shibby!
    It worked fine on RT-N66U too, but on ac68u it doesn't. The one thing I've noticed is that there's no imq module on ac68u (and maybe on other arm builds), and also no indication of starting imq driver in the logs. As I understand, it is required for limiting upload, and on RT-N66U there's always something like
    Code:
    Jan  1 02:00:50 unknown user.info kernel: IMQ starting with 2 devices...
    Jan  1 02:00:50 unknown user.info kernel: IMQ driver loaded successfully.
    Jan  1 02:00:50 unknown user.info kernel:     Hooking IMQ after NAT on PREROUTING.
    Jan  1 02:00:50 unknown user.info kernel:     Hooking IMQ before NAT on POSTROUTING.
    but nothing of the sort on RT-AC68U

    P.S. QoS is disabled, and where can I toggle CTF? Never used it before (though heard of it) and can't find it in the web ui
     
  4. shibby20

    shibby20 Network Guru Member

    RT-N18 i arm also. The same image is for n18 and ac68.

    Bw limiter in my tomato mod does not use Imq driver.
     
    alllexx likes this.
  5. alllexx

    alllexx Reformed Router Member

    Ah, I see. Thank you for the information! I'll try resetting settings to see if bw limiter will work then when I get back from vacation.

    Best regards,
    Alex
     
  6. alllexx

    alllexx Reformed Router Member

    While on vacation it dawned upon me that bw limiter could conflict with captive portal. After disabling captive portal, bw limiter works perfectly fine. Shibby, is it possible you could fix this conflict in the next releases?

    Thank you,
    Alex
     
  7. BrandonS

    BrandonS Network Newbie Member

    I can confirm this is also happening on my AC68u with 125. Once Captive Portal is turned off the upload limiter works properly again.
     
  8. Papka__

    Papka__ Addicted to LI Member

    RT-N16 on 131. Same problem with upload limit when Captive portal used. Is it possible to fix somehow?
     

Share This Page