1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Adding Linksys E-series Support

Discussion in 'Tomato Firmware' started by tvlz, Apr 29, 2012.

  1. tvlz

    tvlz Addicted to LI Member

    ** Now Supported **

    E1000v2/2.1: if flashing from stock firmware
    Cisco M10v2: if flashing from stock firmware
    E900:
    E1200v1:
    E1200v2: if flashing from stock firmware
    E1500:
    E1550:
    E2500: No 5GHZ
    E3200: No 5GHz

    I don't have any of them right now so I am looking for people who have them, know how to De-Brick and are willing to help.

    I'm willing buy routers if I can get enough donations to cover the cost if nobody that can De-Brick has that router model.
    Please add router model & version when you donate so I can add support for the most popular router first.

    https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=RCHUS94V2UURC
     
  2. tvlz

    tvlz Addicted to LI Member

    Bought a Linksys E-1500 and made a test build.
    Flashed successfully from stock firmware(ver 1.0.04 Build 2)- if you can't let me know.
    I have only done limited testing so if you try it let us know of any bugs.
    E1500screenshot.JPG

    E-1500 Test Build
     
  3. wik403

    wik403 Serious Server Member

    [/quote]
    Hi! I have LinksysE3200. Flashed latest Victek Tomato for E3200 - wifi work, wan/lan no. Also tried other Tomato firmware (E4200 and N10) for this router, flashed successfully and lan/wan no work. Guess that different hardware lan switch.
    I will test your build. Please make it.
    Thanks for your work.
     
  4. tvlz

    tvlz Addicted to LI Member

    Try this UNTESTED (** MAY BRICK ROUTER **)
    Removed link

    Give enough time for flash to complete (5 min), don't forget to erase nvram
    Post screenshot if it works and report bugs.
     
  5. shibby20

    shibby20 Network Guru Member

    @tvlz - nice work. I have planned add support for those routers but i haven`t any of them at the moment. I have a lot of Asus routers and i will add support for RT-N53 also.
    Can you send me PM with patch to add support for E1500. Thx.
     
  6. wik403

    wik403 Serious Server Member

    Hi! E3200 Test Build flashed, wifi work, lan port no. Attached screenshot and syslog.
    Thanks.

    PS. I successful bricked my E3200 router by flashing teaman firmware.
     

    Attached Files:

    • 1.png
      1.png
      File size:
      151.7 KB
      Views:
      298
    • syslog.txt
      File size:
      10.3 KB
      Views:
      104
  7. tvlz

    tvlz Addicted to LI Member

    New Test Builds to try

    Give enough time for flash to complete (5 min), don't forget to erase nvram
    Post screenshot if it works and report bugs.
    Looks like the same chips as E2500(5358U/43236)
     
  8. Daryl Martin

    Daryl Martin Serious Server Member

    I have a 2500, but no cable to debrick it & test. I am excited to see development continuing. I've used Tomato on my routers for years.
    Thanks everyone!!!!
     
  9. streppuiu

    streppuiu Networkin' Nut Member

    I have an e3200 and I am glad to see you are trying to add support for it.

    shibby20 or tvlz, please let me know how much does a (refurbed) e3200 cost in your country.

    Also, could you point me to a good debrick tutorial for e3200 ?
     
  10. tvlz

    tvlz Addicted to LI Member

    New test build for e3200, hopefully the lan ports work now

    About $65 - $70 USD for a refurb E3200
     
  11. lissny

    lissny Networkin' Nut Member

    does any tomato support quota system? bandwidth is already counted but to event and conditioned
     
  12. streppuiu

    streppuiu Networkin' Nut Member

    I'll see what I can do. Thanks for your work.

    I would like to know if the Tomato version that you are working on is a version of TomatoUSB and if it does actually have usb support. I am asking this because E3200 has usb and I can't see any "USB and NAS" menu option in the screenshot posted above by vik403. Thanks again.
     
  13. Ioana

    Ioana Serious Server Member

    Hello, I have a Linksys E3200. I would like to try your test build but I don't know how to unbrick my router should it be the case. I am very glad to see that E3200 has some chances to get TomatoUSB.
     
  14. tvlz

    tvlz Addicted to LI Member

    Important:
    If you have successfully flashed a test build and it works PLEASE post and let us know,
    Shibby wants to include working models in this next build

    Ioana,
    e3200
    debrick

    e3200 Usb support in code, not in test build(didn't make a usb build)
     
  15. lissny

    lissny Networkin' Nut Member

    E2500 works well.

    I think for e3200 "USB and NAS" menu options will be added in Final Stable version
     
  16. flashfart

    flashfart Serious Server Member

  17. Ioana

    Ioana Serious Server Member

    I just had a quick look at the E3200 debrick tutorials. Very interresting. I have some soldering experience to build the needed serial cable, I think I will give it a try in the weekend. Thank you, tvlz.
     
  18. Daryl Martin

    Daryl Martin Serious Server Member

    TVLZ screenshot.jpg TVLZ screenshot.jpg

    E2500 works here too! Nice job, tvlz!!!
     
  19. flashfart

    flashfart Serious Server Member

    E1500: Works, and has successfully moved about 1 GB data at very marginal signal strength in Wireless Client mode (no encryption). RSSI and noise floor often reported at same value, but connection does not drop. Chipset identifies as rev 2, otherwise same as tvlz's hardware described above. Quite impressed. Thanks!
     
  20. streppuiu

    streppuiu Networkin' Nut Member

    I just tested your latest build for E3200. After the flash the following are happening:

    0. I am able to connect both to LAN and WLAN
    1. The DHCP server is working both on LAN and WLAN. My Laptop receives an 192.168.1.X ip address and 192.168.1.1 gateway
    2. I am able to ping the router (192.168.1.1)
    3. When I try to access the web interface using LAN direct cable connection the browser sais "connecting to 192.168.1.1" and stays like that for a long time (2 mins maybe). Then it loads the Overview page. The same happens if I click another link in the menu, all pages load after a very long lag and sometimes they do not load completely
    4. Telnet works

    After a little cold sweating I managed to reflash the stock firmware using telnet. Here are 2 screenshots. Do you need anything else ? I can do it again and get the stuff you need. Maybe a dmesg.

    1.JPG 2.JPG
     
  21. Scott Ellis

    Scott Ellis Networkin' Nut Member

    E2500 works great (with the exception of the 5GHz radio, of course). Wireless Bridge, Client, and AP modes appear functional (tested bridged to an E3000 running TomatoUSB). Great job.
     
  22. lissny

    lissny Networkin' Nut Member

  23. lissny

    lissny Networkin' Nut Member

    how Can I flash E2500 with tomato-E2500USB-NVRAM60K-1.28.RT-N5x-MIPSR2-093-AIO.bin ??
    Because its size is 8.5 MB and E2500 have only 8 Mb Flash size.
    E2500 support only 8mb Flash memory. shibby should remove "USB and relative files" to make it compatiable. and light. because e2500 does not have any usb port. thanx
     
  24. maurer

    maurer LI Guru Member

  25. streppuiu

    streppuiu Networkin' Nut Member

    I tried again on my E3200 using tomato-E3200USB-NVRAM60K-1.28.RT-N5x-MIPSR2-093-BT-VPN.bin

    On my laptop the same lagging happened when I tried to use the web gui. But not on my other laptop. It seems I have something on my laptop that's blocking the access to the web gui. I disabled the firewall and still have problems.

    After lan and wan set up using the working laptop I tried a few things , including copying in the lan, wlan, wan connections, usb and everything is WORKING GREAT. I encountered no disconnections or other problems. Great job, congratulations. All other transfers, internet, ssh, telnet work perfectly from my laptop too, only the web gui doesn't work. Does anyone have any idea why ?

    The only thing that I wasn't able to run properly was the virtual wlan (which I know is experimental). My laptop could not connect to the second wireless net.

    By the way, what does "AIO", "Nocat" and "BT" mean in the name of the files ?

    Thank you people for the work you are doing.
     
  26. Python46

    Python46 Networkin' Nut Member

    AIO stands for 'All In One', Nocat is a Captive Portal, and BT stands for 'Bit Torrent'.
    Hope that helps.
     
  27. lissny

    lissny Networkin' Nut Member

  28. kthaddock

    kthaddock Network Guru Member

  29. wifiwire

    wifiwire Serious Server Member

    Can anyone explain me noob-proof what and how I flash this onto E3200? What build is recommended? (nocat, mega, aio??)
    I havent found any tutorial : (
     
  30. streppuiu

    streppuiu Networkin' Nut Member

    I have this strange problem with E3200.

    After using the web ui (or trying to use it, see above) putty won't connect to the router for ssh from that pc. And this happened when I used my other laptop too, the one that I am able to browse the web ui from. After a while, ssh conectivity comes back. Browsing the Internet still works.
     
  31. streppuiu

    streppuiu Networkin' Nut Member

    wifiwire,

    1. Download one of the firmwares that have e3200 in their name from this page:
    http://tomato.groov.pl/index.php?dir=K26RT-N/build5x-093-EN/Linksys E-series (experimental)

    2. Do a 30/30/30 reset:
    http://www.dd-wrt.com/wiki/index.php/Hard_reset_or_30/30/30

    3. Go to the web ui of your router and authenticate when required (user:admin, passw:admin):
    http://192.168.1.1

    4. Go to Administration > Firmware update

    5. Select the file you just downloaded

    6. Hit Update

    7. Wait 5 minutes

    8. Do a 30/30/30 reset

    9. Go to your new web ui and auth (user:root, passw:admin or root):
    http://192.168.1.1
     
    lepa71, oyxhvv and wifiwire like this.
  32. wifiwire

    wifiwire Serious Server Member

    thank you :=) I will try this later today :)
     
  33. wifiwire

    wifiwire Serious Server Member

    it woooooooooooorks!!!!11 Thanks steppuiu, I straight followed your guide, was sure I bricked as web interface didnt work with firefox, but with IE9 I could configure WiFi, works like a charm so far :)) I´m very happy now........my parents would have been very angry if I bricked the router by trying out unofficial firmwares xD
     
  34. oyxhvv

    oyxhvv Serious Server Member

    thx a lot ya! follow ur steps I've finish flashing my E3200 with tomato firmware,wait for this day long!!!Cheers!:)))))
     
  35. lissny

    lissny Networkin' Nut Member

    its working here fine..
    i have some trouble with some wireless users. they use router and change their mac to any permitted mac user , they are accessing my net free.
    Any suggestion?
     

    Attached Files:

  36. Python46

    Python46 Networkin' Nut Member

    E1200 v2 does not have usb. Please adjust the builds with that in mind.
    Thanks
     
  37. dusti08

    dusti08 Networkin' Nut Member

  38. Daryl Martin

    Daryl Martin Serious Server Member

  39. tvlz

    tvlz Addicted to LI Member

    dusti08,
    Flashing from stock linksys firmware?

    Try this modified build, hopefully it should flash successfully.

    Use either "0" or "60", no increase in signal by going higher.
     
  40. callous

    callous Network Guru Member


    How do i flash back to the linksys firmware once i flash to this alpha version of Tomato?
     
  41. kthaddock

    kthaddock Network Guru Member

    I think the best thing to do is to setup nocat and let users use USER / PASSWORD
     
  42. tvlz

    tvlz Addicted to LI Member

    callous,
    That build was for that specific issue that dusti08 was having flashing his E2500 from stock firmware, if you are having the same problem and have an E2500(that build is for E2500 only!) feel free to try the modified build.
     
  43. lissny

    lissny Networkin' Nut Member

    how to use No CAT ? if i have installed it than where to go to set user and passwords
     
  44. dusti08

    dusti08 Networkin' Nut Member

    Thanks tvlz, got same upgrade fail error at 12% mark with the modified build.
     
  45. frankindevil

    frankindevil Serious Server Member

    just got an E3200 yesterday and flashed AIO version. Was about to configure transmission setup. I have split two partitions. one is for download, one is SWAP. After I configure the setup. please check screenshots. the problem is the GUI of transmission can not be opened. Not sure if its the problem of configuration. please help find out. thanks alot.

    1.jpg

    22.jpg

    33.jpg


    UPDATE: right now i can access the login screen. i have changed several times of the login passwords. but all failed. anybody knows the default password for TR?

    [​IMG]

    [​IMG]

    UPDATE2: I CHANGED the ID/pw as root/root. vola! done!. case CLOSED.thanks anyway.
     
  46. callous

    callous Network Guru Member

    Any word on whether e3200 likely will have 5ghz support? It's been months and Im beginning to think despite having someone finding the drivers the e2500 for a similar chip, that they ran into some unsurmountable issue.

    Would great to let us know - some people are sitting on the fence whether to buy the e3200 or not
     
  47. tvlz

    tvlz Addicted to LI Member

    Eventually it will be supported
    Time, know how, my lack of interest in 5Ghz, but most importantly no donations:rolleyes:!
     
  48. lissny

    lissny Networkin' Nut Member

    there is no e2500 "NO cat"
    by shibby in 095 version
    >????
     
  49. ardanzhu

    ardanzhu Serious Server Member

    This is a good news!!
     
  50. callous

    callous Network Guru Member

  51. fuzinc

    fuzinc Serious Server Member

    Is IPv6 supported in AIO?
     
  52. lissny

    lissny Networkin' Nut Member

    yes dear AIO have support for IP 6
     
  53. coffeeborg

    coffeeborg Network Guru Member

    Hi

    Will there be an AIO build of 1.01 (tomato-E3200USB-NVRAM60K-1.28.RT-N5x-MIPSR2-101-AIO.bin)?

    Thanks
     
  54. lefty

    lefty Networkin' Nut Member

    A few things i wanted to note about the E1550 and E900:

    E1550 - if you erase nvram from the shell or from the webgui, and the unit reboots, after the reboot you have totally power cycle the unit, otherwise it won't be able to be accessed, and this is setting a static IP or no static IP, doesn't matter, you still have to totally power cycle the unit. And this is a must on tomato or dd-wrt, both behave this same way. Another good tidbit, this unit is overclockable, how fast? Not sure, but i have ran mine for 2 weeks now @ 400Mhz (default is 300Mhz) and it seems to be doing fine with no extra heat, this unit runs cool in general compared to my E2000 or E3000. Awesome!

    E900 - i read alot of reports about this unit not working correctly with comcast cable, most people claiming that they have to disable WMM in order for this to work with their comcast cable, effectively reducing the unit to a G router, well i have comcast 'blast' (50mbit down) and i can safely say, atleast on tomato, i don't have this problem with this unit, infact it connects @ HT40 300mbps link rate with no problems for me (alot of people claimed they couldn't get more than a 64mbps link rate) but like i said, this could be due in fact that i am not running stock firmware on mine. *shrugs* Also, this unit is NOT overclockable, you can nvram set clkfreq= all you want, and it will not accept the input values, it doesn't brick the unit or error out, it just doesn't take the settings. So it would appear hardware locked at 300Mhz. Still a good unit for $20 refurb. :)

    And one last thing i noticed about these E-Series units in general, so far, the mac address on the sticker of the unit ends up being the LAN mac addy when flashed with tomato or dd-wrt. With my E2000, E3000, and E900 this is infact the case, with the E1550 the mac addy on the sticker of the unit ends up being the WAN mac instead of the LAN mac. Not sure that matters much, but just something i noticed.

    Thanks to those that added support for these E-Series units with tomato!
     
  55. dc361

    dc361 LI Guru Member

    I'll add my thanks as well for the support. During my testing I found the E900 to be excellent with Tomato -- I have been using Shibby's 'MAX' build on my units. I can also say that I get 300mb/s link rates and with my test unit at work I've been able to get great throughput both on wireless and wired.
     
  56. lefty

    lefty Networkin' Nut Member

    Yes it would be nice if more people would donate to the cause, i did to tvlz, shibby, and toastman to show thanks for great work. But namely to tvlz, he seems to be the main one responsible for getting the port to these units, so donations and kudos to him!
     
  57. lefty

    lefty Networkin' Nut Member

    Correction and oversight on my part, scratch my last posting about the mac address, the mac addy on the sticker of the E900 is the wan mac address as well.
     
  58. wurst0815

    wurst0815 Serious Server Member

    Also a very big thank you from my side!
    My E3200 works very well (and stable!!!) with Tomato Firmware 1.28.0000 MIPSR2-102 K26 USB Mega-VPN unlike DD-WRT does.
    5GHz Support would be very appreciated because of the lack of free channels in 2.4 GHz.
     
  59. Benzy

    Benzy Serious Server Member

    Any news on E3200 and 5GHz support yet?
     
  60. tvlz

    tvlz Addicted to LI Member

    Very soon, I've been working will Shibby on a test builds for E2500 almost finished, after that the E3200 should work too, hopefully
     
  61. shibby20

    shibby20 Network Guru Member

    E3200 = E2500 + 16MB of flash + USB port + gigabit.. Am i right? If i am, then i can make a test build with 5GHz module.
     
  62. callous

    callous Network Guru Member

  63. lefty

    lefty Networkin' Nut Member

    Not sure that it would matter but the difference is the CPU, E3200=BCM5357 and E2500=BCM5358U
    AFAIK these chips are almost all detected as a 5357 because they are part of the 53xx BCM family of SoC.
     
  64. ValiE

    ValiE Serious Server Member

    Hi,
    I'm currently have some strange issues with my E3200 running TomatoUSB
    Current Version: 1.28.0000 MIPSR2-104 K26 USB
    The problem is that, after configuring some basic settings (WAN and wireless), if I'm rebooting the router, my 5GHz section disappear : from router config section and also the 5GHz SSID. If I restore the router to factory settings and reconfig basic parameters, same behavior : I can see the 5GHz SSID, can connect to it but ... After reboot the 5GHz part is missing.
     
  65. shibby20

    shibby20 Network Guru Member

    can you show me result of:
    nvram show | grep eth

    after reboot (when you haven`t 5GHz part)?
     
  66. ValiE

    ValiE Serious Server Member

    Tomato v1.28.0000 MIPSR2-104 K26 USB AIO
    root@LinksysE3200-Tomato:/tmp/home/root# nvram show | grep eth
    lan_ifnames=vlan1 eth1 eth2
    wl0_ifname=eth1
    wl1_ifname=eth2
    wl_ifname=eth1
     
  67. shibby20

    shibby20 Network Guru Member

    looks good. Show me also "nvram show | grep landevs"
     
  68. ValiE

    ValiE Serious Server Member

    Thanks Shibby. Yesterday I've made a clear NVRAM using 30/30/30 hard reset procedure and not the procedure from WEB page with erase NVRAM as I use to follow. After this, I was able to reconfig the router and after a number of reboots, the 5GHz part is still in place.
    Is somehow strange as in the update process (DDWRT -> Linksys firmware -> TomatoUSB) I used the same 30/30/30 nvram erase. Maybe after updating to Tomato the erase Nvram step didn't worked ... Who knows?
    Thanks again for your help
     
  69. chadw01

    chadw01 Serious Server Member

    Hi all,

    Just picked up a Cisco Valet M10 v2 and was wondering if there was a Tomato build out yet for this that supports OpenVPN?

    Thanks!
     
  70. huibuh

    huibuh Reformed Router Member

    It is done :)

    You can flash the tomato firmware on the Linksys Cisco E3200 right out of the Linksys stock firmware web gui.
    NO NEED TO PRE FLASH ITWITH A DD WRT trailed initial build....

    And the complete process hardly took 10 minutes ;-)

    Dualband Wlan works fine with Shibbys build ( no issues here with the 5Ghz band ! )


    Howto:

    1. Download one of the firmwares that have e3200 in their name from this page:
    http://tomato.groov.pl/download/K26RT-N/build5x-108-EN/Linksys%20E-series/

    I used „tomato-E3200USB-NVRAM60K-1.28.RT-N5x-MIPSR2-108-AIO.bin“

    2. Do a 30/30/30 reset:
    To do a 30-30-30 reset you must push the reset button with your router powered on. Hold it for 30 seconds with the router powered on. STILL holding it, pull the power cord for 30 seconds. Still holding it, plug the power back into your router and continue to hold the reset button for 30 more seconds. You will have held the button for a full 90 seconds without releasing it.
    Be warned: 30-30-30 resets are done on the Linksys E3200 via the red reset-button on the bottom of the device AND UNPLUGGED LAN Cables/Wan cables - so ONLY power cord is plugged in the router.

    3. Go to the web ui of your router and authenticate when required (user:admin,or blank, passw:admin):
    http://192.168.1.1

    4. Go to Administration > Firmware update

    5. Select the file you just downloaded

    6. Hit Update

    7. Wait 5 minutes

    8. Do a 30/30/30 reset

    9. Go to your new web ui and auth (user:root, passw:admin or root):
    http://192.168.1.1

    10. I could not reach the tomato web ui at this point so i unplugged and replugged the powercord of the E3200 router at this point – After 1 powercycle and a 5 min wait all was well and i could log into tomato just fine.
     
  71. tmparisi

    tmparisi Reformed Router Member

    Hi All,

    I just purchased a E3200 and currently have DD-WRT installed. I am having quite the difficult time with USB support and am considering switching to TomatoUSB. This is primarily because of the following listed supporting items:

    • NAS support: external USB storage, with file sharing on LAN and WAN (supports FAT/FAT32, EXT2/EXT3 and NTFS)
    • Media server DLNA
    I need to hook a USB HDD to my E3200 and access it via UPnP or DLNA with a media player. Are these functionalities available in the E3200 experimental build?
     
  72. Victek

    Victek Network Guru Member

  73. mythboy

    mythboy Reformed Router Member

    Thank you! I can't flash from the stock firmware of M10v2. Now I will try the bin provided here to initial flash!
     
  74. Magdiel1975

    Magdiel1975 Networkin' Nut Member

    Hi guys..
    I know this thread is old.. but I have not been able to flash Tomato on my e2500 v3.. I have tried different versions and all I get is an error.."Upgrade Failed"
    I've tried
    tomato-E2500-NVRAM60K-1.28.RT-N5x-MIPSR2-121-Max
    tomato-E2500-NVRAM60K-1.28.RT-N5x-MIPSR2-128-Max
    tomato-K26-1.28.RT-MIPSR2-115-Max

    None work.. is there anything I need to do before flashing from stock?

    thanks.
     
  75. Katjubu

    Katjubu Network Newbie Member

    First thing that comes to mind: you did try the...

    tomato-E2500v3USB-NVRAM60K-1.28.RT-N5x-MIPSR2-128-Mega-VPN

    ...build right if you have a v3 ?
     
  76. Magdiel1975

    Magdiel1975 Networkin' Nut Member

    I finally got it to flash.. Yes, I had to flash DDWRT first, but I tried a couple of versions before I was able to flash ddwrt...I can't remember if it was that one, but now I was able to flash Shibby Tomato latest build.. it's working great :) - thanks.

    ***I used this one.. dd-wrt.v24-23569_NEWD-2_K2.6_mini-e2500V3*** which is the only one that worked for me.
     
    Last edited: Apr 10, 2015

Share This Page