1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Admin Interface Remote Access - Cannot Get It To Work

Discussion in 'Tomato Firmware' started by EViS, Jan 8, 2012.

  1. EViS

    EViS Networkin' Nut Member

    I am trying to get remote access to work so that I can access the tomato v1.28 interface from outside my network.

    So far I have enabled 'Allow Wireless Access' under 'Web Admin' and set the HTTP port to 1234. I have also forwarded Ext Port 1234 to Int Port 80 at Int Address 192.168.1.1.

    Trying to access the router with http://ipaddress:1234 from inside the network brings up the Tomato login box. However, doing the same from outside the network results in a 'Web page not available' error.

    What other details should I provide you guys to help me diagnose where I am going wrong and why remote access is not working for me?
     
  2. Toastman

    Toastman Super Moderator Staff Member Member

    Did you check the box "Allow remote access" and change the port there? Or are you trying to use the local access?
     
  3. EViS

    EViS Networkin' Nut Member

    Local access works when I point my browser to the local router IP of 192.168.1.1 or the DDNS address of example.ddns.com:1234.

    I am trying to get remote access working and when I point a remote browser to example.ddns.com:1234 or ip.add.re.ss:1234, nothing comes up.

    Under Administration > Admin Access > Web Admin, I have the following setttings:

    Remote Access: HTTP
    Port: 1234
    Allow Wireless Access: checked

    Under Port Forwarding I have the following settings:

    Proto: Both
    Src Address: /blank/
    Ext Ports: 1234
    Int Port: 80
    Int Address: 192.168.1.1

    Where is the setting for "Allow Remote Access"? Or do you mean "Allow Wireless Access"?
     
  4. Toink

    Toink Network Guru Member

    Do you really have to use port 1234? Why not try another port?
     
  5. EViS

    EViS Networkin' Nut Member

    No, I will also change to HTTPS afterwards. Just trying to get remote access to work firstly. I have also tried ports 5566 and 8080, all to no avail. I must be missing a setting somewhere?
     
  6. Toink

    Toink Network Guru Member

    Try to reboot the router as soon as you set the ports in port forwarding and the remote admin. And make sure you dont have the 'Admin restrictions' ( in Admin Access Tab) enabled. And make sure you have the correct IP address or use a DNS server
     
  7. fubdap

    fubdap Addicted to LI Member

    Just above "allow wireless access" there is "Remote Access". It is drop-down menu where you select either "disabled", "HTTP" or "HTTPS".
     
  8. EViS

    EViS Networkin' Nut Member

    I have rebooted countless times (again now), admin restrictions does not have any boxes checked and I have tried to connect remotely using the correct IP address and a DNS server.

    Any other thoughts? (thanks for the help so far chaps).
     
  9. mvsgeek

    mvsgeek Addicted to LI Member

    Couldn't be anything as obvious as a firewall blocking port 1234?
    Since local access works, you could always try connecting to the local PC with RDP or VNC for example, and then accessing the router from there. A devious kludge I'll admit, but I've resorted to it.
     
  10. Toastman

    Toastman Super Moderator Staff Member Member

    I'm really confused as to what you are doing here.

    Try this. Set everything back to the default settings. Then check the "enable remote access" box - don't change the port which is 8080 by default. Now from OUTSIDE your home, try http://ipaddress.whateverdns.com:8080

    If that doesn't work, then you have some other problem.
     
  11. Toink

    Toink Network Guru Member

    EViS, are you connected on a wired DSL/Cable or via a wireless internet? If it's a wireless internet connection (Wimax, HSDPA+, WCDMA, etc), then this will not work.
     
  12. EViS

    EViS Networkin' Nut Member

    To clarify, I am wanting to access the Router (admin interface) from any computer OUTSIDE of my LAN.

    So far within the LAN, on any computer, I can access the Router either with it's LAN IP of 192.168.1.1 or the DDNS address I have setup of http://ipaddress.whateverdns.com:1234. This DDNS address will be used to access the router remotely from outside of the LAN.

    I am not wanting to access any computers' desktop within the LAN. I only require access to the router's admin page to then WOL a computer.

    The LAN is connected to the Internet via a Cable connection. However, I am testing to see whether remote access is working from the browser on my Android phone which has a HSDPA connection. Toink, you say that this may be the problem? Why would this be the problem?
     
  13. Toink

    Toink Network Guru Member

    Hmm... If your router is connected to a wired modem. Then there shouldn't be any problem at all. It's just a matter of correctly configuring your router (enabling remote access, port forwarding the port to the router's IP, etc.)

    Anyways, you seem to have this setup. Which should've worked by now if you setup your router correctly... Would it hurt if you completely hard reset your router and start from there? Have you tried Toastman's suggestion of using port 8080 yet and see if it goes through?

    I only mentioned about the wireless DSL connection because those type of DSL connection are normally behind a proxy therefore port-forwarding doesn't work.

    Have you checked your modem's firewall / NAT settings?
     
  14. gfunkdave

    gfunkdave LI Guru Member

    I suspect that your problem is in the port forwarding. You should not need to forward ports. Delete the port forwarding rule you've created. Then go to Administration --> Admin Access and change Remote Access to HTTP or HTTPS. Use any port you like. It should work.

    Make sure that your DDNS provider has an accurate current IP for you, as well.
     
  15. EViS

    EViS Networkin' Nut Member

    Bizarre. I physically unplugged the router and modem as opposed to "Rebooting" it via the tomato interface. And I can connect remotely. Thanks for all the help fellas :).

    Now that this is working, is there anyway I can streamline WOL a PC on the LAN? At the moment I have to login to the tomato interface, got to Tools and then click on the computer. Anyway I can include all of these steps in one URL which I can bookmark in my Android phone? Or maybe some sort of Android WOL app?
     
  16. gfunkdave

    gfunkdave LI Guru Member

    Yeah, the Tomato "reboot" option doesn't seem to truly reboot the router. I don't know quite what it does.

    WOL in Tomato just sends a standard wake-on-LAN magic packet. Here is a nice writeup on how to wake your machine using an iOS app, without needing to log in to the router:

    http://www.justinmontgomery.com/wake-on-lan-configuring-your-pc-tomato-iphone

    I assume there are similar Android apps out there.
     
  17. Eri

    Eri Serious Server Member

    Sir, what is ipaddress should be typed ?
    is it LAN Router Address or WAN address?

    Thanks for replying.
     
  18. Eri

    Eri Serious Server Member

    Hey i could figure it out.
    It works for me.

    The mentioned IP is our IP that is assigned by our DNS provider ( i use openDNS), if we could set it up correctly in our router.
     

Share This Page