1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ADSL2MUE EU Firmware v4.22 beta

Discussion in 'Other Linksys Equipment' started by Toxic, Apr 12, 2006.

  1. Toxic

    Toxic Administrator Staff Member

    S/W 4.22-xx beta release notes

    1. Fixed LLC/VC cannot be modified in RFC 1483 Routed mode.
    2. Re-setting PPPoA mode in VC.

    S/W 4.21-xx release notes

    1. Added RFC 1483 Routed Mode in Encapsulation selection.
    2. Fixed LED abnormal behivor for LAN one.(That is not competible for nsp3.50 setting).
    3. Fixed Bridged Mode Only cannot be connected to CO side issue.

    S/W 4.20-xx release notes

    1. Fixed setting to PPPoA mode first time cannot get Internet gateway address when reset to default.

    S/W 4.19-xx release notes

    1. Fixed Mac Address displayed in webpage issue.
    2. Added Checking Username and Password are more than or equal to 4 characters in "Adminmanage page".

    get it ADSL2MUE v4.22 EU firmware

    use at own descretion

    read the upgrade documentation first

    http://www.linksysinfo.co.uk/files/Upgrade procedure ADSL2MUE Firmware.doc
  2. R0ut3r

    R0ut3r Network Guru Member

    ty toxic, one prob solved :)

    the 4.19 drop the conn and hangs, the 2.17 drop the connection (about every 24 hours) but reconnect itself without turn off the adsl2mue
    later i'll try this one
    edit: hmmm there are 3 files.. how to flash ?
    after the launch i'll give a look ..........
  3. R0ut3r

    R0ut3r Network Guru Member

    the bin file is identical with the one present in the 41.9uk
    so, i think, i can flash with the bin and smaller img file, or use only the bigger img file
    flashing.... :eek:
  4. Toxic

    Toxic Administrator Staff Member

    tbh i dont know, this was grabbed from a beta source.
  5. R0ut3r

    R0ut3r Network Guru Member

    works.. but seems there some dhcp problem
    i use the adsl2mue connected to a wrt
    initially i have big problem to see the adsl2mue http interface between the wrt, partially solved activating.. and deactivating th dhcp server :eek:

    now i'm connected with the 4.22 :D
    ty toxic
    one week and i can says if it's stable or not :)
  6. R0ut3r

    R0ut3r Network Guru Member

    one question: the log is full of "manager_get_defaults - !node"
    what's means?
  7. Toxic

    Toxic Administrator Staff Member

    Ok I now have an upgrade document from linksys

    Upgrade doc

    i have also added this to the firmware archive as well.
  8. R0ut3r

    R0ut3r Network Guru Member

    i add my try not in the doc:
    from the 2.17 i have used the same method showed for the 4.12
  9. R0ut3r

    R0ut3r Network Guru Member

    better than 4.19
    SEEMS to be stable :)
    ty again :cheering:

    edit: i haven't tryed the other one with the rfc-routed yet...
  10. ccc36

    ccc36 Network Guru Member

    Can this firmware be installed in the Australia machine?
    Thanks! :thumb:
  11. falcon56

    falcon56 Network Guru Member

    thanks i try this ;)
  12. cgondo

    cgondo Network Guru Member

    anyone tried this on the Austalian modem?
  13. ccc36

    ccc36 Network Guru Member

    I did not try this on the Australian modem. I am not so brave. Now, I am fighting with linksys ANZ support, because he said I should have "NAT" function in the "Setup" option. Actually, there is not. :thumbdown: . I am really worry about my ADSL2MUE, because it is a pure modem but it is not open all the ports. Nothing can do on it.
  14. lostsoul

    lostsoul Network Guru Member

    i have a adsl2mue (4.12-EU stock) with 4.17-TI firmware.. and sometimes i got lost signal on adsl, reboot the modem and everything works fine... the 4.22 firm solve this problem? since i have 4.17-TI which procedure use? the 4.22 is like 4.17-TI ?
  15. Patego

    Patego LI Guru Member

    hi guys,

    I recently upgrade my 4.12 EU version modem to the 4.22, and now I can't get a stable connection, it hangs every 5 or 6 minutes. So I went to the livechat at linksys support page.

    The guy told me that this is a third-party firmware, that linksys does not have any firmware available to this device, and because I just upgraded my modem to this version, I can't go back anymore.

    So I have some questions,
    - how can I get an adsl2+ connection with the original 4.12 firmware? (it says on the package that this is an adsl2+ modem)

    - how come that is not any firmware available for this device not even the original one?

    - I do not understan why I can't go back to an original firmware like the guy said (I guess it's because there isn't any!)

    PS: the connection hang problem I have just happens with this crappy modem. I just bought an 15 euro modem and it works great, not like this very expensive peace of crap from linksys!
  16. FiveHorse

    FiveHorse Network Guru Member

    can we get round the NAT / firewall in the new 4.22 firmware?

    im currently using the 2.17TI firmware to enable blanket port forwarding on the modem
  17. kalvin

    kalvin LI Guru Member

    When I update firmware I see "Status: Unable to write to MTD block device"
    What is wrong?
  18. mstombs

    mstombs Network Guru Member

    I'm bumping this thread 'coz I've noticed that an older version 4.19 was put into the downloads section with no release notes at the end of last year. The release notes for 4.19 and 20,21 and 22 are in this post.

    Can these files be linked in the downloads section of linksysinfo - then you can delete this post and put this thread back to rest!
  19. eddietah

    eddietah Addicted to LI Member

    does this firmware support ADSL2+
  20. mstombs

    mstombs Network Guru Member

    Yes 4.22 is ADSL2+ capable, but some folk find it needs a heftier PSU 5V 2A rather than the poorly regulated 5V 1A supplied.

    Its also using 4 year old V4 drivers I recall, the latest ones that work with the hardware are V7.03, available in RouterTech 3rd party firmware which supports this router.
  21. eddietah

    eddietah Addicted to LI Member

    so if i'm using third party firmware. do i need to flash back to the official linksys firmware 4.12 or 4.19 first before i flash to this 4.22 firmware? thanks in advance.
  22. mstombs

    mstombs Network Guru Member

    4.12 was never available from Linksys for download, so not really an option. If you are using the old 2.17Ti (older than 4.12 but has more useful web UI) you should be able to upgrade to 4.22 carefully following the 2-step instructions in the 4.22 instructions:- this loads an interim firmware which knows how to load the more modern "single image" firmwares.

    And then from 4.22 you can web upgrade to RouterTech which will give you back the 2.17Ti web screen etc.
  23. BrokenModem

    BrokenModem Addicted to LI Member

    Just tried the 4.22 Firmware (originally 4.12 UK) but was unable to load the second file. Said it was the wrong checksum (or something like that). Now I get the dreaded red light - any ideas as to how I should fix and what files I should use? Thanks.
  24. mstombs

    mstombs Network Guru Member

    You probably now have a router that doesn't boot Linux, but the bootloader should be OK. Have a look at the de-bricking guides over on RouterTech.org. You can re-load firmware using a quirky old Ti PC application (sometimes called adam2app) referred to as PC-Tool. This provides a front end to plain ftp commands to the bootloader, and also calculates the filesystem offsets and sets the mtd variables, which have to be correct for the firmware you intend to run.
  25. BrokenModem

    BrokenModem Addicted to LI Member

    Thanks for the info. I was able to access the modem using the TI PC app you described. Non of the Linksys firmware's I could find would recover the modem but I was able to load the latest RouterTech version which seems to work OK. Thanks again.

Share This Page