1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ADSL2MUE Modem issues

Discussion in 'General Discussion' started by matt_je, May 15, 2005.

  1. matt_je

    matt_je Network Guru Member

    Hi All

    I have just purchased the above modem as a replacement to a fault d-link modem. The problem I am having is that I am running a website from my machine and I am now unable to access it from outside my network. From reading post on this site and other information on the net the modem is not just a modem but infact does some basic routing.

    How can i get round this. The modem plug directly in to a wirless router with port 80 forwarded to my local machine but I don't get past the modem. If I put the modem into Bridge mode then I can't access the net all.

    Am I missing something ??
     
  2. Old_Nick

    Old_Nick Guest

    Hi

    I had this problem when I recently moved from a cable ISP to ADSL. As you correctly stated, the 2MUE functions as a very basic router as well as just an ADSL modem - essentially it filters on inbound traffic on all ports - not much help if you want to run services behind it!

    I'm guessing your ADSL ISP runs either PPPoe or PPPoA (i.e. they have given you a username and password which you entered into the web interface on the 2MUE). The trick is to reconfigure the modem into 'Bridged-Only' mode - you find this on the main modem web page, and put your wireless router into PPPoE mode instead. Then enter the username and password into the router's configuration pages (it doesn't seem to matter if your ISP uses PPPoA, not PPPoE - mine does and it still works fine)

    In Bridged Mode, the modem is basically transparent - all it does is turn ADSL traffic into ethernet packets and forward them to the router. If your setup was anything like mine (ADSL2MUE connected to WRT54G), you will have found that you couldn't plug the 2MUE into the 54G's WAN port with the modem in PPPoE/A mode - you had to connect it to one of the LAN ports instead. In Bridged Mode you connect the modem to the WAN port as you would expect - it makes a lot more sense!

    The 2MUE still requires an IP in this configuration, which must obviously be different to your router's IP. The only sticking point is that, once you've put the modem into bridged mode, its web pages will not be accessible from machines behind the router - you'll have to plug a laptop directly into the modem in order to access its web pages. I'm told you can get round this by putting the modem and the router on separate subnets (i.e. 192.168.0.1 and 192.168.1.1), but the bridged configuration makes accessing the modem's web interface largely unnecessary anyway (the external IP details, uptime and connect/disconnect buttons for the PPPoE/A connection appear on the router's web pages anyway)

    This setup works fine for me - I run web and secure shell VPN on a mini linux box behind my router with no trouble at all (except for dynamic IP changes which you can get round using dyndns.org and a background update script). Just remember to set the keep-alive time on the router's PPPoE settings, or your link will drop after a period of inactivity, and you'll lose your IP!

    Enjoy
     
  3. matt_je

    matt_je Network Guru Member

    Hi

    I have tried what you suggested but I still can't get this to work. I put the modem in to bridge mode and set my router PPPoE with my username password. But nothing !

    Any more ideas on what i could be doing wrong !

    not sure if thus would make much differance but it a d-link DI-624 wireless router
     
  4. gnomeza

    gnomeza Guest

    Ugh, another "me too!" post but:

    I purchased the ADSL2MUE to use with my ATM-based ADSL service.
    I configured the modem in Bridged Only mode and connected to it with PPPoE set up on the router. The connection times out.

    My understanding of PPPoE to PPPoA bridging isn't all that good, but how can you connect to the modem to configure it if it isn't supposed to have an IP address? It's supposed to be transparent right?

    I don't count connecting to the modem's USB port. We're Windows-free here so whether it's even possible to configure the modem through USB with generic drivers remains to be seen (I haven't yet tried to get a serial console on the USB device).

    The ADSL2MUE is an interesting little linux box anyway (Montevista w/2.4.17 kernel on a
    MIPS 4KEc) and shows great potential. I'm hoping I'll be able to get more detailed logging info from it to debug the PPPoE/PPPoA problem.

    In the meantime, any useful hints would be welcome...

    - Mark
     
  5. DocLarge

    DocLarge Super Moderator Staff Member Member

    Hi guys, let me save you some time.

    Bridging the adsl2mue is "not" going to work because bridging it now means that the device behind it will have to handle all PPPoA traffic. I "just" went through this a few months ago after first coming over to England from the U.S.A.. The adsl2mue is advertised as being "just" a modem, but as you've figured out, it's the lowest modem/router device that's sold overseas by Linksys. Any device behind the adsl2mue that needs a PPPoE connection ain't firing up behind that brick...

    So, here's your two choices:

    1) Purchase the WAG54G with ver 1.01.06 (this is what I bought first and I had "NO PROBLEMS). I was able to do port forwarding (big complaint about this device), ftp, and VPN was solid! with the greenbow client, and the web interface was accessible from anywhere.

    2) Purchase the x-modem ce from adslnation.com. Check out this link for some additional info (http://www.adslnation.com/products/xmodem-ce.php) This little device is the "shit," and it's what I'm using now. This adsl modem is predominantly used by MAC users, but since it makes an ethernet connection on the backside with any PPPoE capable device, you'll be able to use your ethernet device without fail.

    I have no complaints about the x-modem ce. I brought my linksys wrv54g wireless router (50 VPN tunnels [100 with quickvpn license upgrade] SPI Firewall, WPA-PSK, WPA Radius, Radius, WEP) over from the states and had to sideline it initially when I was going through the process of finding a suitable modem to make the connection (I was on cable modem back in the states.) The adsl2mue was garbage (no port forwarding), and the wag54g was great, but didn't have enough vpn tunnels (only 5).

    Long story short, I bought the x-modem and I've been able to use my wrv54g without incident, so the solution to your problem may be finding an adsl modem similar to the x-modem that does PPPoE.

    Doc

    Oh, forgot the most important part; with the x-modem ce, the ip address assigned to it is "TRANSPARENT" to "all" devices on its segment!

    http://www.adslnation.com/products/xcespec.php
     
  6. exxos77

    exxos77 Network Guru Member

    If your modem works in PPPoA or PPPoE mode but doesn't in Bridged-only mode, make sure your ADSL line variables (VPI, VCI and encapsulation) are the same in Bridged-only mode as the (working) ones you have in PPPoA or PPPoE mode.

    I know it sounds stupid, but the modem doesn't keep these options from one mode to the other.
     

Share This Page