1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AdvancedTomato - new GUI based on Shibby's mods

Discussion in 'Tomato Firmware' started by Jacky444, Mar 20, 2013.

  1. 56kb

    56kb Addicted to LI Member

    Thanks I love AT:)
     
  2. scoobynz

    scoobynz Serious Server Member

    I would like to say that I was initially drawn to dd-wrt because the interface was more polished / professional and imo easier to navigate than Tomato. Of course, it was so unstable that I soon migrated onto and stuck with Tomato. That said, I think this interface brings the polish and professionalism to Tomato, so thank-you very much for your work.
     
    nick ant0ny likes this.
  3. nick ant0ny

    nick ant0ny Networkin' Nut Member

    All i can say, jacky444 great work! Really thank you and shibby for your efforts and time you spend on these images! Wish you all the best to both ;)
     
  4. krism75

    krism75 Serious Server Member

    I flashed you latest version, but when using my Samsung S3 the menu's weren't working.
    Clicking on a menu-item didn't doe anything. Any idea what the problem can be?

    I noticed in your screenshosts, that you have en AT - theme, which I don't have in the list. Can this be the problem?

    Otherwise, nice job!
     
  5. bdf0506

    bdf0506 Serious Server Member

    I upgraded my E3000 router just now to 1.28.0000 MIPSR2-1.09.10 K26 USB Big-VPN. Took a few minutes longer than usual to flash, but it's loaded now.
    On the build notes, you mention that you fixed the issue with mobile devices not showing subcategories, but it doesn't work correctly. On an iOS device running Safari and Chrome, I was able to get it to behave once in each browser, but most times you tap the main category and nothing happens. Before this release, usually you would tap it and it would load the main page of that category and that was it. It appears that when you click the category it tries to load or take you somewhere, but it just doesn't work as it should. Let me know if I can help at all to fix it...
     
  6. tinyema

    tinyema Reformed Router Member

    Hi jacky444 great work! I like it VERY much! ;)
    I flashed 1.9.10 AIO on my RT-16 and I see that there's a little bug: I have QoS enabled, but under QoS > View Details it says "QoS is disabled >> Enable.

    Thanks.

    Ciao
    ema
     
  7. KamilJ

    KamilJ Reformed Router Member

    Jacky can you compile a version with new wifi drivers from Shibby repo and new build based on Toastman tomato?
     
    uboot likes this.
  8. fearz

    fearz Serious Server Member

    Does this version include the new wifi drivers?


     
  9. kthaddock

    kthaddock Network Guru Member

    check with "wl ver"
     
  10. KamilJ

    KamilJ Reformed Router Member

    @fearz
    I think not...
     
  11. kthaddock

    kthaddock Network Guru Member

    Then you have to live in the dark without knowing. :eek:
     
  12. Kim K

    Kim K Serious Server Member

    I asked earlier about having a version that doesn't require flashing, but I wanted to upgrade to Shibby 110 so I took the plunge and went the AT route today.

    Just wanted to say thank you Jacky444. The clean theme is a great piece of work, and the mobile one is nice too.
     
  13. Jacky444

    Jacky444 Addicted to LI Member

    I'm very sorry for the late replies, for some reason I did not receive any email notifications from board. So I thought no one really cares about the update =/.

    Alright so first the problem with mobile devices & navigation:
    I've roughly tested the script few times on my mobile and the issue is very hard to fix. As noticed it has been around since I added new menus. Problem is I'm using Javascript to detect width of page so I can adapt the navi to work with click/hover handler properly. Like on big desktop screen it supposed to be using mouse over event while on mobile its supposed to use on click event. So this is sort of issue I don't yet know how to fix.
    Also the problem here is each mobile device has different width of page in browser. And Galaxy S3 has a large screen so in landscape mode the javascript detects width of page more then 800px which means menu changes to "hover" state event instead of on click. I am actually thinking to just add mobile checker for the events and do it that way. Since the width of device doesn't matter when you can't physically HOVER the button.

    Wifi Driver
    Now answer about the WIFI Driver, I'm using Shibby's repo's to compile AT so anything he does is there. Shibby only had 2 branches last time I checked (RT-N and RT) but I've noticed he recently added AC branch as well, I guess that is branch for new AC routers like RT-AC66U from asus. I can give it a look and compile that as well but in Next release.

    I had many trouble merging our gits so the RT-N version's of firmware have some issues, at least I got few reports on email. Issues are minimal and don't affect router's performance or routing.

    New Themes Names
    In last release I've renamed themes to "Default Theme" and "Clean Theme". Since UI is AT makes no sense to have AT - Theme name while AT isn't compatible with original themes anyway.

    Thank you all for feedback & thanks for using AT.

    I've been very busy with some other projects lately so I didn't have much time to look into issues.
    I'll check for other UI issues posted in previous posts as well and fix them.


    As for now I don't think shibby uploaded Test wifi-drivers on git, except if you mean AC drivers. Toastman's Tomato isn't compatible with AdvancedTomato GUI.
     
  14. sanmao

    sanmao Reformed Router Member

  15. Jacky444

    Jacky444 Addicted to LI Member

    Yeah but 1024px some people still resize browser window to that width when they have multiple windows opened. So that would detect it as a mobile device ^^. Anyway I've sorted out the issue completely yesterday by using jQuery browser detection script and now it works perfect.

    P.S.: Ow the touch detection, that is not bad idea! Some laptops might be touch enabled so this is great idea really. I'll give it a try ! Sorry just woke up and my mind is ....

    P.P.S.: After doing research I've realized detecting touch is bad idea, since most browsers have it bugged and even modernizr doesn't support this check well. So I'll stick to detecting mobile browsers. I believe its best solution to the issue.
     
  16. Jacky444

    Jacky444 Addicted to LI Member

    Alright, so after a long time I finally got some spare time and I've fixed reported bugs in AT (available in next 1-2 weeks) and I've finally came up with idea how to show the UI without having to flash AT firmware.

    Tomorrow I'll start working on the demo AT page which will be available to view in next 2-3 days.
    It will work on my web server which seems the easiest way of showing at the moment.

    Also demo page will always have latest updated AT files so you can see what was fixed and what not. At least things that are related to web ui it self.
     
  17. Jacky444

    Jacky444 Addicted to LI Member

    Update: Demo AT Page is now online. Please read note in Orange box on top of UI. It is very important that you understand this Web presentation is extremely buggy because I did not want to spend too much time re-coding Tomato Web Handler. Demo runs on Source code of compiled AdvancedTomato so you can also see the entire javascript, css and asp files in their true source (no minify, no features removed etc.)

    Hope this meets your requirements "see before upgrade".

    If you have any additional requests or questions, please ask/write. =)

    AdvancedTomato DEMO page
     
    uboot and Elfew like this.
  18. Jacky444

    Jacky444 Addicted to LI Member

    AdvancedTomato Update V1.10.10 is now available.

    Change Log:
    Code:
    1.10.10:
    - Fixed "QoS is disabled" messages
    - Final navigation fix for mobile navigation (Changed from width to mobile device browser detection)
    - Fixed cookies expire times (Shibby's 110 update which wasn't included in AT 1.09)
    - Added new Theme called Metro Flat UI (It isn't based on Metro though)
    Its small, I know. It was released to fix most annoying issues (There is also loads of fixes for RT-N build. Fixed issues that came with Git merging). Anyway I'm also releasing Testing Wifi-driver build soon and RT-AC66U for new Asus AC Wifi based router as well. Working on it.

    As usual, Please check MD5 sums after download to verify image before flashing. MD5 sums are now easier to compare as well e.g. Asus RT-N66U: http://at.prahec.com/uploads/router/v1.10.10/RT-N66U.md5sum

    Download

    P.S.: There seem to be small issue with HTTPD handler. It disables the left navigation. If you wish to keep Left Navi, Please DO NOT FLASH this update ! Fixing very soon!
    Note: ISSUE effects only RT-N builds. K26 builds are working great.

    Update: Issue fixed, compiling new versions. This might take few hours.
    Update: I'm going sleep, compile is about 50% done. I've uploaded FIXED versions of RT-N66U firmwares & WNR3500L V2 ! New MD5 Hashes also uploaded. Linksys E-Series folder & Asus RT-Nxx wasn't fixed yet. I'll upload rest tomorrow. Good night ^^.
     
    uboot and Elfew like this.
  19. Jacky444

    Jacky444 Addicted to LI Member

    Update Fixed. Please those who already flashed previous update files, re-download file for your router and re-flash. It will fix the navigation. I'm very sorry for any inconvenience caused to you !

    Working on New Driver compile today and AC66U.
     
  20. sanmao

    sanmao Reformed Router Member

    Thank you Jacky.
    Report a problem: i flashed my RT-N66U, navigation working fine on my iPhone but not working on iPad.
     
    Jacky444 likes this.
  21. Jacky444

    Jacky444 Addicted to LI Member

    Never-ending issue with browsers LOL :D. I will look into it and add browser detection for tablets as well. Hope its even possible.

    Thanks for report!
     
  22. Jacky444

    Jacky444 Addicted to LI Member

    I had a issue with my web site so downloads did not work properly. The issue was caused by the cache of page which would normally send a file download request. I've fixed it and its working properly now.

    Sorry for any inconvenience caused to you =/
     
  23. fearz

    fearz Serious Server Member

    Can anyone confirm what is the WIFI driver in the latest version?
     
  24. Jacky444

    Jacky444 Addicted to LI Member

    Its still old stable version. I couldn't get shibby's new driver patch to work yet. Once I do I will post here links to (ND) versions a.k.a. New Driver which will have new thingie.
     
    uboot likes this.
  25. Jacky444

    Jacky444 Addicted to LI Member

    Alright guys, I'm sorry for the long delay, but New Driver version of AT is underway!
    Compile just started so in 2-4 hours builds will be available on official AdvancedTomato web site!

    AdvancedTomato builds with new Driver now available here:
    http://at.prahec.com/files/?browse=v1.10.10/K26RT-N/Testing/

    MD5 Sums:
    2d9bdf810c95feaa442ba6af7cd07873 tomato-E4200USB-NVRAM60K-1.28.AT.RT-N5x-MIPSR2-ND-1.10.10-AIO.bin
    9cc91e6144e2cb09f9db795a8bc85998 tomato-K26USB-1.28.AT.RT-N5x-MIPSR2-ND-1.10.10-AIO-64K.trx
    2f9321c382288d338645b9126e29e095 tomato-K26USB-1.28.AT.RT-N5x-MIPSR2-ND-1.10.10-AIO.trx
    b2831701de53c9e2d21eea3fdfd4338e tomato-Netgear-3500Lv2-K26USB-1.28.AT.RT-N5x--ND-1.10.10-AIO.chk
     
  26. AndreDVJ

    AndreDVJ Addicted to LI Member

    Very nice Jacky. I'm gonna test right away these FW with new driver.
     
  27. Yorak

    Yorak Reformed Router Member

    Is there a way I can use the theme without using the different firmware? I am just using a shibby build and would love the AdvancedTomato theme with it. Great work regardless. :)
     
  28. Jacky444

    Jacky444 Addicted to LI Member

    The easiest solution is just flashing the AT to be honest. It is basically a themed Shibby mod, nothing different about the functionality or router firmware. Only as a theme it won't work properly since its not just a theme. Its a full new Web UI with new Javascript functionality & lots of new CSS.
     
  29. Yorak

    Yorak Reformed Router Member

    Actually, can I just backup my settings, flash straight to AdvancedTomato and restore them? Is it that simple?

    Thanks.
     
  30. Spyros

    Spyros LI Guru Member

    I went into a great trouble yesterday after trying tomato-E2000-NVRAM60K-1.28.AT-RT-N5x-MIPSR2-1.10.10-Max.bin, the image is corrupted and it took my hours to unbrick my e2000.
     
  31. Jacky444

    Jacky444 Addicted to LI Member

    I'm very sorry, did you check MD5SUMS before flashing ? I did express multiple times that cloudflare might having some issues with bin/trx files hosted on my web server which can cause corrupted images at download. People in some countries that get those issues I sent the files over email which solved the issue with Corrupted images.

    I'm very sorry for inconvenience caused to you, can you please check MD5Sums of downloaded files and report back to me?
     
  32. Spyros

    Spyros LI Guru Member

    tomato-E2000-NVRAM60K-1.28.AT-RT-N5x-MIPSR2-1.10.10-Max.bin

    and

    tomato-E2000-NVRAM60K-1.28.AT-RT-N5x-MIPSR2-1.10.10-MiniIPv6.bin

    have a not matching md5, downloaded 3 times.
     
  33. RobbieW

    RobbieW Reformed Router Member

    #Jacky444,
    Thought I'd try your new interface and a different version of Tomato so downloaded this...
    tomato-K26USB-1.28.AT-RT-N5x-MIPSR2-1.10.10-AIO.trx
    I'm running an RT-N16 and used your auto-selector to pick that file. I like the interface though, as many others have commented, theres a lot of white space. I was previously running tomato-K26USB-1.28.7502.1MIPSR2Toastman-RT-VPN.trx.

    I run a utility on the router that takes NMEA (boaty stuff) data from a USB port and broadcasts that onto my subnet (http://www.stripydog.com/kplex/ , it does other things as well but thats what I'm doing with it). I had re-compiled, using buildroot, that utility for MIPSEL and it ran well enough on the Toastman version of Tomato firmware. On your firmware, the utility fails to start with a message that the symbol 'htons' cant be resolved.

    So I reflashed the router with what I think is the same base firmware but without your GUI...
    tomato-K26USB-1.28.RT-MIPSR2-110-AIO.trx
    from Shibby and the utility runs as with the Toastman firmware.

    So, I wonder if you have some small difference with your build setup to Shibby's that excludes the 'htons' from your libraries?
     
  34. fearz

    fearz Serious Server Member

    Anyone tried the new driver? can you please post results? is it any better?
     
  35. AndreDVJ

    AndreDVJ Addicted to LI Member

    I'm testing the new driver with my WNR3500L V2. It's stable, works well. I currently can't tell if the new driver is any better or worse than the old driver. I live in a building incredibly crowded with wireless connections where I can't tell if that new driver provides better range or more stability.
     
  36. Jacky444

    Jacky444 Addicted to LI Member

    Very sorry for long reply, forum doesn't send me email notifications any more all though I'm still subscribed !

    There is no differences in any libraries except nvram defaults are different, other than that every thing is compiled the same way. I do not understand why its not working, but maybe Shibby can answer to this question? I'm sorry I can not provide proper support for this because I do not know how to. =(

    I will look into it, thanks for report!
     
  37. Jacky444

    Jacky444 Addicted to LI Member

    I have re-uploaded fixed files:
    - tomato-E2000-NVRAM60K-1.28.AT-RT-N5x-MIPSR2-1.10.10-Max.bin
    - tomato-E2000-NVRAM60K-1.28.AT-RT-N5x-MIPSR2-1.10.10-MiniIPv6.bin

    I'm very sorry for the issues & inconvenience caused. I do not understand how this could happen.
     
  38. yudouxie

    yudouxie Reformed Router Member

    [​IMG]
    @Jacky You made the TT more friendly. Really good job! BTW, Picture of Ethernet Ports State is not so harmonious with other stuff. Personally, I think 'hide/show' is better than 'click to hide/show', and I hope the Ethernet Ports State is hide-show-able too.
     
  39. Jacky444

    Jacky444 Addicted to LI Member

    Thanks ^^. Great idea really, I haven't thought about it. I'll add these changes in next update!
     
  40. Jacky444

    Jacky444 Addicted to LI Member

    Thank you very much. This comment made my day/night
     
  41. quietsy

    quietsy LI Guru Member

    This made me upgrade after 6 months (I'm lazy) and I absolutely love it, great work.
     
    Jacky444 likes this.
  42. uboot

    uboot Serious Server Member

    Shibby released rev 112... ;)
     
  43. Jacky444

    Jacky444 Addicted to LI Member

    As soon as Shibby updates git sources I'll update AT base to 112.
     
    uboot likes this.
  44. uboot

    uboot Serious Server Member

    u are amazing! :D
     
  45. shibby20

    shibby20 Network Guru Member

    git was updated few day ago ;)
     
    uboot likes this.
  46. Jacky444

    Jacky444 Addicted to LI Member

    Oh? I thought that was 111 update ! My bad! I will compile AT asap!

    One note: I will not compile ND & AC-66U versions anymore because I don't have space on the machine and it takes a little too much time for me (I'm really busy lately).
     
  47. Jacky444

    Jacky444 Addicted to LI Member

    Sorry for the delay!

    AdvancedTomato version 1.11.12 is now available.

    Downloads

    Change log:
    Code:
    1.11.12:
    - Changed "Click to hide/show" into only icons arrow up/down
    
    1.10.11 by Shibby:
    - WAN DHCP in K24 problem was fixed
    - add "string" module for ip6tables
    - enable lib optimalization for all builds (make images smaller)
    - removed command version, speed, s_client) from openssl (make images smaller)
    
    1.10.11 by Shibby:
    - Some fixes in NETFILTER – thx Victek
    - VLAN: Correct ID for RT-N66 allowing VLAN and tagged network – thx Victek
    - Add support for newer flash chips in latest RT-N66U hardware revision – thx RMerlin and Victek
    - All K26 and K26RT-N builds are compiled using new/fixed toolchain
    - ACCESS RESTRICTION: use string module instead web module (https is blocked now – facebook for example)
    - pairNIC DDNS service – thx Andy
    - Stealthmode and mymotd – some improvements – thx Monter
    - Busybox 1.21.1 update
    - Add optware-install.h script to Tomato – just mount drive to /opt directory and run "optware-install.sh". That'a all.
    - Transmission: update to 2.81
    As usal please check MD5 sums before flashing so you don't brick your router or anything like that. If web site shows older version don't mind it, its cached so some times it shows the wrong info.

    Happy flashing!
     
    sanmao and uboot like this.
  48. boardlord

    boardlord LI Guru Member

    Hello,

    Since I updated to the latest version (for E3000), I cannot wake my machine with the command "/usr/bin/ether-wake xx:xx...." It says: -sh: /usr/bin/ether-wake: not found...

    Anybody has experienced this?
     
  49. shibby20

    shibby20 Network Guru Member

    ether-wake is a part of busybox. It`s working on my tomato, well @Jacky444 it must be broken in your sources

     
  50. boardlord

    boardlord LI Guru Member

    Thanks shibby for the reply, let's see what Jacky says :)
     
  51. Jacky444

    Jacky444 Addicted to LI Member

    Heh, I don't know what to say, I just downloaded GIT again and re-commited every thing and then compiled. I have no idea but this is like 3th AT version that has some sort of "extra" issue coming from other things then I change.

    Its strange =/
     
  52. boardlord

    boardlord LI Guru Member

    I hope you can nail down the issue, I've become very much used to turning on and then using my machine remotely :)
     
  53. Jacky444

    Jacky444 Addicted to LI Member

    I will do my best!
     
    uboot and boardlord like this.
  54. uboot

    uboot Serious Server Member

    I think shutdown the router would be easier if "Router control" buttons will be moved from "Administration" to the main navigation column when "metro left side" style is in use. ;)
     
  55. uboot

    uboot Serious Server Member

    and please update your repo.
     
  56. Jacky444

    Jacky444 Addicted to LI Member

    Hey! I'm on vacation currently and I have no access to my files & VPS from here.
    I also had issues updating git because GitHub doesn't allow me to re-write all the files again because I had to re-download every thing, again... Once I get from vacation I'll give it a try again or just delete/recreate the git.

    Regards from Croatia!
     
    cyber062 likes this.
  57. uboot

    uboot Serious Server Member

    Okay okay, I did not mean to be rude. Well, happy holidays! :)
     
  58. Jacky444

    Jacky444 Addicted to LI Member

    No problem at all !
    I'm back from vacation and I'll update git in few days =) As soon as I get time.
     
    maple.chick, uboot and cyber062 like this.
  59. cyber062

    cyber062 Serious Server Member

    @Jacky444, you make really good job! I like it very much!

    Installed on E3200 and WRN3500L V2
     
  60. Jacky444

    Jacky444 Addicted to LI Member

    Alright, due to lots of issues with Github I'm having I've re-created repos and I'm uploading files right now.
    Git should be available in few minutes under same links.

    P.S.: I found latest files, updating git now!
     
    Last edited: Sep 8, 2013
    uboot, cyber062 and sanmao like this.
  61. AndreDVJ

    AndreDVJ Addicted to LI Member

    Hello Jacky,

    I wish if you could compile Shibby's 112 with New Driver for WNR3500L V2. I actually tried building by myself but I don't really understand the requirements to get things compiling (My distro of choice is CentOS). That's the reason I'm requesting, though I understand your time and disk space constraints. Thanks in advance.
     
  62. boardlord

    boardlord LI Guru Member

    Jacky, just to make sure that something didn't go wrong when I flashed the most recent version I went back to 1.10.10 and the ether-wake command works as it should in that version. Just wanted to let you know :)
     
  63. Jacky444

    Jacky444 Addicted to LI Member

    To compile Tomato you need Debian a-like distro. The best choice is ubuntu. Debian should work with specific libraries and stuff. I had too much issues with other distros then ubuntu so I've chosen Ubuntu.

    I stopped compiling "new driver" because it required too much hastle with files & git's. I simply don't have time to spend days on the ND release. I hope Shibby will soon add beta driver into official builds since it looks it works fine.

    Thank you, I will try to fix the issue with new version of AT which will be released with Shibby's 113.
    I got some free time lately so I'm working on some theories for new functionality. Might be added in next release or not, I'll see how much spare time I will find =)
     
  64. gehx75

    gehx75 Reformed Router Member

    i lost the 5ghz band after flashing advancedtomato to my e3200 so I flashed back to shibby 112....is this a known issue?
     
  65. Jacky444

    Jacky444 Addicted to LI Member

    Thats a new one :O. I really don't understand where are these issues coming from. I will try to fix these in next release. I got reports for weird issues before but 5GHz band not working is a whole new level.

    I'm very sorry, I will try to fix this in next release!
     
  66. gehx75

    gehx75 Reformed Router Member

    jacky thx for your reply...no worries, take your time...from what I saw i really like what you've done...looking forward to using it
     
  67. yudouxie

    yudouxie Reformed Router Member

  68. Jacky444

    Jacky444 Addicted to LI Member

    Thanks for report, I can look into it but I need some more information/data. This is isulated issue and this is first report of it.

    First off, did you try any other versions of AdvancedTomato? Does the issue happen there as well?
    Do other bandwidth statistics pages work fine or the download is not tracked there eather?
    Do you get any javascript errors in on the page (Firefox -> Web Developer -> Error Console)?

    P.S.: AT Interface will get some new changes in future releases. I'm planning to recode and re-design UI to a full screen interface (no matter the size of screen) with better use of space (information & settings expanding over the screen in box containers). There is a lot of work to be done and not much time to do it. So this might take a while.

    I'm open to any suggestions from you guys!
     
  69. yudouxie

    yudouxie Reformed Router Member

    1, This's the first AdvancedTomato I've ever used. BTW, I'm not sure whether Shibby's build works well at those pages.
    2, Both Real-time and Last-24-hours work properly.
    3, No javascript error prompts.

    Thank you.
     
  70. Jacky444

    Jacky444 Addicted to LI Member

    Sorry for the delay, I really don't know what could that be. Any chance you could try older AT or a Shibby official 112 to see if the current firmware is the issue?
     
  71. Jacky444

    Jacky444 Addicted to LI Member

    I've attached AT 1.12.12 overview page screenshot (Remake) and please let me know if you have any suggestions for improvement. Also your opinion is very much valued!

    New Status Overview Page.png
     
  72. yudouxie

    yudouxie Reformed Router Member

    I surggest that you do not set auto refresh as default.
     
  73. uboot

    uboot Serious Server Member

    Look really fine!
    The attached images is my hint... note aroung bottom left ;)
     

    Attached Files:

  74. Jacky444

    Jacky444 Addicted to LI Member

    I understood what you like the first time you wrote it :p I did not miss it out trust me !

    I did think about it, but there is problem with that since the navigation is based on JS and if I change that differently I'll have issue with TOP menu. I'm still trying to find a solution so don't worry =).

    Just sayin this might not be included in next update since its pain in the ass to make it work without extending too much code for it =)

    Ow and thx =), upcoming version will have large change log!
     
  75. uboot

    uboot Serious Server Member

    Ah, right. :p
    However, take a look to new img below. ;)
     

    Attached Files:

  76. Jacky444

    Jacky444 Addicted to LI Member

    Okay! I will see that tables aligment is done as on the screenshot! =)
    At least for those pages where I can make it work.
     
    uboot likes this.
  77. Jacky444

    Jacky444 Addicted to LI Member

    Okay tables aligment done, looks pretty slick now =)
    Another thing, I need suggestions about last theme which will be added into AT (4th), I'm open to colors suggestions!

    I'm thinking it will be FLAT style (boostrap 3.0 sort of) but I'd like to hear opinion of you guys about color scheme.
     
    uboot likes this.
  78. uboot

    uboot Serious Server Member

    Another useful feature would be real-time graphs for cpu/ram/swap consumption and working temperature! :D
     
  79. Jacky444

    Jacky444 Addicted to LI Member

    Alright as promised: AdvancedTomato version 1.12.12 is now available!
    If you experiance any issues with flashing or webUI please report them here or on my web site!

    Change Log:
    Code:
    1.12.12:
    - Status Overview page has been changed
    - Fixed some CSS issues
    - Fixed incorrect calculations at Bandwidth & IP Traffic pages (1000 bits/s = 1 kbits/s aka 125byte/s)
    - Lots of other changes & improvements
    - Improved SVG graphs styles (nothing big, just little changes =))
    - Recoded almost entire html/css & changed the way bootstrap responsive code works
    - Size of the UI was reduced by few kb
    - Responsive code was improved
    - Added 4th theme called "Elenor"
    - Added Hide arrow for Ethernet Ports State (if you wish to hide it temporary)
    - Added custom file input elements (Replacing ugly browser ones!)
    Downloads

    Happy flashing!

    Yeah Agreed! I was actually thinking to make that. It might come in future but there are few issues that come with adding such stats, for starters I need to learn properly how tomato web server handles things and how to even code such feature. Need more insight into Javascript framework as well.
     
  80. yudouxie

    yudouxie Reformed Router Member

    Nice to know that there is new AdvancedTomato (1.12.12) update available.
    Unfortunately, when the menu was set to left-right mode from you demo website in my 1366*768 screen , 'shutdowm' and 'logout' are unreachable.
     
  81. Jacky444

    Jacky444 Addicted to LI Member

    Huh thats some small screen for this year & current technology :p. Okay, any chance you could post a screenshot I might be able to add responsive code to make nav fit smaller screens like yours =).
     
  82. yudouxie

    yudouxie Reformed Router Member

    screenshot as below:
    bb.png

    and the alignment is somewhat strange when visiabilities combined as in the pic.



    i.png
    after all, well done.
     
  83. Jacky444

    Jacky444 Addicted to LI Member

    Okay I'll try to come up with idea to fix the issue on small screens.
    Yeah the aligment is almost impossible to make the way it would fit each time with hidden stuff. I did think about a javascript based script to do this manually but it would end up taking too much space. So I decided simple CSS rules as now is enough, to be honest there is no reason to hide blocks with this design, it uses space much better and makes details available with ease.
     
  84. yudouxie

    yudouxie Reformed Router Member

    tYou don't need to modify it. Different from the demo website, the menu woks well when my routered was updated.
     
  85. Jacky444

    Jacky444 Addicted to LI Member

    That's great news =). Thanks for feedback!
     
  86. boardlord

    boardlord LI Guru Member

    I presume the builds for E300 are still ongoing? :)
    This only happens when I would like to download the newest version...
     

    Attached Files:

  87. Jacky444

    Jacky444 Addicted to LI Member

    Ow, Thanks for report. Silly me, I forgot to upload images for E3000. I'm sorry :p.
    Fixing in few moments!
     
  88. yudouxie

    yudouxie Reformed Router Member

    My router is E3000.
    I downloaded tomato-K26USB-1.28.AT-RT-MIPSR2-1.12.12-Big-VPN for it.
    No problem at all.
    :D
     
  89. boardlord

    boardlord LI Guru Member

    All is good now, thanks :D
     
  90. boardlord

    boardlord LI Guru Member

    This is getting a bit embarrassing for me, but ether-wake doesn't work with the new again :( What can I do to help? Please, anyone with an E3000 try the ether-wake command in SSH console :)

    Edit: Dirty flashed back to 1.10.10, and ether-wake works again :(
     
    Last edited: Sep 25, 2013
  91. Jacky444

    Jacky444 Addicted to LI Member

    I'm sorry for that I really don't know what the issue is. IT has been around since X64 OS for flashing. Seems its my machine setup. I'm sorry I don't know what to do to fix this.
     
  92. boardlord

    boardlord LI Guru Member

    Shibby mentioned that ether-wake is part of busybox, and I saw in your changelog that you updated busybox after 1.10.10... Maybe something went wrong there?
     
  93. Jacky444

    Jacky444 Addicted to LI Member

    That is definatly possible. Though Shibby doesn't have issues with that, while AT has. All though I gota say I tested it on my Asus RT-N66U and it works fine (wake up by lan), so its really confusing.
     
  94. boardlord

    boardlord LI Guru Member

    I tell you what I'll do. Tonight I'll cleanly (erase NVRAM) reflash the newest version, and report back. I'd like to stick with AT, since the interface is much more intuitive than the traditional Tomato one.
     
  95. Jacky444

    Jacky444 Addicted to LI Member

    Ok, that would help at debuging. Also don't forget to backup nvram before erasing =).
    I'm also lately thinking to some how create optware installer for AT. That would save me a lot of time compiling & having issues with firmware it self. I don't really know how I could manage to do that but there cartanly must be a way.

    I don't know anything about optware so I've contacted shibby in this matter. Maybe we can work out a solution that would definatly be great :)
     
    boardlord likes this.
  96. kthaddock

    kthaddock Network Guru Member

  97. Jacky444

    Jacky444 Addicted to LI Member

    I know shibby added optware installer script (since I've added it to AT as well), but what I mean is like creating AdvancedTomato as an optware application. Which would mean it would install through optware and it would work on Shibby's firmware as well.

    P.S.: I just noticed there is a bug under admin-access page. New elenor theme is not beeing displayed as option. If you like to try it you'll have to access SSH and type "nvram set web_css=css/elenor". This will be fixed in next release.
     
    Last edited: Sep 26, 2013
  98. boardlord

    boardlord LI Guru Member

    Alright I feel embarrassed again... The reason ether-wake didn't work with (at least) the newest version is because I used the command "/usr/bin/ether-wake MAC". I used "ether-wake" without the "/usr/bin" path and voilá! it worked as it should :) So, be advised AT users, use busybox commands without path :)
     
  99. Jacky444

    Jacky444 Addicted to LI Member

    Heh that is great news ! Its not a problem, I get same problems all the time.
    I'm very happy it works after all.
     
    boardlord likes this.
  100. boardlord

    boardlord LI Guru Member

    Thanks for bearing with me :)
     

Share This Page