1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AdvancedTomato - new GUI based on Shibby's mods

Discussion in 'Tomato Firmware' started by Jacky444, Mar 20, 2013.

  1. Jacky444

    Jacky444 Addicted to LI Member

    New theme has been released (Loomie) see more here: http://at.prahec.com/themes/view/9/.

    I don't see why there would be any differences in the builds, AT is based on Shibby and the only modifications are done Web Interface vise. I never modify anything else before compilation process.
     
  2. remlei

    remlei Networkin' Nut Member

    for some reason, after release/renew my IP (DHCP) on WAN, my firewall setting (under Firewall Script) are gone for good (unlike Shibby builds, they are properly loaded in each WAN ip leasing)

    using the latest build

    To trigger the problem, add some firewall scripts and see the magic happens.

    Temporarily fixed this by adding the script on the WAN UP side.


    Also I had this under WAN portion, where Release/Renew (DHCP) and Connect/Disconnect (PPP) were displayed together.
    untitled.JPG
    Connect/Disconnect button arent even working when clicked on them anyway.
     
    Last edited: May 24, 2014
  3. JTD121

    JTD121 Networkin' Nut Member

    Just to update the thread, Advanced Tomato does not play well with the B/C/D1 revisions of the Asus RT-N12. I flashed Shibby, then tried to upgrade to AT, and it hung the router. I left it for about 10 minutes, and couldn't connect to the router. Ah well! :)
     
  4. hgeorges

    hgeorges Network Guru Member

    Hi
    I'm not sure if here is the place to ask some questions...
    Started using/testing advanced tomato for a couple of months, and I like the design. Used before Shibby's version for a couple of years, and I like the fact that I have all Shibby's features in the new UI.

    I checked the logs and I saw some warnings or errors which I'd like to understand and potentially address - if possible to eliminate. There were some related to wmem_max and rmem_max. Those I fixed.

    Any suggestions are appreciated.

    Things work (the router/firewall does the job, hopefully properly), but such loose messages don't give me a nice feeling... :)

    Thank you!
    hg

    root@gateway:/tmp/home/root# cat /var/log/messages | grep -i fail
    May 31 07:00:03 gateway daemon.err miniupnpd[1404]: Failed to get IP for interface vlan2
    May 31 07:08:48 gateway daemon.warn miniupnpd[1523]: upnp_event_process_notify: connect failed: Connection timed out
    May 31 07:16:54 gateway user.warn sd-idle[435]: Failure to open /dev/sdb for spinning down: No medium found
    root@gateway:/tmp/home/root# cat /var/log/messages | grep warn
    May 31 07:00:01 gateway daemon.warn dnsmasq[696]: no servers found in /etc/resolv.dnsmasq, will retry
    May 31 07:00:01 gateway user.warn kernel: vlan2: Setting MAC address to 60 a4 4c 28 71 a1.
    May 31 07:00:03 gateway daemon.warn miniupnpd[1404]: SendNATPMPPublicAddressChangeNotification: cannot get public IP address, stopping
    May 31 07:00:17 gateway daemon.warn dnsmasq[9920]: warning: interface ppp9 does not currently exist
    May 31 07:00:17 gateway daemon.warn dnsmasq[9920]: warning: interface ppp8 does not currently exist
    May 31 07:00:17 gateway daemon.warn dnsmasq[9920]: warning: interface ppp7 does not currently exist
    May 31 07:00:17 gateway daemon.warn dnsmasq[9920]: warning: interface ppp6 does not currently exist
    May 31 07:00:17 gateway daemon.warn dnsmasq[9920]: warning: interface ppp5 does not currently exist
    May 31 07:00:17 gateway daemon.warn dnsmasq[9920]: warning: interface ppp4 does not currently exist
    May 31 07:00:19 gateway daemon.warn dnsmasq[9920]: no servers found in /etc/resolv.dnsmasq, will retry
    Dec 31 19:01:00 gateway daemon.warn dnsmasq[1046]: warning: interface ppp9 does not currently exist
    Dec 31 19:01:00 gateway daemon.warn dnsmasq[1046]: warning: interface ppp8 does not currently exist
    Dec 31 19:01:00 gateway daemon.warn dnsmasq[1046]: warning: interface ppp7 does not currently exist
    Dec 31 19:01:00 gateway daemon.warn dnsmasq[1046]: warning: interface ppp6 does not currently exist
    Dec 31 19:01:00 gateway daemon.warn dnsmasq[1046]: warning: interface ppp5 does not currently exist
    Dec 31 19:01:00 gateway daemon.warn dnsmasq[1046]: warning: interface ppp4 does not currently exist
    May 31 07:08:48 gateway daemon.warn miniupnpd[1523]: upnp_event_process_notify: connect failed: Connection timed out
    May 31 07:16:54 gateway user.warn sd-idle[435]: Failure to open /dev/sdb for spinning down: No medium found
    root@gateway:/tmp/home/root#
    root@gateway:/tmp/home/root# cat /var/log/messages | grep invalid
    May 31 06:21:03 gateway daemon.err transmission-daemon[8963]: blocklist skipped invalid address at line 1 (blocklist.c:367)
    May 31 06:21:03 gateway daemon.err transmission-daemon[8963]: blocklist skipped invalid address at line 2 (blocklist.c:367)
    May 31 07:02:16 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 1 (blocklist.c:367)
    May 31 07:02:16 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 2 (blocklist.c:367)
    May 31 07:05:47 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 1 (blocklist.c:367)
    May 31 07:05:47 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 2 (blocklist.c:367)
    May 31 07:06:05 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 1 (blocklist.c:367)
    May 31 07:06:05 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 2 (blocklist.c:367)
    root@gateway:/tmp/home/root#
    root@gateway:/tmp/home/root# cat /var/log/messages | grep -i err
    May 31 06:21:03 gateway daemon.err transmission-daemon[8963]: blocklist skipped invalid address at line 1 (blocklist.c:367)
    May 31 06:21:03 gateway daemon.err transmission-daemon[8963]: blocklist skipped invalid address at line 2 (blocklist.c:367)
    May 31 06:21:03 gateway daemon.err transmission-daemon[8963]: UDP Failed to set receive buffer: requested 4194304, got 229376 (tr-udp.c:78)
    May 31 07:00:03 gateway daemon.err miniupnpd[1404]: ioctl(s, SIOCGIFADDR, ...): Cannot assign requested address
    May 31 07:00:03 gateway daemon.err miniupnpd[1404]: Failed to get IP for interface vlan2
    May 31 07:01:35 gateway cron.err crond[715]: time disparity of 23358900 minutes detected
    May 31 07:01:39 gateway daemon.err nmbd[791]: Samba server gateway is now a domain master browser for workgroup HOME on subnet 192.168.20.1
    May 31 07:01:51 gateway daemon.err nmbd[791]: Samba name server gateway is now a local master browser for workgroup HOME on subnet 192.168.20.1
    May 31 07:02:16 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 1 (blocklist.c:367)
    May 31 07:02:16 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 2 (blocklist.c:367)
    May 31 07:05:47 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 1 (blocklist.c:367)
    May 31 07:05:47 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 2 (blocklist.c:367)
    May 31 07:06:05 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 1 (blocklist.c:367)
    May 31 07:06:05 gateway daemon.err transmission-daemon[1556]: blocklist skipped invalid address at line 2 (blocklist.c:367)
    root@gateway:/tmp/home/root#
     
  5. Gitsum

    Gitsum LI Guru Member

    How long till we see the updated version?
     
  6. lepa71

    lepa71 Serious Server Member

    Any update coming?

    Shibby has [RELEASE] 119
     
  7. Jacky444

    Jacky444 Addicted to LI Member

    Hmm I don't see how that could be affected by the UI it self. I can look into it.

    About 119 update, I can not start working on it untill shibby releases GIT Sources for me to be able to upgrade AT. Its been 7 weeks since Shibby updated GIT. Guess he has good reason why its not updated yet. As soon as git sources are updated, I will start working on a new update AT 1.25.19.

    I also can't wait for ARM sources to upgrade my R7000 to Tomato :)
     
    Gitsum likes this.
  8. abubin

    abubin Addicted to LI Member

    is there any advantage of using this apart from the better GUI?
     
  9. Jacky444

    Jacky444 Addicted to LI Member

    Nope
     
  10. uboot

    uboot Serious Server Member

    Shibby released v120. Waiting sources... :(
     
  11. Jacky444

    Jacky444 Addicted to LI Member

    Yeah me too :/ Can't wait to run AT on my R7000!
     
    Praxis123 likes this.
  12. JTD121

    JTD121 Networkin' Nut Member

    Curious, and this might be the wrong place to ask; If I enable the Use dnscrypt-proxy checkbox, do I need to set it up on individual machines on the network? Or do some kind of testing to see if it's working at all? Also, any config files?
     
  13. gabontz

    gabontz Network Newbie Member

    Hello people!

    I need help with AdvancedTomato.
    I have a WRT54GL with 16Mb flash, and flashed ower the AIO for wl_500w.
    When I changed the flash, I have broken the pcb circuits where the usb mod wires were soldered.
    So I stick only with sdmod, but I can't make it work.
    Can anyone help me to make sdmmc work on this mod?

    Thanks in advance!

     
  14. uboot

    uboot Serious Server Member

    Ehi Jacky, Shibby has just committed his changes to the repo! :D
     
  15. Jacky444

    Jacky444 Addicted to LI Member

    Yeah thanks, already working on it since yesterday! Compilation takes about 2 days and I've already merged changes (can't do them through git due to so many changes in code :)), but yeah already compiling =)
     
  16. Praxis123

    Praxis123 Network Newbie Member

    Any chance we can see this for the R7000?
     
  17. gabontz

    gabontz Network Newbie Member

    Hello again,

    I just discovered why I can't make mmc.o to work. :) I was rtying to put it from a k24 build.
    I didn't know that on k26 we do not have mmc over gpio.
    Jacky444 is there any chance to port this theme to a k24 build?
     
  18. Jacky444

    Jacky444 Addicted to LI Member

    Update 1.25.20 is now available!

    Change Log (inc. Shibby's update):
    Code:
    - Fixed wrong redirect when restoring Bandwidth/IP Traffic statistics (By Spittie)
    - Fixed issue where reboot/shutdown/logout reloaded page (not confirmed)
    - Fixed BW Limit button in the device list (By Spittie)
    - Fixed issue on Administration -> SNMP page where it did not save any settings
    - Increased Custom Log file path input characters on Administration -> Logging page
    - Updated Copyright to year 2014 (By Spittie)
    
    - Updated OpenSSL to 1.0.1h
    - incressed 6rd-prefix range
    - Updated transmission to 2.83
    - dnscrypt: add user selectable/manual proxy input – thx lancethepants
    - fix advanced dns/dhcp page
    - dnscrypt-proxy update to 1.4.0
    - dnsmasq update to 2.71
    - DDNS – new services: ovh and changeip
    - ovpn client gui: allow to set ip/mask on TAP/TLS
    - zlib update to 1.2.8
    - Add Web server: php/pcre/nginx/spawn-fcgi – thx Victek - AIO builds only
    - openvpn update to 2.3.4
    - minidlna – 1.1.2
    - miniupnpd – 1.8 (20140422)
    - dnsmasq: update to 2.70
    - Comcast Fixes: DSCP and buffer overflow with GUI – thx lancethepants
    - dropbear: fix some PATH
    - DNSSEC with GUI – thx lancethepants – AIO builds only
    - dnscrypt: Add dns priority option – thx lancethepants and Victek
    - ethstate: fix when we have network aliases of WAN interface
    - Access Restriction: return to old „web module” style. „String” module is still in image, well user can you it in his own iptables rules
    - libsodium: Update to version 0.5.0
    
    Downloads

    I have R7000 my self and I can't get ARM sources to build AdvancedTomato for it. I wish I could though.
    Once shibby releases sources for ARM builds, R7000 will get interface as well!

    Sorry no chance for that, compiling K24 kernel is way too complex for me :/
     
    peyton and uboot like this.
  19. Bozo29

    Bozo29 Networkin' Nut Member

    Hi Jacky,

    It's there any chance to see Advanced Tomato for ARM Asus RT-AC68U?
     
  20. Jacky444

    Jacky444 Addicted to LI Member

  21. IcyTexx

    IcyTexx Reformed Router Member

    He just said it.

    EDIT: Sorry Jacky, the thread was open and I didn't refresh before answering.
     
  22. boardlord

    boardlord LI Guru Member

    The fields "Wireless Network Mode" and "Channel"on the "Basic networking page" are empty so they cannot be set. Therefore if I change any parameter on this page and want to save AT errors out with "The field "wl_net_mode" is invalid. Please report this problem." So I'm reporting it :)

    Oh, and clearing nvram doesn't help :(

    Edit: E3000 here
     
    Last edited: Jun 16, 2014
  23. JTD121

    JTD121 Networkin' Nut Member

    Just curious, which should I be trying to download?

    [​IMG]
     
  24. Campigenus

    Campigenus Serious Server Member


    Same situation with a Netgear WNR3500L v2.
     
  25. Campigenus

    Campigenus Serious Server Member


    Same situation with a Netgear WNR3500L v2. Had to go to the command line to change the wireless channel.
     
  26. Jacky444

    Jacky444 Addicted to LI Member

    I will look into it, sorry for the trouble!

    Your choice really, first link is AC based firmware, second is RT-N.
     
  27. kthaddock

    kthaddock Network Guru Member

    Thats is a quirk in Shibby 120 build, "The field "wl_net_mode" is invalid. Please report this problem"
    Reported in Shibby's tree.
     
  28. boardlord

    boardlord LI Guru Member

    Yup, already reported here too :)
    But also the wireless Channel field too

    Sent from my Nexus 4 using Tapatalk
     
  29. kthaddock

    kthaddock Network Guru Member

    Channel field doesn't work if you setting "Interference Mitigation 4" at the same time.
     
  30. boardlord

    boardlord LI Guru Member

    I'm sure that that's not the cause, since in the last release "Channel" behaved as it should, and in this release it remained empty even after an nvram erase.
     
  31. JTD121

    JTD121 Networkin' Nut Member

    Thanks, I wasn't sure if there was a difference other than the N vs AC. But weird that the search for the RT-N66U came up with an AC firmware, no?
     
  32. JTD121

    JTD121 Networkin' Nut Member

    Just got this, too, in AT. Just setting dnscrypt-proxy (which apparently requires loglevel?) and it spazzed out about this!
     
  33. remlei

    remlei Networkin' Nut Member

    THere's a bug under DHCP/DNS page. You cant save setting, it says it saved the setting and restarting something, but when you refresh the DHCP/DNS page, the configuration back to it was like nothing. And after a few seconds router crashed. After reboot checked DHCP/DNS page and still the same.

    Weird enough the changes were applied on NVRAM its just not show on AT web setting. Plus with the unreasonable crash.

    Using RT-N16

    Shibby 120 doesnt have this weird bugs.
     
  34. lepa71

    lepa71 Serious Server Member

    I have the same thing. There is nothing inside dropboxes.
     
  35. Jacky444

    Jacky444 Addicted to LI Member

    I guess Shibby pushed some issues to git without all changes, that's why there are issues now. I did clean download of sources and just modified what is required for the GUI. I'm working on fixing the above issues but it might take a while. I suggest downloading previous version mean while.

    Should I remove 1.25.20 from web site?
     
  36. lepa71

    lepa71 Serious Server Member

    It works fine, but can't change anything on those fields. I would take it down or post a now as incomplete.
     
  37. JTD121

    JTD121 Networkin' Nut Member

    1.25.20.1, I like it :) So this is Shibby's fault, or just that you downloaded the sources while he was still uploading and some stuff wasn't up-to-date? *shrugs* no biggy. As long as most of the functions work, I can live without tweaking for a couple days!
     
  38. Jacky444

    Jacky444 Addicted to LI Member

    Its possible yeah, I'm not sure. I already fixed issues with basic-network page and its already compiling =)

    P.S.: Update 1.26.20 (minor update) already available. It fixes wifi issues on basic-network page and also removes Google fonts (large loading time) I'm still working on a way to get Google fonts work on AT. They're heavy on space that is the problem (older routers)
     
    Last edited: Jun 22, 2014
    JTD121, uboot and boardlord like this.
  39. boardlord

    boardlord LI Guru Member

    Just flashed 1.26.20, and voilá, the basic-network page works as it should. Fantastic support Jacky :)
     
  40. railgrinder

    railgrinder Network Guru Member

    As always, great work with AT. I flashed to 1.26.20 but there still seems to be issues with the basic wireless networking section.

    I tried to enable the 80MHz channel width for the 5GHz radio but receive wl_nbw_cap error message (see at_error_a_12620.png). When I navigate to another page and return to the basic wireless page, the setting reverts to 40MHz. I've also tried to reflash and clear NVRAM but the error still occurs.

    Furthermore, the settings under the basic wireless section doesn't match what's displayed under the status overview screen (see at_error_b_12620.png). Specifically the channels don't match for 2.4 and 5GHz radios and the channel width for 5GHz radio displays 80MHz. I've also tried switching between EU and United States regulatory modes for each radio but still no go.
     

    Attached Files:

  41. Rob P

    Rob P Network Newbie Member

    Hi Jacky,
    I have been using the tomato-K26-1.28.AT-RT-MIPSR1-"MINI" firmware on Buffalo WHR-G54S with 4MB flash size.
    I find it very useful and thank you for supporting this.
    After version 1.24.17, there has been no release for "MINI" only 'MAX'.
    Any updates?
     
  42. Spyros

    Spyros LI Guru Member

    I dont see the updated drivers for broadcom on E2000 and issues in DNS/DHCP page
     
    Last edited: Jun 24, 2014
  43. uboot

    uboot Serious Server Member

    Hi, Jacky. Could you include busybox renice in AdvancedTomato? I'd really appreciate that.
    Shibby never responded me... :(
     
  44. shibby20

    shibby20 Network Guru Member

    because i never see this request. Include renice is not a problem.
     
    uboot likes this.
  45. lepa71

    lepa71 Serious Server Member

    @shibby20

    Is it possible to build Tomato fw for R6250?

    Thanks
     
  46. neomorpheus

    neomorpheus Connected Client Member

    Hi,

    Any update regarding the ARM port?
     
  47. ak907

    ak907 Connected Client Member

    Hello Jacky, I noticed your E900 Build is too large for my Linksys E900 flash size (8mb) ... Is there a smaller version I can download?
     
  48. neomorpheus

    neomorpheus Connected Client Member

    I really hope that Jacky hasn't abandoned this project.
     
  49. Jacky444

    Jacky444 Addicted to LI Member

    I haven't abandoned project, I'm sorry but I'm just so busy I have no time working on this project.
    I'm also very disappointed to the bugs I keep creating and I miss ARM sources, I really want to port AT to ARM.

    Also I'm deciding to lower the amount of Firmwares I'm compiling because it takes way too long and some older routers are suffering from space usage due to the new UI. Since the UI is new, I'm thinking to start porting it only for AC/ARM builds and perhaps few RT-N routers.
     
    neomorpheus likes this.
  50. ZifXiFy

    ZifXiFy Network Newbie Member

    Does this gui takes much more space than shibby one's then ?
    If not could it be a possibility to cooperate with shibby and create a "AdvancedTomato" by shibby once your're GUI is stable and as good as bugfree ? (if he also likes your GUI too :p)
    Then you could focus more on improving the webinterface instead of searching between missing merges,compiling,etc whenever you do in your free time.
    Just a suggestion tho, your gui looks really good, nice work :)
     
  51. Jacky444

    Jacky444 Addicted to LI Member

    I already asked Toastman and Shibby and both disagreed. They want to keep UI as it is original from original developer. I don't know why, since really AT allows easier development (Jquery) and it sure looks better. I would improve it even further if both agreed to use it, but guess its pointless. It does take 80% of my time to merge, compile fix issues etc.

    Web standards are now far ahead from Tomato's coding (HTML5, CSS3, Scalable Graphics, Canvas, etc...). I'm very positive AT could be much more than it is (graphs could be greatly improved, responsive design, etc...) but I just can't afford to spend so much time on it while only few hundred users use it. If Tomato developers would work together and create single new interface for all Tomato releases it could be amazing. But most believe that Router is made for Routing and there it stops. All though Web UI is what allows you to customize router.

    Anyway I don't want to sound rude or offensive, its just my opinion. I will continue my work but I will from now on compile firmware only for most used routers with installed AT (Tomato Anon statistics).
     
    The Master and neomorpheus like this.
  52. shibby20

    shibby20 Network Guru Member

    @Jacky444 wi well return to this conversation soon ;)
     
    The Master, neomorpheus and ZifXiFy like this.
  53. ZifXiFy

    ZifXiFy Network Newbie Member

    Reading through your thread it becomes clear to me that much have changed, redesigned, improved since first release so hopefully it will pass "the conversation" as stated by shibby.
     
  54. neomorpheus

    neomorpheus Connected Client Member

    Jacky, thanks so much for your response and really hope that Shibby works with you on this.
    I have a R7000 and is still sealed, since I got it over a month ago.
    Dying to use it, but really disappointed that no firmware can stabilize it.
    Have you ever tried openwrt? Do you think that you could port your GUI to it?
     
  55. ZifXiFy

    ZifXiFy Network Newbie Member

  56. neomorpheus

    neomorpheus Connected Client Member

    No, since other users already reported ping issues and other stuff.
    Not blaming shibby or Kong, since not even netgear itself can get it stable.
    Perhaps I'm spoiled by my wndr3700v2 running openwrt, months without a reboot or anything like that.
    But granted, this router is still relatively new and I really liked tomato on my old wrt54.
     
  57. Jacky444

    Jacky444 Addicted to LI Member

    I have a lot of knowledge about Tomato now and to be honest I always loved Tomato more than any other alternative firmwares. I own R7000 my self (if you haven't read previous posts) and I can't wait to port my GUI to it!
    Though I don't have issues with Shibby's latest build.

    I'm developing AdvancedTomato V2 which is going to be very bug free from beginning (Hopefully few selected users will help me out with Beta testing). AT v2 won't be developed the way to save space on router (meaning custom fonts, svg graphics, no more holding back! Perhaps even google graphs API to make graphs better!) anyway, so far I've developed & designed the UI basics see screenshot how it might look.
    Also note I'm not even trying to make it work on older browsers like IE6-9.

    AdvancedTomato-v2.jpg

    Also info for developers: I'm using as much open source libs as possible like Jquery, Mix of Bootstrap & custom CSS and Fontastic (at the moment, might expand collection further).

    P.S.: Navigation is not complete, it misses icons on the left (still searching for perfect ones!)
     
    neomorpheus, Gitsum and uboot like this.
  58. ceckin

    ceckin LI Guru Member

    I'm not sure if this was mentioned before, but if you have issues with DNS/WAN connection, the pages takes minutes to load, just because the browser is constantly trying to download fonts from Google. Maybe a viable approach would be /tmp caching (in RAM) on boot/WAN up. This way even older device can handle jQuery/Bootstrap/FontAwesome and fit in its 16MB Flash.
     
  59. boardlord

    boardlord LI Guru Member

    Just being selfish, but I hope the e3000 will make the cut :-D sign me as a tester if you like!
     
  60. Jacky444

    Jacky444 Addicted to LI Member

    I really doubt E3000 will be able to work with V2 version. I already incressed size of WebGUI for 300kb.

    New preview's available:
    AdvancedTomato-v2-access.jpg AdvancedTomato-v2.jpg
     
    uboot likes this.
  61. The Master

    The Master LI Guru Member

    After a LONG LONG TIME... A GUI for 16:9 or 16:10 Displays... i hate the websites @ 4:3.... its like the good old 80s :(
     
  62. ak907

    ak907 Connected Client Member

    the memory usage on your first V2 screenshot is quite high... is this caused by the GUI?
     
  63. Jacky444

    Jacky444 Addicted to LI Member

    It wasn't the GUI, I had issues with DLNA, fixed by restarting service. It actually used 230mb/256mb ram :O
    GUI's footprint is low, the same as original. I'm working on loading javascript and other resources in the background while user is iddle.
     
    ak907 likes this.
  64. quebec

    quebec Network Newbie Member

  65. Jacky444

    Jacky444 Addicted to LI Member

    Please rather do not flash it, you will probably brick router doing so.
    I haven't compiled all firmwares, I'm darn busy writing new UI. Eum if I get some time I will compile right version for your router :)
     
  66. Jacky444

    Jacky444 Addicted to LI Member

    First Experimental build of AdvancedTomato 2.00 is available!!!
    I built only two images so far, RT-N66U and WNRL3500Lv2.
    Download here: http://advancedtomato.com/files/?browse=AdvancedTomato 2.00 (BETA)/

    Screenshots:

    ATv2-port-forward.jpg ATv2-qos-graphs.jpg ATv2-status-overview.jpg ATv2-vpn-client.jpg

    Web Demo (very buggy):
    http://advancedtomato.com/demo/#status-home.asp

    I'm have been working 5 days in row about 18 hours a day to create this new GUI. Its still not perfected but its close to building something better! Please comment bellow what would you improve, change also if you encounter bugs, errors, etc... Don't be shy!
     
    uboot, cyber062, ZifXiFy and 2 others like this.
  67. Riddlah

    Riddlah Networkin' Nut Member

    Great update. Just a couple things I've noticed. This was under Google Chrome. There seems to be more issues if using Pale Moon (based on Firefox). Don't have Firefox on this machine to test.
    - On the Virtual Wireless page, the 'Random' button is misaligned: [​IMG]
    - The Wireless page under Advanced, not sure how it might look but since the boxes will be the same length, what do you think of having the 2.4 and 5 GHz settings side-by-side (this may only work on higher resolution screens)
     
  68. cyber062

    cyber062 Serious Server Member

    @Jacky444 Great Job !!!!
    Suggestion : More space between the icones (lan1, lan2, lan3, lan4) in /status-home.asp -> Ethernet Ports State

    Router : 3500Lv2
    Navigator : Chrome
     
  69. Jacky444

    Jacky444 Addicted to LI Member

    I will fix the specific issue!
    About the second idea, I did exactly what you just suggested before compiling! I was going to compile it with wi-fi's side by side! But than It didn't look right to be side by side, so I changed back to normal. I will check it again, see if I might still change back :p


    Thanks, will be expanded :)

    Thank you for feedback!
     
  70. AndreDVJ

    AndreDVJ Addicted to LI Member

    I own a WNR3500L V2. I am going to test and provide feedback.
     
  71. Jacky444

    Jacky444 Addicted to LI Member

    Thank you!

    Github issues tracking & repo for new AdvancedTomato V2 (just GUI until public release):
    https://github.com/Jackysi/AdvancedTomato-V2/issues

    New addition to the UI (Collapsible navigation bar):
    ATv2-navi-collapsed-jffs.jpg
     
    Last edited: Jul 19, 2014
    Riddlah, uboot and ZifXiFy like this.
  72. Motrix

    Motrix Network Newbie Member

    V2 is looking fantastic! Can't wait to try it


    Sent from my iPad using Tapatalk
     
  73. ak907

    ak907 Connected Client Member

    How soon after an update do you usually compile your advanced tomato? I have never tried your builds but am waiting anxiously for your arm build to try it out. I am not a huge fan of the GUI of tomato... just the features
     
  74. remlei

    remlei Networkin' Nut Member

    ^stick with shibby firmware if you are only interested in features since it's preety much the same anyway except it has nice gui and ergonomic design in mobile browsers.
     
  75. xjq194949

    xjq194949 Network Newbie Member

    Great UI, Very smooth and responsive.
    One problem though, I can't seem to customize the port for Media Server.
    [​IMG]
    Is this a Shibby thing or a AdvanceTomato thing? Or just me somehow messed up the setting?
     
    Last edited: Jul 21, 2014
  76. AndreDVJ

    AndreDVJ Addicted to LI Member

    Three days using the router with AT 2.0 inferface. The web interface definitely does not like IE10 on Windows 7. QoS menu and the Network icons

    ERROR occured!
    There has been error while loading a page, please review debug data bellow if this is isolated issue.
    Otherwise please contact AdvancedTomato developer Jacky.

    TypeError: Não é possível obter a propriedade 'substr' de referência indefinida ou nula

    It's in portuguese, which says "It's not possible to get property substr of undefined reference or null.
     
  77. Jacky444

    Jacky444 Addicted to LI Member

    I missed changes on this page from Shibby's git, my bad! fixed!


    I noticed that too after trying it out on IE10, this issue is fixed in latest release.
     
  78. Jacky444

    Jacky444 Addicted to LI Member

Share This Page