1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Almost all Tomato FMs on RT-N66U

Discussion in 'Tomato Firmware' started by w11x22, Apr 19, 2013.

  1. w11x22

    w11x22 Networkin' Nut Member

    Hi all......
    I have this speed issue with my Router. When I test with speettest.net I get only 4 to 7 Mbps and my Cable Internet is 14 Mbps. I tried Shibby 103 to 105, I tried RAF and I tried Toastman different versions but speed issue remains the same. As soon as I test speed test via Router I get between 5 7 Mbps but right away when I remove my Laptop and connect directly to Cable Modem I get full 15 Mbps so it is not the issue of of my Laptop or Cable Modem. I tried different times of the day but same thing. I used Wired connection to test this not the Wireless....Also no QOS enabled and no BW Limiter
    PS: I did cleared NVRAM after each Flashing....
    Any Idea????
     
  2. mito

    mito LI Guru Member

    Hi, test with stock firmware to see what happens. By the way, you can also test with RMerlin's firmware that is also a well developed firm.
     
  3. w11x22

    w11x22 Networkin' Nut Member

    I just tested it with Merlin which is basically Stock but with little more tweaks and the speed test came even better than 14 Mbps... I used exactly the same HW with no change what so ever...
     
  4. Monk E. Boy

    Monk E. Boy Network Guru Member

    Did you have QoS enabled?

    If it was enabled and the inbound speed was set to, say, 8Mb then speedtest will test at under 8Mb.

    I have an RT-N66U setup with QoS configured properly on a 50Mb line and it has no problem going over 40Mb on speedtest. I have QoS configured properly, with the configured speeds using lower than connection speeds, which is why it doesn't test at 50Mb.
     
  5. w11x22

    w11x22 Networkin' Nut Member

    Thanks for the reply Monk. No, the test I do is without any QoS or BW Limiter... I flashed the Router and do the testing on Default settings with only one device attached to the router......
     
  6. Monk E. Boy

    Monk E. Boy Network Guru Member

    What if you run the test over Ethernet?

    I would guess from default settings you mean you didn't scan your surrounding area for wireless signals and choose channels that weren't already occupied, and instead were relying on the (shudder) Auto setting...

    Ethernet will let you know if there's a problem with the router not being able to shuffle data between WAN & LAN/WLAN or whether it's isolated to WLAN clients.
     
  7. w11x22

    w11x22 Networkin' Nut Member

    Monk it is in my orignal post that all testing is being done only on Wired connection, Ethernet using the same HW meaning same Laptop same Ethernet cable etc.....
     
  8. Elfew

    Elfew Addicted to LI Member

    forget to speedtest ;)
     
    w11x22 likes this.
  9. mito

    mito LI Guru Member

  10. w11x22

    w11x22 Networkin' Nut Member

    :)...... I could but I am spoiled by Tomoto and cant live without it now... There are some features that I use alot and they are nowhere to find in Stock or Merlin builds.... I am hopping to get this resolved so I continue to use Tomato
     
  11. koitsu

    koitsu Network Guru Member

    w11x22, could we please get an exact list of firmwares (exact filenames please!!) and what sorts of speeds you saw with each one (including the one which works better for you)? Your initial post just has a rambling of non-specifics; we need the specifics (filenames).

    Thanks.
     
  12. Monk E. Boy

    Monk E. Boy Network Guru Member

    "Tomato Firmware v1.28.0500 MIPSR2Toastman-RT-N K26 USB Ext" runs at full speed here. I can get the exact firmware (.bin/.trx) name on Monday...
     
  13. shibby20

    shibby20 Network Guru Member

    on my rtn16 with my mod v108 i am able to get about 100Mbps over lan and wireless connection. Using my android smart phone i get ~50Mbps. IMO there is not a problem with tomato. Best regards.
     
  14. w11x22

    w11x22 Networkin' Nut Member

    Hi Shibby
    Its nice to hear from you (The Guru)..... Please dont take me wrong, I love Tomato and I myself would like to resolve this as I do not want to go some other platform. Tomato, Specially Shibby, has some very nice features that I use on a regular basis and non of the Router available has those features...As Koitsu asked, here is the FMs I tried...
    tomato-K26USB-1.28.0498.1MIPSR2-Toastman-VLAN-RT-N-VPN
    tomato-RT-N66U-K26USB-1.28.9013MIPSR2R1.1f-RAF-VLAN-VPN-NOCAT-LIGHTY
    tomato-K26USB-NVRAM64K-1.28.9013MIPSR2-RAF-VLAN-VPN-NOCAT
    tomato-K26USB-1.28.RT-N5x-MIPSR2-104-AIO-64K.trx
    tomato-K26USB-1.28.RT-N5x-MIPSR2-105-AIO-64K.trx
    This following Merliin built I am using with good/perfect Speed test
    RT-N66U_3.0.0.3_178.15

    I am going to give 108 a try and see what happens......
    As I mentioned earlier I am using the same method to upgrade ie from ADMINISTRATION and UPGRADE and NVRAM CLEARED Checked.... As you mentioned that yours N16 is working perfect, could it be a problem with just N66us???
    I run all tests on same Laptop with Ethernet Cable even Merlin and with Merlin I got what I wanted.....
    Thanks again to all the big guys who jumped in and try helping others..... I cant thank you guys enough for this support



    OK... SO I tried 108 and brought Laptop near to Router and upgraded it from Merlin to 108 and did the test and again it was close to 6.5 and 7.... Now without moving anything just upgraded it back to Merlin and bingo, Speed test shows close to 15 Mbps.......
     
  15. RMerlin

    RMerlin Network Guru Member

    When dealing with cablemodem, it's sometime needed to power off your modem, wait 5-10 mins, then power it back on to ensure that your ISP fully resets your connection. This can fix quite a few oddities.
     
  16. w11x22

    w11x22 Networkin' Nut Member

    Thanks Merlin, I feel so lucky that all the big guns are trying to help me.... I will give this a shot and let you know but one quick question why the same Cable Modem without reboot works OK with one FM (Merlin) but on the other hand refuse to work properly with another one........
     
  17. alpovs

    alpovs Reformed Router Member

    Can you check if you get different IP's when you are on tomato and ASUS/Merlin firmware? To my surprise I was getting different IP's from my cable provider for the same MAC on RT-N66U. Can anybody explain?
     
  18. w11x22

    w11x22 Networkin' Nut Member

    WOW!!!!!!!!!!! Who could have thought..... I unplugged the Cable Modem and in the mean time re upgraded the FM to Shibby 105. It took me 7/10 min and by then I plugged in my Cable Modem and first thing I tried was the speed test and after testing it 4 or 5 times couple of times the Speed test was better than Merlin... I was shocked, who could have thoguht.... I guess Tomato and Cable Modem were not geting together very well, but after rebooting the Cabel Modem it works like a charm (even better)..... Thanks all and specially RMERLIN..... What a team and Gurus...Bravo and Hats off to all who helped....
     
  19. w11x22

    w11x22 Networkin' Nut Member

    Sorry Alpovs, I did not pay attension to my IP before or after Tomato......
     
  20. mito

    mito LI Guru Member

    @ alpovs, great!
     
  21. koitsu

    koitsu Network Guru Member

    Could you disclose the exact model (and version) of cable modem you were using?

    To me, the only thing I can think of that might cause this problem is speed and/or duplex negotiation mismatch per IEEE 802.3 standards -- for example, one end things it's using 100mbit the other things its using 10mbit -- or (much more likely) one end thinks its using half-duplex and the other end thinks it's using full-duplex.

    I have actually encountered a speed negotiation problem between a very specific set of hardware: the Asus RT-N16 hardware revision A1 (latest), and a Motorola SB6120 hardware revision 1.0. Replacing the Motorola with a newer SB6120 (hardware revision 3.0 or newer) fixed the issue. What this indicates is a PHY behavioural incompatibility between two vendors (Motorola changed their PHY vendor in later hardware models). I didn't suffer from any performance issues as a result of the mismatch, but it's still hard evidence.

    Rule of thumb: when it comes to cable modems (as well as DSL bridges ("DSL modems")), power-cycling them (not rebooting, but an actual power cycle!) often solves a lot of things. I shouldn't need to state my opinions on this one. ;-)
     
  22. w11x22

    w11x22 Networkin' Nut Member

    Thomson.DCM-476...No Idea on Version but it states "FACTORY ID 2". If that makes any sense to you..........
    Powering cycling is what I do when things do not make any sense but in my case Merlin and Stock were performing well but Tomaot so I never thought about power cycling of Cable Modem....
     
  23. Monk E. Boy

    Monk E. Boy Network Guru Member

    Try visiting http://192.168.100.1 - it should take you to the web server built into the cable modem. There may be more technical details on the make/model/firmware/etc. on the site.

    If you're not running in bridge mode (in which case your N66U wouldn't have a public IP address, it'd have a NAT IP address), then you'd just visit the default route/router for the network on front of the N66U.
     
  24. w11x22

    w11x22 Networkin' Nut Member

    This is what I got after connecting via 192.168.100.1
    Status Code: Operational
    Software Version: STAC.02.50
    Software Model: a81a
    Bootloader: 2.3.1

    PC Connectivity:
    USB: N/A
    Ethernet: 1G BaseT
    USB VendID: N/A
    MAC Address: XX:XX:XX:XX:XX

    Cable Signal: Ready
    Tuning: Complete
    Ranging: Complete
    Data Service: Ready
    Connecting: Complete
    Configuring: Complete
    Registering: Complete

    Current State: Operational
    Highest State Obtained: Operational

    Configuration Parameters: Computers Allowed by Service Provider: 3
    Computers Detected by Modem: 2
     
  25. koitsu

    koitsu Network Guru Member

    Thanks. The reason I wanted the cable modem version/etc. is because if other people have the same issue as you and have the same equipment, the thread can/may help them. That's all.
     

Share This Page