1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Android "Obtaining IP Address" Loop

Discussion in 'Tomato Firmware' started by WaylonCovil, Mar 11, 2014.

  1. WaylonCovil

    WaylonCovil Serious Server Member

    Last night, I installed the latest (and several older) versions of Toastman's Tomato build on my Asus RT-N16. (My apologies for posting in the Linksys forum.)
    Everything went fine except for my Moto X. It keeps looping and saying Authenticating, Obtaining IP Address.
    Another android device was able to connect to the network without issue. My Moto X has been able to connect and obtain an IP address on this device when it's running another firmware.
    I ended up putting another firmware back on it.
    Any initial suggestions as to what I could try?
    Thanks!
     
  2. kthaddock

    kthaddock Network Guru Member

    Try to delete wifi profile in complications Android and reconnect again.
     
  3. WaylonCovil

    WaylonCovil Serious Server Member

    Thanks so much for the suggestion.
    I've tried using several different SSIDs/Profiles and it still didn't work.
     
  4. dc361

    dc361 LI Guru Member

    Be very careful typing the password for the SSID/Profile - I had a problem like that and it turned out I was entering the 'word of the day' incorrectly.
     
  5. WaylonCovil

    WaylonCovil Serious Server Member

    There are quite a few threads online that discuss this issue such as the one below:
    http://forum.xda-developers.com/showthread.php?t=1965812&page=3
    Some suggest setting a Static IP address, or following these steps on the phone:
    Note: You Must have root.
    Go to
    /data/misc/dhcp/
    and delete all 3 / 4 files there.
    And voila it should work.

    I want to solve the problem at the router level.
    Perhaps this information can help others.
    I tried several SSIDs/Profiles without passwords and it still gave me the Obtaining IP Address loop.

    I'm just wondering if there's some setting somewhere that could be causing DHCP to not work exactly the way it should.

    I've tried using G instead of N and that doesn't help.

    By Setting a Static IP, I was able to connect. But I don't want my guests to have to set static IPs to connect to my network.

    Thanks for everyone's interest. :)
     
    Last edited: Mar 12, 2014
  6. WaylonCovil

    WaylonCovil Serious Server Member

    I wanted to provide an update to this issue.
    I tried both Shibby & Victek's versions and my Moto X connected incredibly fast.
    I'm unsure why this is the case but perhaps it will help someone in the future.
     
  7. JoeDirte

    JoeDirte Serious Server Member

    I believe Toastman's builds have DHCP disabled by default. Just throwing that out there in case you were expecting otherwise.
     
    dc361 likes this.
  8. Toastman

    Toastman Super Moderator Staff Member Member

    As JoeDirte said, my builds do not have DHCP enabled by default, you need to set fixed IP on your PC to access the router. Personally, I would always advise that you set fixed IP's on your clients anyway, for reliability and robustness.

    I have not seen a problem with access - all Android phones I have seen in these condos have been able to access the router and obtain an IP easily.

    One thing I have noticed is that the Android phones I have do not accept a secondary gateway which DHCP offers them. That makes it hard to load balance using that method.
     
  9. WaylonCovil

    WaylonCovil Serious Server Member

    Thanks!
    I'll make the switch and enable DHCP.
     
    Last edited: Mar 16, 2014

Share This Page