1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Announce] UFS200 v1.1 - Alternative USB filesystem for NAS200 running jac4 or higher

Discussion in 'Cisco/Linksys Network Storage Devices' started by jackito, Jan 16, 2010.

  1. GnFi

    GnFi Networkin' Nut Member

    Unfortunately even tho i have amule set up correctly and running i have some problems.

    Most of the times amule changes some values in amule.conf file. Those values are max upload and max download speed. It also changes gzip setting. And also max connections.

    If i am right all those values get changed by the web interface. Its exactly the settings that web interface has in the settings page.

    Another problem is with cpu utilization. While i see amule only use 8~20% of the cpu and reach 70+ when hashing files and everything is working great even at that time the web interface is very slow.

    For some odd reason the page loading never completes.

    Damn i will look at it tomorrow. To tired now.
    I have finished with the amule guide (its quite big but it works even for people with min knowledge i think) with how to from the start to the end of a working a mule on this system.
    All i need now is an admin from here to take a look at it.
    I have to sleep right now.
    Cya

    Maybe from tomorrow i will start working on ctorrent and a good guide on it.

    Lol it is only doing the never ending loading in firefox :p
    In explorer it is working fine....

    So after some testing i have no problems in explorer. Very possible that my firefox installation is somehow tweaked and has some problems with amule web interface.

    The problem i had with changes in the amule.conf is solved. :p
    On to the ctorrent configuration and a guide for it
     
  2. jackito

    jackito LI Guru Member

    I also faced this behavior, and also after running for a few days, it was taking a lot of memory. ctorrent+dctcs is lot more lighter and I think that the downloads are faster also than with ed2k protocol.

    Feel free to open a new thread to publish this doc, and I will add a link in the UFS200 announcement to it. Don´t be afraid of errors in the guide, and let the community find them, if any. Hundred of eyes see more than two or three pairs. :)

    Niceeee. A think a lot of people will really benefit from it. Maybe this way they can solve the problems they found that prevents them from making dctcs+ctorrent work.
    Thanks a lot for your work GnFi!

    jackito
     
  3. GnFi

    GnFi Networkin' Nut Member

    Unfortunately i am so inexperienced in linux. I only know some basic commands. I hope i haven't messed up in the so called amule guide. At least i haven't found a valid one to compare :p
    Right now i am messing up with ctorrent+dctcs web interface. Damn its really very light. Maybe because ctorrent process is forced to be in a lower priority?
    Anyway it works till now but i will test more before i fix a so called guide.
    That is if the way i wrote the amule guide is ok in the eyes of a viewer. But that is not on me to decide.
     
  4. GnFi

    GnFi Networkin' Nut Member

    Hello again.

    I have a small problem and i cannot understand why.

    Every time i boot my NAS200 my Server Name changes from GnF_NAS200 to (none).

    That makes my NAS200 not acceptable from windows network since i have mapped it under the name GNF_NAS200. I can bypass this by remapping it under the name (none) but that is not the solution i like.

    The weird thing is that inside NAS200 default web interface (system options) the normal server name is still there.

    A solution is to change it once to something else in there (lets say GnF_NAS20) press save then change it again to my old one and save again.
    That works until next reboot.

    I have done some changes and it might be true that they are responsible for this behavior.

    I have saved 2 scripts in /harddisk/volume_3/data/rc.d

    One is the rc.relocate (i think that is responcible for my disks not going to sleep anymore)

    Code:
    #!/bin/sh
    #
    # Save this as /harddisk/volume_*/data/rc.d/rc.relocate
    # The volume number depends on your configuration
    
    # Helper subroutine to save some typing
    relocate_ramdir()
    {
    rm -Rf $1
    mkdir -p $1
    rm -Rf $2
    ln -s $1 $2
    }
    
    # replace volume_1 by volume_3 if you're running in RAID mode!
    relocate_ramdir /harddisk/volume_3/conf/.varlock /var/lock
    relocate_ramdir /harddisk/volume_3/conf/.varlog /var/log
    relocate_ramdir /harddisk/volume_3/conf/.vartwonkymedia /var/twonkymedia
    but i have a problem of my NAS200 dropping connections after 30 minutes so downloading a big number of files from it (or upload), or downloading one big file or uploading that takes more than 30 minutes is not possible.
    That is a problem i am facing for a long time now and not since upgrading to jac4 or UFS200. I thought that might fixed this problem but i was not still able to try if it did

    The second script i uploaded is rc.resetrootpassword
    I have commented everything inside it with # and left it there to be ready is i forget my pass lets say. All i will have to do is remove # from it.

    Code:
    #!/bin/sh
    #
    # Reset the root password
    # If you need to reset the password of root for ssh just delete the # symbol from all the lines below this one. Keep this file in rc.d directory of your shares
    #egrep "^root:" /etc.default/passwd >/etc/x
    #egrep -v "^root:" /etc/passwd >>/etc/x
    #mv /etc/x /etc/passwd
    #for x in 1 2 3
    #do
    #  cp /etc/passwd /harddisk/volume_$x/conf
    #done
    
    #mv $0 password_reset_done
    #/etc/rc.d/rc.reboot
    I really haven't messed with anything else.

    hostname command returns
    (none)

    Anyone knows a workaround for this?

    Thanks in advance


    weird. The file in /etc.default/sysconfig/network is ok after manually fix. I cannot understand why. Even if i change it after restart nothing happens but the file remains ok.......
     
  5. Mcdn

    Mcdn Networkin' Nut Member

    got stuck

    Ok hope Im not doing anything wrong with posting my question here. Id so please delete it or redirect it to where it should be.

    I've bought a NAS200 a long time ago. And after being on search for a new one, I accidentally came across this forum.....and glad that I did. Maybe now I can bring some new life into my NAS200.

    Also it is worth mentioning that I don't have that high linux skills.
    Anyways let me continue where my problem is.

    I first did this tutorial made by jac goudsmit. Installed the new firmware, changed the password. Didn;t install/configure Twonky and telnet.
    After doing all this I was able to login via SSH (PuTTY) and SCP (WinSCP).

    Doing all this and browsing trough the forums made me visit this thread. And thought it would be kinda cool to have all these 'options' on my NAS200. Especially the "Bittorrent support (dctcs + ctorrent)" and "Shoutcast support (listen to your music anywhere)"...but also want to take a look at all the other fun stuff.

    So I start downlaoding the UFS200 rar and formatted my 1GB usb stick, put the files on it, and let is wait till needed.
    I login via SSH and SCP. Run all the commands (edit passwd.ufs200, modify root user, edit groups).

    So I'm ready to do step 10, upload the rc.ufs200_boot file to my NAS200 (/harddisk/volume_X/data/rc.d/)
    Now comes the problems. There isn't a folder/directory .../data/rc.d/

    I have set my disk config: two separate disks.
    I do have /etc/rc.d/ but no "rc.d" under /volume_x/data/

    So can anybody help me further here?
    Hope my question is clear enough, and understandable (Dutch is my first language)

    Thanks up front for anyone taking the time and effort to help me :)

    //Mcdn
     
  6. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    You could have started a new thread but this place is okay too.

    As far as I can tell, you have all the needed skills to be "dangerous" :biggrin:

    You need to create this folder yourself by entering the command mkdir -p /harddisk/volume_1/data/rc.d in your case. During startup, the JacX firmware checks if the folder exists, and will execute any scripts there that have files starting with "rc.", e.g. "rc.ufs200". The best way to create a script there is to use the built-in editor of winscp, because it will automatically use the correct line endings (line-feeds only, no carriage returns).

    Geen probleem!

    ===Jac
     
  7. Riccardobensone

    Riccardobensone Networkin' Nut Member

    Hi!
    With this file system is possible install svn service? Subvesion is very important for me, but i don't have any idea for insall in nas200.
    Thx!
     
  8. salvacion

    salvacion Networkin' Nut Member

    Hello,

    I installed the jac4 firmware a while ago and wanted to try out ufs200. After following all the installation steps, I wanted to start enabling features but realized that I don't have a /etc/rc.d/rc.ufs200_services_startup

    I believe I followed the directions pretty closely, possibly with the exception that I didn't have a "groups" file only a "group" one.

    I wrote the files on volume_3 since I am using "two disks configured as one large disk" and when browsing the volume_3/data/ directory I can see all the files I upload through ftp.

    My question is, can I just shutdown the NAS, remove the usb stick, and try again, or are there any other steps I should take before trying to install ufs200 again?

    Thank you in advance

     
  9. DJ Soulfly

    DJ Soulfly Addicted to LI Member

    Good work i have installed it to and even my compiled busybox v1.16.1 will run smoothly with UFS200. Also I have managed to get OpenVPN running correctly.

    But i have only one simple question. OpenVPN is started automatically from /etc/rc.d/rc.ufs200_services_startup. Since i have done that my hard disks don´t go in standby mode after 10 min. When i stop the service of OpenVPN manually it goes in standby mode after 10 min. But i want to keep it running with the option that the harddisk will go in standby mode after 10 min. It must be possible since OpenVPN is run from the flash drive.

    Thanks
     
  10. gmmyabrk

    gmmyabrk Networkin' Nut Member

    Just to let you know.

    The download link on the announce page is no longer working. (20120224)
    Rapidshare is returning a 404 error. Seems that all the file-hosting sites are running scared after the Mega raid.

    Is there any other download link available?
     
  11. DJ Soulfly

    DJ Soulfly Addicted to LI Member

    It's still working just tested the download link. If you still experiencing problems try this link https://rapidshare.com/#!download|6...|77000|R~754BFB5F77B5ABD09A25E1A00678E8D5|0|0

    To bad i still haven't got any answer to my above post. I've got a little further it's not OpenVPN related but UFS 1.0 related. With the USB stick removed booting to the stock jac4 the fans en hdd wil be in standby mode after 10 min. With UFS 1.0 not. Anyone?
     
  12. ltoth45

    ltoth45 Serious Server Member

    Hello,
    I have a BestConnection NAS200, have anibody tried this UFS200
    method-working or not?
    And can I use the firmware NAS200_V34R79jac4.bin in my unit?

    Thanks a lot!
     
  13. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    As far as I can tell, the BestConnection NAS-200E is NOT the same as the Linksys NAS200. It's hard to find information about it (all I can find is Hungarian shopping sites) but it looks different and the specifications don't match.

    You should not try to use ANY Linksys/Cisco firmware on the BestConnection machine. They are most certainly NOT compatible.

    ===Jac
     
  14. CarloWPG

    CarloWPG Serious Server Member

    I am having difficulty locating the download described in this thread.

    I have tried both links (like another user in this forum) and have been greeted by a page stating that the file is unavailable. One shows a file size of 0mb and another link shows the file size to be 77mb but is not available to be downloaded.

    A search on RapidShare shows that the file is not available.

    I have been trying to mod this NAS to act as a torrent download device until I have the time to complete the file server I'm assembling completed (almost done just need something minorly important - HDD's lol).
     
  15. jackito

    jackito LI Guru Member

    Hi all,

    Sorry for the problem with the download link. I just noted that the it's not working anymore.
    I tried to upload the file again but I found that I don't have the original file (UFS200-v1.0.rar) anymore.
    I must say that I'm not using NAS200 since several months now, but I still have a UFS200 backup around, the problem is that I need to find time to clean it up, and check that all the scripts are fine for publishing.
    If anyone else have the original file and want to upload it, please feel free to do it and let me know.
    If not, I will try to find the time to clean up my backup and upload it again.
    Thank you all for your interest.

    Jackito
     
    Toxic likes this.
  16. Toxic

    Toxic Administrator Staff Member

    if someone can give me a link to it i'll host it here.
     
  17. wiggmpk

    wiggmpk Networkin' Nut Member

    Desperately looking for this download as well :(
     
  18. wiggmpk

    wiggmpk Networkin' Nut Member

    If anyone has a copy of this, it would be greatly appreciated if I could get a PM with a link or something. Been looking at tinkering with this for a while =/ waited too long to download it.
     
  19. jackito

    jackito LI Guru Member

    I know it's been too long since my last post but finally I found some hours to spend on this project again.
    I will post again really soon, during this weekend, with a new link to download the file, and a surprise that I hope everyone will enjoy..... stay tuned. :)
     
  20. jackito

    jackito LI Guru Member

    At last, UFS200 has it's own website!

    You can download from there UFS200 v1.1. Yes! An updated version with new features added.
    Let me know if you find any problem accessing the new website and feel free to give your feedback about the project and the new release.

    jackito
     
  21. Toxic

    Toxic Administrator Staff Member

  22. wiggmpk

    wiggmpk Networkin' Nut Member

    Total Win, thanks Jackito & thanks Toxic. I noticed you scouring the other threads for the file, good looking out mate.
     
  23. wiggmpk

    wiggmpk Networkin' Nut Member

    Every time I try to boot to UFS200, I get "Permission denied (publickey)" when trying to SSH into the NAS. In addition my FTP/WebGUI account credentials no longer work, admin/admin works though. I get similar symptoms when I had previously tried to change the default busybox, which was directly related to editing passwd. Forcing me to run:
    Code:
    export PATH=/harddisk/volume_3/data/rc.d/busybox-1.16.1:/bin:/sbin:/usr/bin:/usr/sbin
    every time I login via SSH.

    I've tried 2 different flash drives, both USB ports, different power sequences (as suggested in previous posts). I would imagine UFS200 is actually booting, because removing the flash drive restores behavior to normal. Is it accurate to assume that it's at least booting from the flash drive? Any help would be appreciated...
    Code:
    $ cat /harddisk/volume_3/data/rc.d/rc.ufs200_boot
    #!/bin/sh
    # (C) Copyright 2008-2010 Fernando Casas Sch�ssow
    # Distributed under the terms of the GNU General Public License v2
    #
    # UFS200 initscript
    #
     
    DATEANDTIME=`date +%b\ %e\ %T`
     
    if [ -f "/boot/boot_my_custom_kernel" -a ! -f "/boot/.custom_kernel_running" ]
    then
        /bin/echo $DATEANDTIME >> /var/log/rc.ufs200_boot.log
        /bin/echo "Trying to load custom Linux kernel..." >> /var/log/rc.ufs200_boot.log
        /usr/sbin/kexec -l /boot/vmlinuz --append="console=ttyS0,38400 root=/dev/mtdblock1 init=/init"
        touch /boot/.custom_kernel_running
        /bin/rm /harddisk/volume_1/data/rc.d/failskip
        /bin/rm /harddisk/volume_2/data/rc.d/failskip
        /bin/rm /harddisk/volume_3/data/rc.d/failskip
        /bin/rm /harddisk/volume_4/data/rc.d/failskip
        /bin/rm /harddisk/volume_5/data/rc.d/failskip
        /bin/rm /harddisk/volume_6/data/rc.d/failskip
        /bin/echo "Rebooting to the custom Linux kernel loaded..." >> /var/log/rc.ufs200_boot.log
        /etc/rc.d/rc.kexec_reboot
    else
        /bin/echo $DATEANDTIME >> /var/log/rc.ufs200_boot.log
        /bin/echo "Proceeding with normal boot..."  >> /var/log/rc.ufs200_boot.log
     
        # If the system is running on a custom kernel, then let the user know
        # and prepare the system for the next reboot.
        if [ -f "/boot/custom_kernel_running" ]
        then
            /bin/rm /boot/custom_kernel_running
        fi
     
        if [ -f "/boot/.custom_kernel_running" ]
        then
            /bin/mv /boot/.custom_kernel_running /boot/custom_kernel_running
        fi
     
        # Then run my tasks
        /bin/echo "Launching rc.ufs200_basic_features..."  >> /var/log/rc.ufs200_boot.log
        /etc/rc.d/rc.ufs200_basic_features &
        /bin/echo "-----------------------------------------------------------------------------------" >> /var/log/rc.ufs200_boot.log
    fi
    
    Code:
    $ cat /harddisk/volume_3/conf/passwd
    root:y2dafD0lPxqnMpEtbLQ:0:0:root:/:/bin/sh
    bin:x:1:1:bin:/bin:
    lp:x:4:7:lp:/share/spool:
    mail:x:8:12:mail:/var/spool/mail:
    ftp:x:14:50:FTP User:/:
    nobody:x:99:99:Nobody:/:
    ourtelnetrescueuser:x:100:100::/home/user:/bin/sh
    guest:xqnMpE/plEnFs:501:501::/home/user/guest:/dev/null0
    sysadmin:scpcnq5xqnMpEFtCaRQ:502:501::scB0d.SmdNCs2:/dev/null1
    Code:
    $ cat /harddisk/volume_3/conf/passwd.ufs200
    root:y2dafD0lPxqnMpEtbLQ:0:0:root:/:/bin.newbusybox/sh
    bin:x:1:1:bin:/bin:
    lp:x:4:7:lp:/share/spool:
    mail:x:8:12:mail:/var/spool/mail:
    ftp:x:14:50:FTP User:/:
    nobody:x:99:99:Nobody:/:
    ourtelnetrescueuser:x:100:100::/home/user:/bin/sh
    guest:xqnMpE/plEnFs:501:501::/home/user/guest:/dev/null0
    sysadmin:scpcnq5xqnMpEFtCaRQ:502:501::scB0d.SmdNCs2:/dev/null1
    mysql:x:15:77:MySql server:/var/lib/mysql:/bin.newbusybox/sh
    lighttpd:x:16:78:Lighttpd server:/home/lighttpd:
    amuled:x:17:79:aMuled user:/home/amuled:
    Code:
    $ cat /harddisk/volume_3/conf/group
    root:x:0:root
    lp:x:7:daemon,lp
    mail:x:12:mail
    ftp:x:50:
    nobody:x:99:
    users:x:100:
    administrators::500:sysadmin
    everyone::501:guest,sysadmin
    guest::502:guest,sysadmin
    mysql:x:77:mysql
    lighttpd:x:78:lighttpd
    amuled:x:79:amuled
     
  24. Tyshone

    Tyshone Reformed Router Member

    I have the same problem. However, everything works with the original version (UFS200 v1.0) on the same flash drive.

     
  25. wiggmpk

    wiggmpk Networkin' Nut Member


    If at all possible, could you please upload v1.0 (preferably unmodified)
    I'd like to give it a shot and see if I can get it working.
     
  26. hmiprueba

    hmiprueba Reformed Router Member

    I have the same problem too. I cannot login with the user root account. After plug mi usb flash drive. Them i unplug the usb and login pefectly with de root user. Whats happend? Please upload de 1.0 version. I want to see how it works on my nas. Thanks. I know my english is terrible. :(
     
  27. Tyshone

    Tyshone Reformed Router Member


    Below is a link to my Dropbox account where v1.0 is located. If you are unable to access, please provide your email address so I can give you access.

    https://www.dropbox.com/s/3dssv6z5qowaxsk/UFS200-v1.0.rar
     
    hmiprueba likes this.
  28. hmiprueba

    hmiprueba Reformed Router Member

    hey man!, thank you!!! Where did you get it? I get tired of looking on the web, but I have not found anywhere! I will try this to see if I have luck.
    Many, Thanks Tyshone.:)
    HMI.

     
  29. hmiprueba

    hmiprueba Reformed Router Member

    yeahh works!!. Many thanks Tyshone, obviously there is a problem with the boot file of version 1.1 of UFS200.
     
  30. V3nn3tj3

    V3nn3tj3 Reformed Router Member

    Anyone has found the fix yet for the public key problem?

    Code:
    The client has disconnected from the server.  Reason:
    Unable to authenticate using any of the configured authentication methods.
    Also i don't have any shares exept for 20 times: FLASH_1_1 and can share the disks or create folders on the disks.
    Also my first hard drive (which was non-journaled) now shows up as journaled and has a size of 0?

    I removed hdd's, reinstalled normal firmware, did reset, booted again with hdd's and reformatted them after partions were removed, reboot, installed jac4, booted again, did all the edits on ssh, added the rc.d folder and file, reboot with usb stick in usb port 1, waited about 2 houres before the nas got online, now i have these problems.


    [​IMG]
    [​IMG]
     
  31. kurti

    kurti Reformed Router Member

    there is a problem with the boot file of version 1.1 of UFS200.
     
  32. Flaya

    Flaya Network Newbie Member

    Just found this forum and was wondering if there is a "simple" guide to follow for get up 'n running with jac4+ufs200?

    I'm using win7 btw, and kno very little about ssh and linux. I'm aiming at using my nas200 for watching movies and playing games on my ps2. i have an external hdd (NTFS) that i would like NOT to reformat, connected to the nas as well.
     
  33. Martyn Fleetwood

    Martyn Fleetwood New Member Member

    anyone got a link to version 1.1 of UFS200 file?
     

Share This Page