1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Any hope for WRT54G UPnP DirectPlay failure?

Discussion in 'Cisco/Linksys Wireless Routers' started by Agrajag, Apr 4, 2005.

  1. Agrajag

    Agrajag Guest

    Guys, I own a WRT54G v2 that I've been happily using for some time. I also started out with a BEFSR41 that the WRT54G replaced and, just last week, replaced my USR CMX cable modem with a Linksys BEFCMU10. The two stack nicely and I figured all would be well.

    Then Trillian noted that things work better if you enable UPnP. It was off for me and I'd never been able to get files transfered with it or audio chats to work (don't care about video chats). Trillian is an IM interface that supports al the top IM clients in case you're not familiar with it.

    So I turned it on but nothing really improved. I also turn on UPnP in XP and no, I don't have their goofy firewall enabled.

    Anyway, I then ran into a program that heavily depends on DirectPlay, a component of DirectX and it was failing.

    I then ran DXDIAG (DirectX Diagnostics) and went to the Network tab and clicked on the DirectPlay Test button. It failed giving a rather useless error message. I turned off UPnP and then the test worked. GREAT.

    I then upgraded the bios, tried HyperWRT too and nothing seemed to work. Out of frustration and curiousity I pulled the BEFSR41 out of the closet and swapped it in. Several things happened.

    First, for the first time XP kicked in and saw the router and some tray icon popped up saying it saw a UPnP device and was setting it up. Hey! That's good news. Then I found I could do audio with no problem in the default MSN Messenger client which didn't work before. Still trying to get it going in Trillian..... Also, the DirectPlay test works flawlessly with UPnP enabled.

    For now I'm not using anything wireless. I only added the WRT54G to go wireless with my XBOX but when that acted up, I ran wire down to it and enjoyed the speed increase and stability. So, for the time being I'm set. The question is, what should I do now? I've brow-beat Linksys support over this issue and gotten nowhere. Is this a POS that I just need to live with and hope it gets fixed some day or is there hope?

Share This Page