1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Any success getting the WRT54G to authenticate RADIUS?

Discussion in 'Cisco/Linksys Wireless Routers' started by anthropolemic, Nov 24, 2005.

  1. Hey all,

    I love my WRT, but I'm having an issue that really prevents me from doing what I want with it.

    I've got a WRT54G 3.1 flashed to DD-WRT v23 (Nov. 23 build). I've also got a Windows 2000 Advanced Server with IAS installed, serving up RADIUS authentication using my Active Directory domain controller. I had a D-Link which authenticated against it fine (but did little else right, hence why I have the WRT now). The WRT, however, doesn't successfully authenticate with it regardless of what firmware is loaded. I tried two revisions of the official Linksys firmware before I moved on to DD-WRT, with no success anywhere. I can put in my credentials, and nothing will happen; I won't see any sign of success in the log or anything, and eventually the client will return to the login screen or autoconfigure a 169.254.*.* address. If I put incorrect credentials, or change the shared secret on one end or the other, I can get an error message generated in the log when I try to authenticate, indicating there is some communication. And again, the D-Link authenticates against this exact configuration perfectly.

    Is there some trick to getting this all to work? Or is this something I'll have to live without?

    Thanks!
     

Share This Page