1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anyone create a build of Tomato 1.07 /w ATFTPD

Discussion in 'Tomato Firmware' started by GoldServe, Jul 4, 2007.

  1. GoldServe

    GoldServe Network Guru Member

    Can anyone create a build that has atftpd loaded? It would be perfect if I could get something like that!
     
  2. mikester

    mikester Network Guru Member

    Yes I can ... but why would I want to?
     
  3. GoldServe

    GoldServe Network Guru Member

    I have a wan device that gets a configuration file from a tftp server and it would be awesome if it can be integrated into the router so i don't need my computer to do that. Very simple, one config file.
     
  4. azeari

    azeari LI Guru Member

    heh perhaps its best to add a build with ipkg.. then it'll be easily customized for all the individual needs
     
  5. roadkill

    roadkill Super Moderator Staff Member Member

    ipkg already exists but the config files are readonly
     
  6. mikester

    mikester Network Guru Member

    Two words...

    CIFS1
    winrar
     
  7. GoldServe

    GoldServe Network Guru Member

    The whole point is to make it self sufficient and not use cifs. That last time i tried, I could not get ipkg to install and work.
     
  8. roadkill

    roadkill Super Moderator Staff Member Member

    you can use a script to download the IPKG from internet and decompress it to /tmp
    then run the TFTP server with config file parameter so it will run without problems.
    if I recall correctly someone has asked for this before.
    :grin:
     
  9. GoldServe

    GoldServe Network Guru Member

    I can't really get it from the internet because the modem has to get the config file before I'm allowed to go online...so that doesn't work.
     
  10. roadkill

    roadkill Super Moderator Staff Member Member

    what router do you use?
     
  11. GoldServe

    GoldServe Network Guru Member

  12. roadkill

    roadkill Super Moderator Staff Member Member

    version?
     
  13. GoldServe

    GoldServe Network Guru Member

    the GL is the linux one with 4mb flash and 16mb ram
     
  14. roadkill

    roadkill Super Moderator Staff Member Member

    there are two versions 1.0 and 1.1 check what you have here
    if you have 1.1 you can't use jffs - I saw some of the guys reporting this here never really tried it myself.
    so if you can use jffs please do and put the ipk files on the jffs
    and then you can simply run it with a script at boot time.
     
  15. GoldServe

    GoldServe Network Guru Member

    Okay, thanks for the suggestion. I'll give it a try!
     
  16. roadkill

    roadkill Super Moderator Staff Member Member

    Good Luck
    P.S.
    do a search in the forum because I almost certain I saw that question here for VOIP devices.

    :grin:
     

Share This Page