1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anyone RMA'd in the UK?

Discussion in 'Other Linksys Equipment' started by DarrenBolton, Apr 7, 2005.

  1. DarrenBolton

    DarrenBolton Network Guru Member

    Hey all,

    For the last week I've been trying to get a RMA for my WAG54G v1.2, i've been given the email address for the uk rma section but it is now a week since I emailed them and have had no reply... not even a autorespone to say my message had been recieved. I even tried sending a second email to which I still have not recieved any reply.

    So i was just wondering if anyone else in the uk has managed to get a RMA and if so how they went about it.

    Cheers
     
  2. Morpheus

    Morpheus Network Guru Member

    I have never tried the UK RMA, Can you not take it back to the Shop you got it from?
     
  3. DarrenBolton

    DarrenBolton Network Guru Member

    im into the manufacturers warrenty now, it was early january when it was purchased.
     
  4. noelabc

    noelabc Network Guru Member

    Do you have a case number? You should include a case number provided by a tech support. Just to ensure that proper measures / troubleshooting steps are taken before replacing the device.
     
  5. DarrenBolton

    DarrenBolton Network Guru Member

    yeah i included this information.

    I've just this moment getting a repsonse so fingers crossed
     
  6. Morpheus

    Morpheus Network Guru Member

    you will still have a 12 month warrenty from the shop.
     
  7. Wild_Weasel

    Wild_Weasel Network Guru Member

    I've used the RMA process in the UK once, it worked OK to a degree. They will require the old unit to be shipped prior to submitting a new one, I wasn't happy with this and informed them that I need a replacement unit before I would send the old unit back. They eventually relented and sent me a replacement unit (v2), this was worse then my original 1.2 and I informed them of this. Still sat here with both units waiting to hear what the next steps are!
     
  8. Ian_m

    Ian_m Network Guru Member

    I have RMA'ed 3 UK WAG54G's (one home two for work all similar unreliability and complete failure).

    After phone support agreed on (a Tuesday) to RMA I e-mailed uk.rma@linsys.com, got a reply back Tuesday evening explaining they needed proof of purchase.

    I PDF'ed my Ebuyer account page and sent that Wednesday.

    Then Wednesday got a word document which I faxed back with address details etc etc.

    Then Thursday got a approval for RMA from Linksys and in the evening an electronic UPS posting label.

    Put it in a UPS bag was collected Monday afternoon.

    Replacement arrived following Tuesday.

    Guess what, 2 of these replacements (V1.1) are all failing in a similar way, one has gone back to supplier for refund and other (8 months old) back to Ebuyer demanding a refund as being unfit for purpose. Both these units have been replaced with NetGear DG834G's as 24/7 operation is required and have heard absolutely nothing one site with theirs so I assume it is working. My home DG834G is fine as well, 100% wireless connectivity 100% of the time, wonderfull.
     

Share This Page