1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anyone use HyperWRT and have UPnP problems?

Discussion in 'HyperWRT Firmware' started by frad, Sep 5, 2004.

  1. frad

    frad Network Guru Member

    Before I upgrade to 1.3 I was wondering if anyone has been having trouble with the UPnP feature with it?

    I ask since I am currently running firmware 2.04.4 and every now and then the UPnP stops working. What I mean by this is, after a while windows stops seeing the "Internet Connection" icon under Network Connections, which is the first sign. After that if i try to use any program that uses UPnP they don't work either. Like Azureus or MSN Messenger file transfers.. I thought that maybe the problem was on the Windows side and heard that SP2 has some significant Wireless connection improvements.. So I installed that and still have the same problem.

    I found someone else that has the exact same problem too. here: http://www.askmarvin.ca/forums/index.php?showtopic=2218&hl=upnp

    Has anyone had a similar UPnP issue? I already have come across a few other threads out there on UPnP problems but I am talking specifically about this issue. This issue of UPnP having to be reset every now and then.
     
  2. Toxic

    Toxic Administrator Staff Member

    UPNP has not ben very good for ages. not many use it due to security issues
     
  3. frad

    frad Network Guru Member

    I am aware of its potential security issues.. but for the most part feel they are as much a rish as using a web browser... you just need to be careful not to let just any code run on your system... a Upnp torgan or virus could indeed render your firewall useless but that not my point...


    Again though... are there any people out there with the same symptoms I have been having in regards to Upnp and the WRT54G?
     
  4. Esquire

    Esquire Mesquire Staff Member Member

    Interesting that you brought up this subject, but this could be an issue with Windows rather than with the UPnP on the WRT54G. It's a very old issue on the WRT54G (at least a year old) that I had discussed already elsewhere, even with Wifi-Box himself, who confirmed the UPnP was working. Having said that, there were also reports of the UPnP on older versions firmware not functioning properly when used with ADSL/PPPoE connection, although I haven't quite fully experienced this - I found a way to bypass it.

    My MSN Messenger reports the presence of a UPnP NAT connection even though sometimes the Internet Connection is not present. Just yesterday none of my wireless clients could detect the presence of UPnP (thus no Internet Connection icon) on startup, but my LAN clients could. I pulled out the PC cards on my notebooks, waited a while and reinserted the card and instantly the Internet Connection icon is back once the wireless LAN was re-established!

    You can also try resetting or reboot the router (not the full hardware reset) - I find this too allows Windows redetects the presence of UPnP once network connection is re-established.
     
  5. jasqid

    jasqid Network Guru Member

    YES!
    Internet Connection in My Net. Places was totally gone there for a while. played with SERVICES and double checked that the gateway was installed. Upon reboot, I can see the Internet Connection but it says it's disabled. I've tried to enable it and I get Can Not be Enabled errors.
     
  6. Esquire

    Esquire Mesquire Staff Member Member

    Have you tried rebooting your router?

    Which firmware and version are you using? What type of broadband connection?
     
  7. frad

    frad Network Guru Member

    hmm... well at least there are others with the same issue.. Have you heard of anyone with the same problem who was not using the WRT54G, but another brand of router? Like Dlink or something else? becuase i still have a feeling its Linksys fault.
     
  8. Esquire

    Esquire Mesquire Staff Member Member

    I have seen Buffalo routers also exhibiting problems with UPnP. Windows actually reported a problem rather than simply disappearing or showing a Disabled/Disconnected status.

    The UPnP is software/firmware implemented (there was no UPnP support originally) and at least on my WRT54G and most other units I have seen it has been working, even though not as well as I'd like to see.
     
  9. Esquire

    Esquire Mesquire Staff Member Member

    I managed to duplicate your missing Internet Connection icon tonight - I just kept rebooting until it stopped showing up on boot.

    The strange thing was MSN Messenger still reported a UPnP connection (Tools > Options > Connection). Does yours do that?

    Then I tried rebooting the computer - no Internet Connection icon. I repeated the reboot several times and still no icon. I tried a simple reset on the router again and again - no icon still. I then disconnected from my WLAN (SP2 has a Disconnect button), waited about 30 seconds and reconnected, and there was the icon in question as soon as network was established. Does this work for you?

    I also noticed when I changed any wireless setting, the Internet Connection icon would disappear and reappear. Like I said, it's not working as well as I'd prefer to see - there should be some manual configuration/override on the router side, rather than a simple on/off switch.
     

Share This Page