1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ARGH!!! RV016 -- XP connecting to RV016 VPN

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by xitx, Dec 7, 2004.

  1. xitx

    xitx Guest

    Alright, this RV016 totally sucks, I think.

    First, the DMZ port doesn't work. I put my Web server out on the DMZ and I could connect to it successfully. However, I could not get on the Internet from the Web server. This sucks because I can't get OS and software updates and virus definitions.

    DMZ Host does work, exposing a private IP to the Internet.

    What sucks even more, I do not think the VPN works either. I have tried every configuation 3 or 4 times. First I tried XP, then Greenbow, Sentinel, now I am trying SafeNet (after spending $149).

    I have tried different settings and still can not connect to the VPN. I have tried from my DSL connection, which is behind a Linksys wireless B router. I have also tried from my clients Verizon Wireless NationalAccess Broadband account, NO DICE!

    For the past 3 days I ahve been on every single page referenced on this board and tried a number of different settings and I still can not connect.

    Has anyone had ANY luck setting up a Client -> RV016 VPN connection?

    I do not think it is possible.

    Can someone reccomend a decent, esy to setup, VPM router to buy? THAT WORKS?

    Thanks mucho

    Bryan
    xitx.com
     
  2. majorman

    majorman Network Guru Member

    I have had all of the same issues.

    The VPN (router to router) will not work. I have had to use pass through.

    Also, the DMZ is useless as you described. It offers no real "DMZ" functionality. Some deranged programmer came up with useless DMZ behavior.
     
  3. jorge98

    jorge98 Network Guru Member

    QuickVPN -> RV08

    I finally managed to get the QuickVPN client behind a NAT/firewall to work with the RV08. It appears that the RV042's firmware is very different than the RV08, so the RV models do NOT have the same VPN functionality (there isn't a built-in PPtP server option for the RV042, though I'm still trying to get it working with the RV082).

    The Linksys RV082 seems to have more revision history, so I would venture to guess that the RV042 and possibly the RV016's firmware have not been updated for QuickVPN support just yet.

    Here are a few things that I had to do get things working for QuickVPN behind a NAT/firewall with a remote RV08:

    1. Upgrade to the latest firmware version (1.1.6.3 as of 11/03/04).

    2. Inside the "Firewall" section, enable the HTTPS service. Make sure to Save Settings too.

    3. Inside the "VPN" section, click on the VPN Client Users. Add a username and password that will be used for the QuickVPN Client. Make sure the user that you will be using is selected as Active.

    4. Make sure that your client's NAT/firewall has IPSEC passthrough capability turned-on. If you don't, you may see that the QuickVPN client successfully connects but freezes at "Verifying Network".

    5. Your client's IP subnet should not conflict with the other remote networks. If anyone has anyone experiences with subnetting with these units for multiple remote clients, please let me know

    A good place to debug your problem is to look at the error logs in the wget_error.txt in the directory where the QuickVPN client is installed (i.e. C:\Program Files\Linksys). The wget program apparently tries to connect via HTTPS to the RV08 to obtain VPN server information. If the connection is successful, you can see several .conf files downloaded into the same directory.

    The QuickVPN client also contains the IPSEC.exe and IPSEC.msc, which indicates to me that it actually is just a program to automate the part where you normally would have to follow the 16-page instruction that Linksys has made available.

    Hope this information is useful. Again, check the firmware's revision history carefully!
     
  4. mterry

    mterry Network Guru Member

    You're right, it looks like the Quick VPN client simply configures the built in XP/2000 VPN services and fires them up with the correct parameters. It's mainly a shell over these services. Pretty slick, actually!

    If you're using Quick VPN, make sure the XP service "IPSEC Services" is running, or you will fail to connect - without an indication why.

    I've successfully used it with the new RV042 firmware beta (1.3.3), it's great and much easier than any other VPN option. Because it's simply using the built in XP IPSEC, no reboot required on install!
     
  5. manylink

    manylink Guest

    I finnaly got both RV082 (1.1.6.11) and an RV016 (2.0.3) working with the quickvpn client software.

    The trick to getting the rv016 working was to enable https on the firewall settings. It was not on be default :evil: . The RV082 had it enable by default.

    No where other than a post here did I see mention of https being required for quickvpn. Once I enable it the VPN software worked like a charm.

    I appears that the software uses a SSL connection to get the preshared key and network settings to configure the client policies on the fly.
     
  6. DocLarge

    DocLarge Super Moderator Staff Member Member

    Guys,

    a majority of what you've found out has already been documented in the "Quickvpn Setup Guide

    http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&t=5173 (it's posted as a Sticky and is on the homepage),

    and "Reasons Quickvpn Won't Connect"

    http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&t=5911

    However, being I don't own any of the RV0XX routers, but use quickvpn also, I'm positive there are a few issues that I'm unable to document that you guys might be able to (and have already found).

    I'm going to edit my original "Reasons Quickvpn Won't Connect" post so you guys can list any particular discrepancies to better aid the RV0XX users, if you don't mind. No doubt this will help...

    Doc
     

Share This Page