1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Assign wan port to switch

Discussion in 'Tomato Firmware' started by InsaneNutter, May 7, 2009.

  1. InsaneNutter

    InsaneNutter Addicted to LI Member

    I’m using my old WRT54G running Tomato as a switch, is it possible to use the wan port as another port on the switch?

    Thanks!
     
  2. humba

    humba Network Guru Member

    Yes... a quick forum search should yield at least one or two threads on the subject
     
  3. InsaneNutter

    InsaneNutter Addicted to LI Member

    I have entered this command on the router:

    nvram set vlan1ports=""
    nvram set vlan0ports="4 3 2 1 0 5*"
    nvram set manual_boot_nv=1
    nvram commit
    reboot

    However the WAN port still doesn’t appear to be usable as a switch

    Is that the correct settings for a WRT54G version 1.1?
     
  4. Kiwi8

    Kiwi8 LI Guru Member

    The port numbers are only reversed from V4.0 onwards I think.

    Version 1.1 should be using the following:
    nvram set vlan0ports="0 1 2 3 4 5*"
    nvram set vlan1ports="5"
    nvram set manual_boot_nv=1
    nvram commit
    reboot
     
  5. InsaneNutter

    InsaneNutter Addicted to LI Member

    Hi,

    I’ve done what you suggest with no luck, the device connected to the WAN port still can’t obtain an ip address (from another router on the network) devices connected to the other ports can get an IP.

    If I do an nvram get, these are the results:

    # nvram get vlan0ports
    0 1 2 3 4 5*
    # nvram get vlan1ports
    5

    Sorry to be a pain!
     
  6. Kiwi8

    Kiwi8 LI Guru Member

    U have done the right steps already, but I do not know why it still doesn't work.
     
  7. InsaneNutter

    InsaneNutter Addicted to LI Member

    Humm I dont need to play with other settings on the router do i?

    For WAN / Internet I changed the settings in the router config mode from DHCP to disabled and on the routing table page mode is set to router from gateway.

    The router is also not acting as a DHCP server.
     
  8. InsaneNutter

    InsaneNutter Addicted to LI Member

    I flashed the router with DDWRT and used the option “Assign WAN Port to Switchâ€

    Everything’s working perfectly now.
     
  9. InsaneNutter

    InsaneNutter Addicted to LI Member

    Tomato 1.24 has the added option to use WAN port for LAN in Basic: Network.

    Someone out there was listening :thumbup:
     
  10. Kiwi8

    Kiwi8 LI Guru Member

    It has always worked prior to Tomato 1.24, just that Tomato 1.24 made the function available in the GUI.
     

Share This Page