1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Asus RT-N15u - another router supported by tomato :)

Discussion in 'Tomato Firmware' started by shibby20, Mar 24, 2012.

  1. shibby20

    shibby20 Network Guru Member

    Asus RT-N15u

    CPU: Broadcom BCM5357 500MHz
    RAM: 64MB
    Flash: 8MB
    USB: 1 port 2.0
    Ports: 5x Gigabit
    Radio: 2.4GHz N 300Mbps 2T2R
    Antennas: 3, integraded in PCB

    Tomato status: works all without "LAN" led

    rtn15u.png

    Tomato firmware will be release soon.

    Best Regards!
     
  2. shibby20

    shibby20 Network Guru Member

  3. Dark_Shadow

    Dark_Shadow Addicted to LI Member

  4. Toastman

    Toastman Super Moderator Staff Member Member

    nice work, as always, shibby!
     
  5. mcchuk

    mcchuk Serious Server Member

    nice work, I just try it this morning, it works fine, but
    i) the BT GUI cannot be loaded.
    ii) the USB Flash ( Kingston 2GB) cannot be detected..
     
  6. shibby20

    shibby20 Network Guru Member

    @Dark_Shadow as all RT-N1x just flash using Asus firmware Restoration
    @Toastman - thx :)
    @mcchuk - BT gui works. You propably set wrong "download directory". USB also works. On screen you can see my 3G USB Modem conection. I checked also my USB HDD drive and flashdrive Goodram Edge 16GB. All devices are detected without problem.
     
  7. mcchuk

    mcchuk Serious Server Member

    Hi shibby
    Thanks, it works after i use the firmware upgrade to reload the image again. The usb flash is mounted and the BT GUI is working. But i cannot make the BT Running, after upload the BT seed file and click "start". There are no file or directory created in the download directory..
    The download directory is /mnt/DATA/share
    what should i do ???

    Other issue : the Wifi connection speed is only 54Mps, this router h/w should be able to do 144Mps and above .. any setting can correct this issue.. ???
     
  8. shibby20

    shibby20 Network Guru Member

    where have you mounted USB drive?

    i will check wireless speed. I found one my mistake. I didn`t include gigabit support ;) It`s limited to 100mbps. Will fix this.
     
  9. mcchuk

    mcchuk Serious Server Member


    TomatoUSB shows the follow mount point Description:-
    Description
    Kingston DataTraveler2.0
    Partition 'DATA' fuseblk (1,905.90 MB / 1,864.47 MB free) is mounted on /tmp/mnt/DATA
     
  10. shibby20

    shibby20 Network Guru Member

    do you have "share" directory on Kingston? Try set Download Directory as:
    /tmp/mnt/DATA
     
  11. shibby20

    shibby20 Network Guru Member

    btw i have 300Mbps wireless connection
     
  12. mcchuk

    mcchuk Serious Server Member

    i try this morning with the Download Directory as : /tmp/mnt/DATA the usbDisk Mount Point , then the BT start to work..
    thanks,
     
  13. mcchuk

    mcchuk Serious Server Member

    The USB Disk Upload speed form PC via gigabit lan for 500MB take 5-6 minute , about 1.6MB/s. what is your test condition ???
     
  14. shibby20

    shibby20 Network Guru Member

    over wireless or LAN?
     
  15. xtacydima

    xtacydima LI Guru Member

    hey, awesome job, I think we need an up to date table of supported routers, terms, builds, and features available for each developer - we already have a table layout at tomatousb.org if anyone can just update it, it's getting hard and confusing to follow, even for those of us whom frequent the website
     
  16. mcchuk

    mcchuk Serious Server Member

    upload via gigabit Wire LAN from PC.
     
  17. shibby20

    shibby20 Network Guru Member

    USB speed over samba = 11.2/9.8MB/s read/write
    USB speed over ftp = 12.6/5.9MB/s read/write
     
  18. hyper

    hyper Serious Server Member

    How is the performance & stability of this router - is it one to recommend?
     
  19. shibby20

    shibby20 Network Guru Member

    i think it does. this is really nice router. I dont use it because i have RT-N66U but when i tested this router i haven`t any problems.
     
  20. nomejodas

    nomejodas Network Guru Member

    where can you buy this router? I don't see it on amazon or newegg.
     
  21. shibby20

    shibby20 Network Guru Member

    i cant tell you ;) but i see this router on ebay.
     
  22. nomejodas

    nomejodas Network Guru Member

    ehh I don't want to buy on ebay. Too risky. It's kinda expensive and no dual band either.
     
  23. SupremeHeatgun

    SupremeHeatgun Serious Server Member


    I am now using RT-N15U with build 92, but it still limited to 100mbps. Any plan to fix it. Thx!!
     
  24. Crystal Maiden

    Crystal Maiden Serious Server Member

    how can i use this? i can't find asus firmware restoration utility.

    edit: nevermind, found and done. thanks.
     
  25. ololizoz

    ololizoz Serious Server Member

    Any update? :)
     
  26. shibby20

    shibby20 Network Guru Member

  27. Rickard Lindfors

    Rickard Lindfors Serious Server Member

    Hi and thanks for the support of the rt-n15u.

    I use build 097 on my rt-n15u. Everything works great except from the Open VPN server. It seems that the gui replace some of the previous saved settings when i try to start the openvpn server by hitting the button "start now".

    Information i the fields "port" and "Encryption cipher" for server 1 and "netmask" and "TLS Renegotiation Time" and some more fields for server 2 erases when I hit the button "start now".

    Am I doing something wrong or is it a bug?

    Regards,
    Rickard
     
  28. aa007

    aa007 Serious Server Member

    Hi,

    I would like to ask if the LAN LED will work in the future? I kind of miss it :)

    Thanks
     
  29. kthaddock

    kthaddock Network Guru Member

    If Openvpn setting change when you hit save then your config doesn't match. Do you use Custom Configuration ? Does server start ?
     
  30. SupremeHeatgun

    SupremeHeatgun Serious Server Member

    For build 101 Wan port speed, it limit to 100mbps while RT-N15U should support 1gbps wan port although it can run up to around 300-400 mbps in real case
    And for wireless lan, when i use N mode it can only have 2-3mbps when testing speed while G mode can run up to 20--30mbps
     
  31. nurofen

    nurofen Serious Server Member

    :)
     
    Last edited: Oct 7, 2013
  32. PPiux

    PPiux Reformed Router Member

    Good day guys... I would love to if anyone can give a hint about my problem (You can through me a stone if it is too stupid)

    I have own a RT-N15U for about a year now, installed on it tomato-K26USB-1.28.RT-N5x-MIPSR2-114-VPN
    and its been working flawlessly. Today I decided to update it to tomato-K26USB-1.28.RT-N5x-MIPSR2-116-VPN so, the latest version. Before I flashed it I did a backup configuration, nothing special to backup just being lazy to manually put in all the VPN info. I also used the option "After flashing, erase all data in NVRAM memory", everything went ok, then I restored the configuration backup and I found an odd problem with Port forwarding. I then did a "Erase all data in NVRAM memory and I did reconfigured all manually but, the same problem.

    On the Miniupnpd Custom configuration I have add:

    iptables -I FORWARD -i tun11 -p udp -d XXX.XXX.X.XX --dport YYYYY -j ACCEPT
    iptables -I FORWARD -i tun11 -p tcp -d XXX.XXX.X.XX --dport YYYYY -j ACCEPT
    iptables -t nat -I PREROUTING -i tun11 -p tcp --dport YYYYY -j DNAT --to-destination XXX.XXX.X.XX
    iptables -t nat -I PREROUTING -i tun11 -p udp --dport YYYYY -j DNAT --to-destination XXX.XXX.X.XX
    iptables -I FORWARD -i tun12 -p udp -d XXX.XXX.X.XX --dport YYYYY -j ACCEPT
    iptables -I FORWARD -i tun12 -p tcp -d XXX.XXX.X.XX --dport YYYYY -j ACCEPT
    iptables -t nat -I PREROUTING -i tun12 -p tcp --dport YYYYY -j DNAT --to-destination XXX.XXX.X.XX
    iptables -t nat -I PREROUTING -i tun12 -p udp --dport YYYYY -j DNAT --to-destination XXX.XXX.X.XX

    XXX.XXX.X.XX = The local machine IP I want to forward the port
    YYYYY = The port number and they are the same port numbers forwarded on my VPN service as they were before.
    tun11 and tun12 are the clients 1 and 2 on Tomato.

    This is a pic from before (I intentionally covered the port number with X's):
    [​IMG]
    ...And a pic from after:
    [​IMG]

    As you can see with uTorrent running I don't get the message saying ports are open and I really don't know what else to do and my knowledge has hit a wall, any help will be appreciated.

    Thanks
     
    Last edited: Feb 18, 2014
  33. Teo En Ming

    Teo En Ming Network Newbie Member

    Dear Shibby,

    I flashed my Asus RT-N15U with your tomato firmware versions 88-EN and 116-EN (BT-VPN and Big-VPN). However, I am unable to get your tomato firmwares to work. Any idea what's wrong?
     
  34. KertBert

    KertBert Network Newbie Member

    I flashed my Asus RT-N15U with tomato-K26USB-1.28.RT-N5x-MIPSR2-121-Big-VPN.trx. The USB Disk Upload speed form PC via gigabit lan, up to 2MB/s. what is your test condition for 11.2/9.8MB/s read/write?
     

Share This Page