1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Asus wl-330ge wireless client doesn't work with Toastman or Shibby

Discussion in 'Tomato Firmware' started by gfunkdave, Mar 30, 2013.

  1. gfunkdave

    gfunkdave LI Guru Member

    I dug up my WL-330gE thinking to use it in wireless client mode in hotels and such. I can't get it to work with either Toastman or Shibby builds, even though it's supposed to be supported.

    With Toastman K26 7501.3-Mini or Std (both are under 4MB) (tomato-K26-1.28.7501.3MIPSR2Toastman-RT-Mini), the router is nonresponsive. Lights seem to work but I can't ping it at even after setting a static IP on my laptop. I *think* the problem is that this is a MIPSR1 router, but this firmware version is MIPSR2, even though Toastman says WL-330ge is supported.

    With Toastman MIPSR1 K24 builds (tomato-K26-1.28.RT-MIPSR1-108-Mini), the router boots up but thinks it's a different Asus router. Clicking on Basic -> Network makes the router hang. Logging in via Telnet shows that CPU load is very high - around 1.00.

    With Shibby build 108 mini (tomato-K26-1.28.RT-MIPSR1-108-Mini), the router comes up and everything is fine until I put it in wireless client mode. In order to put it in wireless client mode, I have to set the WAN connection to something besides Disabled. I select DHCP, put in my wireless network SSID and key, and then the router becomes nonresponsive. I can't ping it on its address or access the web config screens. BUT if I look at my main router's Active Devices screen, I can see the little Asus router shows up as an active wifi client with an IP on my LAN and everything. Also (and this is really weird) even though I can't ping the little Asus router on its LAN side, it still serves DHCP to my laptop.

    Shibby or Toastman, or anyone else - any ideas?

  2. gfunkdave

    gfunkdave LI Guru Member

    Bump - any ideas? I've put DD-WRT on it for now, which works great. But I'd prefer Tomato if possible.
  3. koitsu

    koitsu Network Guru Member

    Re: MIPSR1 vs. MIPSR2 on Toastman --

    1. When on DD-WRT, please provide here the output from cat /proc/cpuinfo
    2. The high load may be caused by an interrupt being constantly generated or polled. This is very difficult to debug on embedded devices where tools/utilities for troubleshooting something this low-level are very few. The best I could recommend is output from cat /proc/interrupts ; sleep 1 ; echo ; cat /proc/interrupts as well as output from /usr/bin/top -b -n 1.
  4. gfunkdave

    gfunkdave LI Guru Member

    Thanks, koitsu.

    root@DD-WRT:~# cat /proc/cpuinfo
    system type             : Broadcom BCM5354 chip rev 3
    processor               : 0
    cpu model               : BCM3302 V2.9
    BogoMIPS                : 239.20
    wait instruction        : no
    microsecond timers      : yes
    tlb_entries             : 32
    extra interrupt vector  : no
    hardware watchpoint     : no
    VCED exceptions         : not available
    VCEI exceptions         : not available
    I am actually using the wl-330ge at the moment since my home internet is down - stealing from a neighbor's wifi and using the wl-330 as a secondary gateway on the network. :) So I can't install Toastman's K2.4 Tomato at the moment. But, I do remember looking at top when it was hanging, and httpd was responsible for the high CPU load.
    Thanks for any input...though I'm still not sure why Shibby's build that has supported this for a while doesn't work in wireless client mode.
  5. koitsu

    koitsu Network Guru Member

    Yes, this is a MIPSR1 unit (older CPU).

    It's too bad there isn't good devtools (unless you have Entware, etc.) to help debug that issue. You could have kill'd (not -9'd) httpd, then tried restarting it under strace to see what all transpires/what it's churning on.
  6. gfunkdave

    gfunkdave LI Guru Member

    So between the two 2.4 builds I used, even though Toastman's httpd was having issues, Shibby's wasn't. His worked fine - until I put the device in Wireless Client mode. Then, I still got DHCP service from it with my laptop plugged into its LAN port. I just couldn't ping anything - either the wl-330ge on its LAN side or my home router, which would have been on the wl-330ge's WAN side. But I did see the wl-330ge as a wireless client on my RT-N66U. It had an IP address and showed solid signal strength.

    So I'm not sure what's going on. It must be a bug in Shibby, but it seems like a big bug not to have been noticed before. Thanks for your help.

    Paging Shibby?...
  7. Mangix

    Mangix Networkin' Nut Member

    Wireless Client mode has never worked for me. Wireless Ethernet Bridge on the other hand always has. Might want to try that?

Share This Page