1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Asuswrt-Merlin on Netgear R7000

Discussion in 'Other Firmware Projects' started by XVortex, Mar 27, 2015.

  1. SignedAdam

    SignedAdam Connected Client Member

    mmm in firefox sometime the web ui gos all messed up 380.68_1

    love the new look, when it works & yes ive done the shift reload
     
  2. slidermike

    slidermike Networkin' Nut Member

    Hi Adam,
    have you tried any other browsers to see if its specific to FF?
     
  3. Ubimoo

    Ubimoo Network Newbie Member

    I just updated to 380.68_1 and did a factory reset. I have the following issues:
    • Traffic monitor is missing
    • In system log I see "Aug 1 02:00:21 kernel: EXT4-fs (sda1): warning: maximal mount count reached, running e2fsck is recommended"
    Anyone else see this warning in system log?
     
  4. Patrick Walden

    Patrick Walden Network Newbie Member

    Were you able to see Traffic Manager in 380.68_0? I haven't been able to see it in 380.68*. Also missing, from nvram.txt above- DNSFilter.asp, ParentalControl.asp, Main_TrafficMonitor_realtime.asp, and QoS_EZQoS.asp. You can still access the pages typing them manually, but the buttons/tabs are missing from the menu.
     
    Almighty1 likes this.
  5. Almighty1

    Almighty1 Reformed Router Member

    Just upgraded from 380.68_0 to 380.68_1 directly over the previous version without resetting savings and have no issues other than the things mentioned by Patrick Walden.

    With 380.68_0, I did briefly tried the adding the .asp as mentioned above while logged out and it prompted for login but after logging it, it just went to the main page but was not able to get to any of the pages mentioned as entering the .asp just goes to the login page and then the main page. Haven't tried logging in first in general and then do the .asp. Today with 380.68_1, I logged in and then did the .asp's above and it works fine. Wonder what changes are there between 380.68_0 and 380.68_1?
     
  6. Almighty1

    Almighty1 Reformed Router Member

    Hello everyone, in an effort to help people with the missing pages.

    Save the following file, extract the archive for the html file and open the html file in your browser for shortcuts to the hidden pages that are missing.
     

    Attached Files:

  7. Patrick Walden

    Patrick Walden Network Newbie Member

    Thanks XVortex for the quick 380.1 rls - I am no longer (after doing a factory reset) having the 20 sec pause and things just seem to be runnning smoother. Hope we can get the menus fixed up in next release. You da man - I sent you some money yesterday, not much (peteosw gmail) but if you have a BTC address I can send you more. When I see things I and others are talking about, and all the time it must take for you to reproduce etc etc etc.. thank you so much for making this FW !
     
  8. Patrick Walden

    Patrick Walden Network Newbie Member

    I've them all populated

    I did encounter some long pauses before clicking on VPN on the submenus. I rebooted it yesterday after install ap-block and it was fixed ! Nooo idea but I don't question provenance.
     
    Last edited: Aug 25, 2017
  9. zimsters

    zimsters New Member Member

    I wish I had read this thread seeing that others had issues with traffic monitor and that the URL still worked before I reverted to stock, tried Tomato and then came back to this after multiple reboots and factory resets and firmware flashes!!
     
  10. techtherapy

    techtherapy New Member Member

    I have just installed 380.68_1 on my R7000, and Parental Controls seem to have disappeared. Am I missing something? Was previously on 380_66.

    *EDIT* Always read before you post. Thanks to Almighty1's post above, I was able to reach the missing pages.

    In my case, that was:

    <Router IP Address>/ParentalControl.asp
    <Router IP Address>/DNSFilter.asp
     
    Last edited: Aug 25, 2017
    Almighty1 likes this.
  11. Patrick Walden

    Patrick Walden Network Newbie Member

    Indeed, it seems (and even says in the changelog) that is was mostly behind the scenes stuff. They probably got too wrapped up in cleaning those bugs out before working on delay pauses etc.. I donated to Xvortex this past time - Merlin I haven't forgotten about you either. Nothing says more about someone's character than one who is willing to help the common good for free, rather than being stingy/bothered by criticism, it seems like these couple of devs read the users feedback and take it to heart. Keep up the amazing work!
     
    phalkon30 and Almighty1 like this.
  12. Patrick Walden

    Patrick Walden Network Newbie Member

    Same here, but I had my first one die (on the 5GHz band) after upgrading to 380.67.

    I bought a new router and it works. The first one I tried, doesn't work in wifi at all, even in stock fw now. But was very suspicious timing - RIGHT after I flashed !
     
  13. Frank2

    Frank2 Serious Server Member

    Anyone know how (step by step) to make one of the LAN ports a VLAN?
     
  14. slidermike

    slidermike Networkin' Nut Member

    Frank,
    The topic of using multiple vlans in Asus firmware has been discussed over on the snb forums.
    I suggest googling that for how to steps if no one here responds.
    A clarification point, you cannot make a phy port a virtual port but you can add phy port to virtual interfaces (vlan) which is what your really asking to do.

    An observation, most folks use the Asus GUI because it's cleaner and more intuitive.
    However, it is easier to manipulate vlans in ddwrt and tomato.

    Good luck!
     
    Makaveli likes this.
  15. Frank2

    Frank2 Serious Server Member

    Thanks Mike. You're right...I'm just being lazy. my kid has a Minecraft Server and I want to make sure it's well protected from my LAN. I did set it up in DD-WRT but I'm no longer using DD-WRT
     
    Last edited: Aug 26, 2017
  16. Frank2

    Frank2 Serious Server Member

    On a somewhat related topic (I'm sure it's somewhere on SNB, but thought I'd ask here);
    I set up my kid's Minecraft server using the Guest WiFi (with access to LAN denied). Problem is no one can connect to it from the WAN. However, when I connect the server to my regular WiFi, people can easily connect via the WAN. What is ASUS-WRT doing to block connections from outside? I have ports properly forwarded to the box, but Guest WiFi won't allow outside connections. Am I missing something (obvious)?
     
  17. Stimpy88

    Stimpy88 Network Newbie Member

    Was there a changelog for the new v380.68_1 version?
     
  18. cybrnook

    cybrnook Addicted to LI Member

  19. mBuxx1

    mBuxx1 New Member Member

    downloaded for traffic mangement but its missing :(
     
  20. slidermike

    slidermike Networkin' Nut Member

    Try these links in the post quoted by Hussain above.
    If you search before posting, you might help yourself out.

    your ip address/Main_TrafficMonitor_realtime.asp
     
  21. qingolden

    qingolden New Member Member

    thanks very much for your update for R7000,
    I love this merlin version,

    thanks again boss.
     
    RichtigFalsch likes this.
  22. mBuxx1

    mBuxx1 New Member Member

    i did the search and i did notice traffic management was accessible this way.
     
    Almighty1 likes this.
  23. ns Era

    ns Era Network Newbie Member

    Hello,

    Reverted from v380.68_1 back to Netgear Stock firmware.

    Now, the IPv6 on stock firmware does not work. It was working fine before I flashed to Merlin & while on v380.68_1. But after going back to stock it's saying "Not Available" for both WAN/LAN.

    Is this a known issue? How do we fix this?

    Thanks.
     
  24. slidermike

    slidermike Networkin' Nut Member

    Try resetting to factory settings and power cycling your router.
    Try resetting your modem too.
    Stock firmware and 3rd party firmware do not hinder the other once you have changed them.
    So if your having an IPv6 issue on stock, it is not because you were running a fork firmware on the router.
     
  25. Pandaman

    Pandaman New Member Member

    Hello, i just install the firmware on my R7000 yesterday.
    And when i try to use TEAMVIEWER remote my computer and transfer file
    The upload / download speed so slow then the original firmware.
    Merlin 120kB/s, Original more then 2MB/s
    Can someone tell me is any setting in merlin cause this happend?
    Thanks :)
    [​IMG]
     
  26. ollimö

    ollimö Reformed Router Member

    Does anybody has a Changelog to what has been done/reverted in .68_1 compared to .68_0? Just went back to .67 as it seems to be more stable than the current .68 revisions.
     
  27. M20377

    M20377 New Member Member

    My R7000 has started to act up. Dropping internet amongst other things. So before giving up and buying a new router I tried flashing Merlin. So far it has been rock solid. Really happy.

    I have been reading this thread and as I understand it Merlin FW should in some way be able to wake a computer via WOL as a cron job every day.

    That is, I want my R7000 to wake up a computer via WOL on my network everyday at 02:20 at night.

    How would I go about to solve this?

    Thanks.
     
    Last edited: Sep 2, 2017
  28. slidermike

    slidermike Networkin' Nut Member

    Yep, Merlin has the change log and xvortex does too.
     
  29. Almighty1

    Almighty1 Reformed Router Member

    See post #4518 above.
     
  30. ollimö

    ollimö Reformed Router Member

    Thanks - the official change log was not clear about the .68_1 changes to me - the GITHUB info addressed my question- Thanks so much for your swift responses!
     
    Almighty1 likes this.
  31. Nitin Vaid

    Nitin Vaid Connected Client Member

    I am trying my router to be in repeater mode but I am not getting any internet when connected to repeater WiFi....are there some special settings ?
     
  32. winyl77

    winyl77 Network Newbie Member

    Installed 360.68_1 on R7000 and getting:
    Code:
    Sep  3 18:49:48 smbd[3061]: [2017/09/03 18:49:48.207745,  0] smbd/negprot.c:706(reply_negprot)
    Sep  3 18:49:48 smbd[3061]:   No protocol supported !
    in log when trying to access smb shares on router from windows 7,8,10 client with disabled SMB1 protocol. Same thing happens when I set "min protocol = SMB2" in global section of smb.conf and try to access from Windows client with enabled SMBv1. Well, I have Merlin 380.68_0 on RT-AC68U and SMBv2 works correcly there. As I see in Meriln's changelog SMBv2 is fixed, but not on xvrt on R7000.
     
  33. Xkwizt

    Xkwizt New Member Member

    @XVortex

    I need help with EA6900 please - i flashed v380.68_1 for EA6900 but it tells me that this is not an ASUS router and nothing works.

    How can i fix this?
     
  34. potatosalad

    potatosalad New Member Member

    How do you enable a feature to allow the router to check (by ping or traceroute) if the internet connection is up and if not, to reconnect the 3G modem? I think it's called Watchdog on Merlin. This feature is a part of r00ter firmware but I want to use asus merlin again and cannot find how to do this if I don't enable Dual WAN. I do not have another internet connection in my home so Dual WAN is useless to me. But I really need to make sure the router checks if internet is up so it can reconnect when I'm not home so that other family members can still use the internet.
     
  35. cybrnook

    cybrnook Addicted to LI Member

    It's called "wanduck" I believe.
     
    slidermike likes this.
  36. potatosalad

    potatosalad New Member Member

    I don't see that option anywhere in the web gui. Can you tell me where it is?
     
  37. cybrnook

    cybrnook Addicted to LI Member

    It's not an option that's turned on or off. It's an inherent process baked within the firmware, always on.

    I think literally what you are talking about IS considered dual wan. If your internet line goes down, you want it to switch to the 3G modem, that's dual wan. Wan duck hides behind that.

    Unless your primary internet connection IS the 3G modem, and if it's flaky and disconnects sometimes, all you are seeking to do is reconnect it..?

    If that's the case, you just need to write a script to do what you want.
     
    Makaveli and slidermike like this.
  38. Xbladr

    Xbladr New Member Member

    I was having all sorts of issues with my R7000 on the stock firmware. I had my comcast XB6 gateway in Bridge Mode and have the newest v380.68_1 on my R7000. I have PPTP setup so I can VPN when away. My home PC pulls down 900+ Mbps however I can not get over 2Mbps over my VPN. If I connect to my buddies VPN I get 30Mbps (Same speeds he pulls down locally at home).

    I setup openVPN and with that I can get about 30down and 2up. If anyone can do some testing with this new firmware release and check the VPN speeds that would be great. I have tried all the configurations I can think of and nothing helps improve the speeds.

    I guess it is possible there is a setting somewhere but, I believe there may be something else fundamentally wrong. Thanks
     
    Last edited: Sep 6, 2017
  39. gxcare

    gxcare Network Newbie Member

    It is possible, but requires some shell scripting.
    Here you can see how to set up a cron job: https://github.com/RMerl/asuswrt-merlin/wiki/Scheduled-tasks-(cron-jobs)
    Then in the script you can call the command to send WOL packets which is ether-wake
     
    Makaveli and slidermike like this.
  40. Stimpy88

    Stimpy88 Network Newbie Member

    New version out. No change log yet.
     
  41. Daedelus

    Daedelus Network Guru Member

    GitHub states: "fix depdency selection when building vsftpd"
     
  42. XVortex

    XVortex Networkin' Nut Member

    380.68_2 is a special build.

    It has some interesting options under "Tools" -> "Other settings" -> (At bottom of the page).
    After changing these switches do not forget to apply and reboot your router.
    Remember, you use these options under your responsibility.

    Enjoy.
     
    Makaveli, peyton, Stimpy88 and 3 others like this.
  43. Almighty1

    Almighty1 Reformed Router Member

    Successfully updated from 380.68_1 to 380.68_2 keeping existing settings without issues.
     
    Makaveli likes this.
  44. chchia

    chchia LI Guru Member

    Thanks, this is great! wishing to see smartconnect to be added too! ;P

    minor bug report, page doesnt display properly under Chrome for AI Protection Web App Filter and Time Scheduling.
     
  45. slidermike

    slidermike Networkin' Nut Member

  46. chchia

    chchia LI Guru Member

    if you really look into it, you should know that some folks in China a.k.a Koolshare had make a R7000 version with SmartConnect and it is working perfectly, but he update very slow, usually 1 month behind xvortex version.
     
  47. slidermike

    slidermike Networkin' Nut Member

    And if you really look into it you will see that smart connect requires 2 or more 5ghz radios which our routers do not have.
    Enabling the feature in the gui doesn't mean you really have it working.
    https://kb.netgear.com/25346/What-i...I-enable-or-disable-it-on-my-Nighthawk-router

    What is Smart Connect and how do I enable or disable it on my Nighthawk router?

    Smart Connect balances your 5 GHz WiFi connections into two different radio bands: the 5 GHz radio 1 band and the 5 GHz radio 2 band. Your router uses Smart Connect to choose the best radio band for your device to give you the best WiFi performance.

    For Smart Connect to work, both 5 GHz radio bands must use the same WiFi network name (SSID) and network key (password). That means that when you connect to the router with WiFi, you see only one 5 GHz SSID that connects to both 5 GHz radio bands. If you enable Smart Connect and the SSID and passwords for both 5 GHz radio bands do not match, the WiFi settings for 5 GHz radio 1 overwrite the WiFi settings for the 5 GHz radio 2.

    This article applies to:
     
    Clark Griswald and Makaveli like this.
  48. chchia

    chchia LI Guru Member

    bro, perhaps you would like to try the Koolshare version of smartconnect feature? i am happy to point you to the download link, his latest version is based on 380.67.

    otherwise i think we are not on the same page about this discussion, anyway thank you for your explanation, very much appreciated.

    https://kb.netgear.com/29834/Configuring-Smart-Connect-on-your-Nighthawk-R7000

     
    Last edited: Sep 11, 2017
  49. Nitin Vaid

    Nitin Vaid Connected Client Member

    After setting the router to repeater mode I am not able to access the router nor via land nor via WiFi.. Using R7000
     
  50. slidermike

    slidermike Networkin' Nut Member

    Did you hard code the IP prior to applying the repeater mode?
    If not, you need to look at your dhcp server to figure out which IP the R7000 now has.
     
  51. Nitin Vaid

    Nitin Vaid Connected Client Member

    I have just set the router to repeater mode that's it haven't changed the settings...
     
  52. Nitin Vaid

    Nitin Vaid Connected Client Member

    Well NVM i changed it to default wireless mode
    whats the default mount location path for USB or how can i check that
    i want to save my traffic logs to USB
     
  53. badplay

    badplay New Member Member

    i saw a really big update. so i want to update my R7000. but how i can do this without losing my settings. i have so many settings so i need them.

    also since some days i have trouble with wlan on my printer . all other devices working great


    question to i idiot have clicked te wlan button at the R7000 now the lamp after a restart isnt glowing . is it ok or do i have made a trouble n the settings after pushing that real button ?
     
    Last edited: Sep 9, 2017
  54. r00ternewbie

    r00ternewbie Reformed Router Member

    In response to how to update your R7000 without re-entering all your settings, there is an NVRAM backup/restore utility for this purpose. You can find it here:

    http://forums.smallnetbuilder.com/showthread.php?t=19521

    Download the archive and follow the instructions in QuickStart.txt

    I use this every time I upgrade my firmware and it's saved me hours!

    Sent from my ONEPLUS A3003 using Tapatalk
     
    Makaveli likes this.
  55. potatosalad

    potatosalad New Member Member

    Yes 3G modem is my primary and only internet and sometimes it can disconnect periodically. I have no idea where to start with writing a script for this, any ideas?
     
  56. potatosalad

    potatosalad New Member Member

    Is anyone having a problem where when they change some settings, such as WIFI ssid's or turning dual wan off, etc that when the router is rebooting it comes back online RESET TO FACTORY DEFAULTS? I constantly have to start over until I get lucky and it doesnt reset.

    I really want to use this firmware but this has become ridiculous and I know I'm not the only one experiencing this.
     
  57. slidermike

    slidermike Networkin' Nut Member

    Are you using any attached USB drives on the router? If so, reboot the router first and then try updating.
    To answer the question, no that isn't a common issue so it's probably specific to your situation.
     
  58. potatosalad

    potatosalad New Member Member

    I'm using an MC7455 4G card in a USB enclosure. It works with the firmware but I can't change any settings or almost everytime everything gets reset.

    So what do you mean by reboot first then update? Being I'm using a usb modem, can I still do what your saying?

    So reset to factory defaults, reboot, then plug-in USB modem to the router? Then how is it going to set up my internet connection since the USB modem is my primary and only internet?

    Do I have to unplug modem, reboot, and attach modem every time?

    Edit: And I do think its a common problem because I know of another person in the thread that has the same thing happen when they turn Dual WAN off/on.
     
  59. slidermike

    slidermike Networkin' Nut Member

    First time I heard you mention dual wan. Most folks here don't have that luxury.
    Since it's only happening to those few with that config then my statement stands. It's not a common problem because that implementation isn't common.

    Pretty sure I said USB drives.
    You mentioned a USB modem...
    Fairly common issue with Asus routers and memory leak with attached USB DRIVES.

    A possible work around is to temporarily take out the dual wan config, upgrade then put your dual wan back in place.
    Hope you get it figured out.
     
  60. slidermike

    slidermike Networkin' Nut Member

    Saving a config from one version, upgrading the code and then restoring the previous build config is NOT the recommended procedure.
    It's probably ok most of the time but if you run into issues then that's a likely culprit.
    Unless the code update is a big one then just leaving your existing settings in place while doing the firmware update is ok. No reason to reset to default each firmware update.
     
    Makaveli likes this.
  61. potatosalad

    potatosalad New Member Member

    This happens with Dual WAN on or off. And I am not using Dual WAN so I try and set it to off. Resetting still happens.
     
  62. Stimpy88

    Stimpy88 Network Newbie Member

    Yes, this has been an ASUS bug for coming up to 3 years now. It's never been addressed by anyone. It seems to start mostly while making adjustments to WiFi settings, and is a semi-rare bug, but does seem to depend particularly on how many changes you make to the advanced WiFi settings, so some people may have never encountered this issue, and will say stupid stuff like it's your fault, you must be doing something wrong, my router works perfectly yada yada.

    Another semi-related bug is that the router will suddenly start doing a full restart for every minor settings change you make. Once it starts doing this, it won't stop until you reset to factory defaults, and will come back after making a random number of settings changes. This bug has been around for at least 2 years, and has also never been addressed.
     
    Last edited: Sep 10, 2017
  63. GDT78

    GDT78 Reformed Router Member

    Can someone explain me what is BWDPI?
     
  64. badplay

    badplay New Member Member


    so you mean to me i should normal firmware upgrade and leave the settings like they are ??
     
  65. myersw

    myersw Network Guru Member

    The last sentence says "Unless the code update is a big one then just leaving your existing settings in place while doing the firmware update is ok. No reason to reset to default each firmware update."
    I think that answers your question. As is always the case, if you have issues after a update one of the steps would be to do a reset and reconfigure.
     
  66. badplay

    badplay New Member Member

    380.65 is my version on the R7000
    so it looks like the new update is a big code update or ???
     
  67. Stimpy88

    Stimpy88 Network Newbie Member

    Check the changelog on the first page of this thread, and decide for yourself.
     
  68. peyton

    peyton Network Guru Member

    It is Bandwidth Monitor (qos etc..).
    I enable it for testing but i can't explain.. It works after activating adaptative qos yesterday but now when i looked at statistics all traffic goes to "others" category. Any additional feedbacks ?
     
  69. potatosalad

    potatosalad New Member Member

    THANK YOU! I knew this wasn't some rare thing happening to few select people. It's just nobody cares.

    And yes, I have the second bug your talking about to. Some minor setting update and the damn thing has to do a complete restart of the router. Every. Single. Time.

    Given this stuff, I think I am done with Asus merlin. It's like nobody really wants to address the issue.

    Did you move away from Merlin because of it?
     
  70. johnyr

    johnyr New Member Member

    Is it safe to go from .65 to .68 without factory resetting?
     
  71. badplay

    badplay New Member Member

    i have done it but get in trouble. so i made a factory reset.

    also i have tryed the programm nvram-backup but all were fine after finish i try to flash it back, but:

    admin@R7000-F5D5:/tmp/mnt/ASUS# ./nvram-restore.sh

    Last nvram save/restore (nvram-restore-.sh)
    WARNING: Last nvram-save MAC address ()
    does not match current router MAC (F5D5)!
    This may be valid if you are migrating settings from one router to another

    If you wish to use a different restore file, answer N and specify the
    restore file id the command line in the form
    yyyymmddhhmm-mmmm

    Do you want to proceed [Y/N]?y
    Restore using last nvram save (nvram-restore-.sh) [Y/N]?y

    Script /tmp/mnt/ASUS/backup/nvram-restore-.sh does not exist. Exiting.

    admin@R7000-F5D5:/tmp/mnt/ASUS#


    so i dont know why it want find the right one. but if i try to do: nvram-restore-201709102056-F5D5.sh
    it do nothing:
    admin@R7000-F5D5:/tmp/mnt/ASUS# ./nvram-restore-201709102056-F5D5.sh
    admin@R7000-F5D5:/tmp/mnt/ASUS#
     
  72. gxcare

    gxcare Network Newbie Member

    At the beginning I thought it was my mistake, but now I am 100% sure that since I updated to v380.68 the auto-logout functionality is not working properly: if I close Firefox and reopen it after hours (the auto logout is 30 minutes), it could reopen the router page without prompting for the login. If I open another browser instance (different profile) I get the login page, and if I login I get logged out from the previous one.
     
  73. slidermike

    slidermike Networkin' Nut Member

    I have been running dd-wrt the last two weeks but on the previous xVortex built I always got the login prompt anytime I closed my browser.
    I generally use Edge.
    Have not tried the latest version of code yet.

    **update**
    I never log in from the WAN for security purposes. Only from the LAN.
     
    Last edited: Sep 12, 2017
  74. gxcare

    gxcare Network Newbie Member

    I need to add that I experienced this for sure when logging from the Internet. I am not sure if the same applies when logging on the same LAN.
     
  75. Almighty1

    Almighty1 Reformed Router Member

    Same issue from the LAN as I don't even have a tab opened for the router on the LAN but the only time I had to enter a login/password was after the reboot. Otherwise, it seems to go directly without the login.
     
  76. T-Birth

    T-Birth Connected Client Member

    Upgraded to v380.68_2 without problems/resets. (With Flush Cache)
    Everything is rock solid (but some Pages are missing /Thanks Almighty1 for the pro forma fix.

    Stable and Fast on R7000 with v380.68_2 and AB-Solution (Custom Blacklist+Whitelist) + Skynet (Region Block)

    Really nice, thanks for everything.
     
    Almighty1 likes this.
  77. Makaveli

    Makaveli Networkin' Nut Member

    How are you liking Skynet i'm considering add it to my AB-Solution+ Pixelserv setup.
     
  78. XVortex

    XVortex Networkin' Nut Member

    XWRT v380.68_3 was released.
    Changelog on my site.
     
    Stimpy88, Almighty1, sturmi and 6 others like this.
  79. Makaveli

    Makaveli Networkin' Nut Member

    Thank you sir.

    lol I just upgraded to 68_2 last night.

    From what I can see in the fixes Vortex 380.68_3 = Merlin 380.68_2
     
  80. cybrnook

    cybrnook Addicted to LI Member

    Nope, Merlin has a _3 tag already in his fork:
    https://github.com/RMerl/asuswrt-merlin/commits/master

    So XVortex _3 = Merlin _3 (both with the additional "webui: Fix missing tabs on Parental Control page" commit as well.
     
    Stimpy88, phalkon30 and slidermike like this.
  81. SignedAdam

    SignedAdam Connected Client Member

    Big bad bug in Firmware: 380.68_3 (sorry to poop on the work)

    but after doing restore to default, then applying my setting I found a bug under the following page :

    http://192.168.1.1/Advanced_OpenVPNClient_Content.asp

    when setting Redirect Internet traffic setting to ( policy rules ) and entering a ip address in the box that shows up, after pressing apply the page gos crazy and nothing can be set or unset on the page after applying, and obviously vpn doesn't work because you cant turn it on!
     
  82. cybrnook

    cybrnook Addicted to LI Member

    Standard jazz;

    clean cache, try another browser, factory reset (and not restoring from backup) etc.

    Looking in Merlin SNB threads, I don't see anyone reporting this. So likely a localized case.
     
    Makaveli likes this.
  83. Makaveli

    Makaveli Networkin' Nut Member

    ah you are right thanks for the clarification.
     
  84. SignedAdam

    SignedAdam Connected Client Member

    I restored the router to default 3 times, every time it displayed the same problem in both firefox and MS Edge,

    the problem displayed its self as : two sides of the page were black, along with all the boxies showing no settings, the apply button would do nothing,

    lucky the problem has gone, and I can not repeat it, so now I feel pretty stup!d

    * note : the problem only seem to go after the 4th restore to defaults
     
  85. SignedAdam

    SignedAdam Connected Client Member

    Nope 100% a problem, 100% found it, 100% not going cr@zy, if you enter for the Description under policy rules setting, ok's with a "'" for the Description your page will end up broken after applying

    * to replicate the problem, restart your xwrt Firmware: 380.68_3 to default settings, enter in all the start information, into the start wizard, once at the home page, press the VPN button, then press VPN Client button, scroll down and press on Redirect Internet traffic Tab, which should be showing NO for now, change it to show Policy Rules, then under Rules for routing client traffic through the tunnel (Max Limit : 100), choose a Source IP, by pressing the down arrow and then picking a device in the network, then change the Description to ok's, with a "'" then press the + (plus) icon to add it, then press apply, after the page reloads, you should have a page that you can do nothing with

    I also believe this wasn't a problem in the last firmware 380.68
     
    Last edited: Sep 14, 2017
  86. cybrnook

    cybrnook Addicted to LI Member

    why are you using special characters for hostnames? I think only alphanumeric values can be used.

    If you truly think that using special characters should be allowed, and you think it's a bug, then you need to open a issue in the issue tracker on Merlins githhub page:

    https://github.com/RMerl/asuswrt-merlin/issues
     
    Makaveli likes this.
  87. SignedAdam

    SignedAdam Connected Client Member

    Does it really matter, I've found a bug and reported it, it's a problem, it need fixing there's no question of why you entering it like that,

    If we can't enter special characters then there needs to be a sign there stating that,
     
  88. cybrnook

    cybrnook Addicted to LI Member

    Why so snappy?

    If you do some basic research on hostname conventions, unix etc... you will see that special characters are very much something that has to be taken into account and are interpreted in different ways. Of course, someone who only uses windows would likely never think twice about it, and then do something silly like use spaces or special chars in a hostname.

    So instead of just snapping off that you found a bug, now fix it. Why don't YOU do your own due diligence and see your bug through to fruition? GO report, don't just come in here, get snappy when someone tries to help you, mouth off and then wander off.

    EDIT: and to add to this, I see you in here from time to time and you always react the same, so likely why you don't get much help.

    To finish it off, XVortex is not writing the code, Asus and Merlin are. So if you have a bug, go report it properly because XVortex is not fixing Merlins code, only porting it. So your barking up the wrong tree.
     
    Last edited: Sep 14, 2017
    Makaveli likes this.
  89. SignedAdam

    SignedAdam Connected Client Member

    point 1) you say im snappy, have you read your own reply to me ?
    2) my point in my last reply was - this firmware isn't just made for unix experts, it has a user interface, meaning anyone can use it, including noobies, sounds like you have forgot that ?
    3) I might be abit snappy, because you made out i was a noob, and i didn't know how to refresh my browser cache, or restore a router back to default settings, assuming everyone doesn't know what they are talking about doesn't help,
    4) doesn't everyone come and go online ? or are we all meant to sit at our computers all day, have our eyes glued to a thrad, sorry, i dont have that luxury
    5) hopefully XVortex is working with the people who do fix the bugs, and can pass on my report,

    6) I hope this has helped you understand your self a bit more, and stop thinking your Imperfections are in others you respond to!
     
  90. Mailman74

    Mailman74 New Member Member

    I am looking for a better firmware to use. I tried advanced tomato & ddwrt but the wifi kept dropping and I wanted to try Xvortex. I need to set up 1 to 1 NAT because I have 29 static ip's that I like to assign to devices. I do not know where to put the startup and firewall rules that I used on the other firmwares. Only section I see is a run command and it does not seem to work. On ddwrt I was able to see the saved settings after I ran the commands. Any help thanks
     
  91. cybrnook

    cybrnook Addicted to LI Member

    Call tech support, since you seem to be so entitled to immediate support from everyone. Oh wait..... that's right...

    Guess your extent of "true" concern stops at just ranting issues and not actually filing a bug report. Easy when someone else can do it for you I guess.

    (Ignoring you now)
     
    Makaveli likes this.
  92. slidermike

    slidermike Networkin' Nut Member

    Hi Mailman.
    If no one here can offer you something it's a good idea to head over to the snb forums where the Asus Merlin firmware is addressed daily. Keep in mind the R7000 is nearly identical to the Asus ac68-u so that's why this firmware port works well. If you can't find (via search) someone already discussing 1-1 NAT for the Asus router then you can post but be aware if you mention it being the fork they will point you here. Over there you can use the ac-68u if you want to name your router.
    The minute you say Netgear Merlin fork they point you over here.
     
  93. cybrnook

    cybrnook Addicted to LI Member

  94. Mailman74

    Mailman74 New Member Member

    Much more difficult than ddwrt and tomato
     
  95. cybrnook

    cybrnook Addicted to LI Member

    Before you make the effort, might be worth your while to load up the XVortex port and just do some basic wifi testing to see if it's even going to be worth the effort to then try 1:1, if that's an option.
     
    Makaveli likes this.
  96. Almighty1

    Almighty1 Reformed Router Member

    Thanks, updated from 380.68_2 to 380.68_3 without issues.
     
    Makaveli likes this.
  97. Mailman74

    Mailman74 New Member Member

    I think I have these correct. Now I have the firewall and startup commands that I use. I am using the commands from ddwrt. I used those commands on both ddwrt & tomato and they worked fine. I just do not see a section in XVortex to save the commands
    upload_2017-9-14_15-55-21.png
     
  98. Makaveli

    Makaveli Networkin' Nut Member

    Just upgraded to 68_3 myself also no issues.
     
    Almighty1 likes this.
  99. RMerlin

    RMerlin Network Guru Member

    Don't ever do that, please. Xvortex's code being closed, there is no way for me or the support community to know if an issue is truly genuine to all models, or an artifact caused by a change XVortex made. I'm going to get real cranky if I waste my time trying to chase down an issue that turns out to be specific to this fork, and the requester had lied about what router he has.

    There are perfectly good reasons why I refuse to provide support to XVortex. Don't try to work your way around it. I already stated my terms, and they are non-negotiable.
     
  100. slidermike

    slidermike Networkin' Nut Member

    Completely true. Mostly because unlike dd-wrt/tomato this firmware isn't meant for power users but rather to enhance stock firmware. Different target audience.
     
    Makaveli likes this.

Share This Page