1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Asuswrt-Merlin on Netgear R7000

Discussion in 'Other Firmware Projects' started by XVortex, Mar 27, 2015.

  1. slidermike

    slidermike Networkin' Nut Member

    Its your choice but IMO the exposed vulnerability vs. who really is close to you to want to hijack your wifi connections (in my case anyway) is miniscule. Read up on the specifics of that exploit. Its not very easy or useful so its likely your safe from a would be attacker.
    Also, the vulnerability is a client issue not a router issue.
    Your cell phone vendor may have already updated your phone to avoid it. You will have to research that.
    If you want the older 380.62.1 code I can send you a link in a side chat.

    I believe in balancing my networks security with the realization that I'm probably not the target of someones malicious desire to take it over. Ideally we have 100% secure networks and all features working great but if not, you have to decide which you want more.
    Makaveli and Almighty1 like this.
  2. Justin Trant

    Justin Trant New Member Member

    If you had a link for R7000 v380.62.1 that would be great. I think it's worth a try, even to be sure it's a firmware issue that will probably be addressed later down the line.
  3. Makaveli

    Makaveli Networkin' Nut Member

    The Krack issue is only a problem if you are running in media bridge mode or extender.

    The bigger issue with going back to previous firmware will be other security holes that have been patched since then.
    Last edited: Jan 4, 2018
    Stimpy88, phalkon30 and slidermike like this.
  4. dssboss

    dssboss New Member Member


    I cannot get any devices to connect to the 5GHZ with the latest versions of the this firmware on the Netgear r7000. But everything works fine on V 380.63_2. Had to revert back to this version and everything works fine. On the newer versions I can see the 5GHZ SSID but devices will not take the passwords which are correct....and cant connect.


  5. slidermike

    slidermike Networkin' Nut Member

    on the new code vs older version did you make sure the 5ghz channel is the same?
    How about all the settings such as A,N,AC?
    Did you also update the firmware, restore to factory defaults & re-configure the router manually?
    Anytime there is an issue, standard procedure is to reset router to default and manually reconfigure the settings.

    On the clients did you forget the ssid and then re-connect?
    Sometimes clients need to be forced to forget the ssid & reconfigured.

    That's a big jump in so far as updates/fixes between the two code revs.
    A reset to factory is suggested.

    These are two standouts for me that indicate you should reset the router to default and clear the saved ssid info on the clients.

    380.66 (12-May-2017)
    - NEW: Merged with GPL 380_7378
    * If you are experiencing new wifi stability
    issues, try disabling Airtime Fairness on
    the Wireless -> Professional page (on all

    380.68 (18-Aug-2017)
    - IMPORTANT: due to major webui changes, you will need to
    either flush your browser cache, or force it
    to reload the page (shift-reload) the first time
    you access the webui after upgrading to 380.68.
  6. dssboss

    dssboss New Member Member

    Thanks , I did reset all to factory multiple times. I have updated to multiple version in the past and went back to 380.63_2 after failures with 5GHZ. I didnt turn off Airtime Fairness. What does that do? I will try again. where do i download these other older versions listed above?
  7. slidermike

    slidermike Networkin' Nut Member

    Did you clear out the saved SSID connection in the cell phone & re-connect it?
    ATF is something some folks have no issues with and others have nothing but issues with.
    For testing you can turn off ATF.
    You can google what ATF does.

    Since you said you installed newer versions but went back each time, that would indicate you have those other versions of the firmware. Unless you deleted them which is something you should probably not do unless your certain you wont ever have a need for them again in the future.
    Makaveli likes this.
  8. kingleo

    kingleo Reformed Router Member

    i would like to ask if any chance R7000 add MRTG function?
    Almighty1 likes this.
  9. Koruneko

    Koruneko Network Newbie Member


    I'm on 380.65 and it works just fine. I use dual WAN feature with USB on primary WAN, WAN on secondary and failover for the dual WAN mode. Because my ISP connexion is poor, I sometimes plug my android phone in tethering mode in order to improve my internet speed.
    I tried to update to 380.68 and 308.69 but it seems there is a bug with this dual WAN configuration. It works fine when the WAN is on primary and USB on secondary ; but fails when USB on primary and WAN on secondary. With this last conf. PC on the R7000 LAN can't communicate with the WAN. USB on primary with failover is cool because I just have to plug my phone to automaticaly switch on the tethering mode without having to unplugged my ISP socket.

    Anybody have the same conf/issue ?

    Thx by advance for your anwers.
  10. dssboss

    dssboss New Member Member

    Would it be a problem to go directly from version 380.63_2 to the latest and then restore back to factory and configure all settings on Netgear r7000????
  11. slidermike

    slidermike Networkin' Nut Member

    That should work.
  12. b1ggles

    b1ggles Network Newbie Member

    Does this definitely work on every version of the R7000?

    Given the month I've had to wait for Amazon to get it back in stock, I have what I assume will be a factory fresh UK version arriving today and, having been caught out with a 'new' version of the Archer C9 that isn't third party friendly previously, would appreciate a confirmation, thanks.
  13. slidermike

    slidermike Networkin' Nut Member

    b1ggles, as far as I know there is only 1 version of the R7000.
    There are other flavors such as the "p" but then its not an R7000 it would be an R7000p.
    This is a community forum and your question seems more like your asking for someone to give you a verbal guarantee.
    I suppose you could pop the top and look at the chipsets and placement on the pcb but again that would be on you.
    If the flash fails, do a recovery back to stock. Otherwise, enjoy the new router with great software on it.
  14. zatoom

    zatoom Addicted to LI Member

    My R7000 router, with asuswrt-merlin 380.69, makes contact with dns.msftncsi.com several times per minute.
    (Internet control for windows machines)
    It is the R7000 router that does it and not a dns client of this R7000 router or router for my son.

    Situation: Router of my ISP, then 2 routers and DNS server Pihole> 1 router for my son (gamer) and the R7000 for the rest of the family.
    Question: why is that and how can I stop it .. it pollutes my DNS log files from the Pi hole.
  15. b1ggles

    b1ggles Network Newbie Member

    Hi slidermike, given your knowledge/experience of the subject from early days that was good enough for me. Have now flashed it and all good thank you.

    A lot of later C9s have been permanently bricked by DD-WRT, hence my concern given that the R7000 was launched earlier, guess Netgear were happy they got it right first time :)
    phalkon30 and slidermike like this.
  16. cybrnook

    cybrnook Addicted to LI Member

    If you advertise your pi-hole locally to your devices (in DHCP settings of your Router, and omit advertising your local router as a DNS server), then your pi-hole will track on a per device IP (instead of just saying all queries comes from, then you can find out which device is querying that dns entry. I would assume it shows in pi-hole as one of your top queries.
    slidermike likes this.
  17. Makaveli

    Makaveli Networkin' Nut Member

    From what i've seen the 7000p only adds MIMO but it also has slower memory.

    It maybe the same memory module but why is it down clocked if so?

    The original R7000 is clocked at 1Ghz/800mhz the P model 1Ghz/533mhz.


    And since MIMO doesn't really do much the original model is superior if you ask me.
    cybrnook likes this.
  18. cybrnook

    cybrnook Addicted to LI Member

    DRAM is up there in prices these days :)
    Makaveli likes this.
  19. Fungyei

    Fungyei New Member Member

    I am running 380.69. When I want to setup a guest network by clicking the "Enable" button, the prompt starts counting from 0% to 100%, and when it reaches 100%, I've got log-out my WebUI and the Guest Network had never been started. The case is the same across 2.4GHz and 5GHz.

    Would anyone give me clues / instructions to get the Guest Network done?

  20. slidermike

    slidermike Networkin' Nut Member

    Try a diff browser to see if it's that.
  21. Fungyei

    Fungyei New Member Member

    The case is the same across Firefox, Chrome and Edge.
  22. slidermike

    slidermike Networkin' Nut Member

    Did you try rebooting the router, see if the issue persists?
    How about a reset to default and reboot and then try?
  23. Almighty1

    Almighty1 Serious Server Member

    Does anyone know what the maximum speed for WiFi the R7000 can actually handle in real world usage?
  24. Koruneko

    Koruneko Network Newbie Member

    I already have the same issue with the GUI, resolved it by launching firefox as an administrator (right click on Firefox icon, then 'run as administrator').

    Hope this can help ...
    slidermike likes this.
  25. schumi2004

    schumi2004 New Member Member

    I just registered to confirm 5Ghz is broken in latest 2 builds: 380.69 and 380.68_4

    I started completely clean, did factory resets multiple times but no 5Ghz. Some devices do see 5Ghz but can't connect and a few mobile devices don't see 5Ghz SSID at all.

    I couldn't find an older version for testing so if anyone has a link to 380.63_2 i will test if it brings back 5Ghz on my R7000
    Patrick Walden likes this.
  26. slidermike

    slidermike Networkin' Nut Member

    Please be much more specific than "5ghz doesn't work".
    Ive been running XVortex fork of Merlin code on my R7000 (USA code) and no 5Ghz issue.
    Most of my network devices are on 5ghz.

    What country code?
    What 5ghz standard and advanced settings?
    Screen shots can be useful for seeing the settings.
    Makaveli and phalkon30 like this.
  27. phalkon30

    phalkon30 Reformed Router Member

    If memory serves correctly, there was a change to country codes about a year ago. You should manually assign a 5ghz band that works in your country and try again.

    I have had zero problems with 5ghz in the USA, but I assign an open band based on my country and doing site testing

    Sent from my Nexus 6P using Tapatalk
    Makaveli likes this.
  28. Makaveli

    Makaveli Networkin' Nut Member

    Please stop with these "the sky is falling post"

    I've had no issues with 5GHz on 69 or 68_4

    Provide details or do as suggested above.
    Last edited: Jan 9, 2018
  29. Stimpy88

    Stimpy88 Connected Client Member

    I think you are being unfair.

    Just because YOU do not have any problems with YOUR particular usage case, does not mean to say that others that may encounter a problem are wrong for saying that there is an issue with their setup.

    He did the right thing by resetting to factory defaults first, then coming here asking for clarification and help, as well as informing others that there may be a problem.

    To be honest, there ARE problems with regions on this firmware, which have never been fully addressed for whatever reason, and expecting every user to be able to go in to the router and change WiFi regions is quite a lot to ask of some.

    Schumi2004, try going to your 5GHz settings, and manually set a low channel number, this may help. The default auto setting is to be avoided, as this is what often causes this issue.
  30. b1ggles

    b1ggles Network Newbie Member

    No, he's being entirely fair, this is what the OP said "I just registered to confirm 5Ghz is broken in latest 2 builds: 380.69 and 380.68_4" and is the kind of thing that can make people very nervous and think they may brick their router if they use it.

    It most definitely isn't broken, it's just not working for these two users, very different things. I'm new to this and have applied .69 to my brand new R7000 and all works perfectly, if I'd seen this before I did it I may have thought twice about this version or even gone back to looking at DD-WRT thinking this was a flaky firmware.

    Having read the majority of this thread before committing I knew to change the channel from auto as this firmware is region unlocked and so will potentially pick a my channel devices may not be able to see, that is not a "problem" as you call it and it has also been explained how to set the region if you so desire.

    In this instance, it's possible that the user had been lucky on which channels 'auto' gave him in the past and with the latest update his luck ran out and it picked one he couldn't use. He also may not be using 'auto' at all and has a genuine problem in which case @Makaveli 's request for details rather than making a Chicken Little claim is also entirely fair.
    lepa71 and Makaveli like this.
  31. schumi2004

    schumi2004 New Member Member

    Country code, how do i set that?
    I didn't configured anything specific, time zone was already correctly set and couldn't find anything in professional tab.
    And I thought I was pretty specifc, some devices do see SSID and some don't and the ones who did see couldn't connect.

    Config was set to default and channel assigned was within country regulation but after setting it to a fixed channel as suggested by Stimpy88 it worked. But like you also say, manually setting a channel resolves it not because auto channel is not within country range but for some other reason.

    Thank you that was very helpful!
    And it's not a "the sky is falling post" it just doesn't work nor do the instructions mention to change country code or manually set channel instead of leaving it to default.

    Thank you for helping getting it resolved.

    Manually setting it to a lower channel number did indeed resolved it although auto picked channel was within country regulation range.
    Stimpy88 and phalkon30 like this.
  32. cybrnook

    cybrnook Addicted to LI Member

    XVortex has in his first post a link to change country code:

    Makaveli and slidermike like this.
  33. phalkon30

    phalkon30 Reformed Router Member

    Thanks for following up, glad you got it working!

    Curious if anybody with an android phone running 8.0 or higher is having issues with connections. There are lots of reports in this Google thread, and I'm one of them. https://productforums.google.com/forum/?noredirect=true#!topic/phone-by-google/E7sQJOTnXNk

    It's not specific to our router model, but when my Nexus 6P wakes up from sleep it will cause all networked devices on that band to skip if they are streaming audio /video and sometimes throw connection warnings.

    Sent from my Nexus 6P using Tapatalk
  34. slidermike

    slidermike Networkin' Nut Member

    the wife and I both have Nexus 6P phones running android 8.x
    No issues to report here.
    We connect to the 5ghz on the R7000.
    Hopefully Google comes up with a fix for you and the others suffering from the issue described.
    Makaveli likes this.
  35. b1ggles

    b1ggles Network Newbie Member

    Google screwed wifi in the December 'security' update, we had it with two N5Xs and a Moto Z Play, when any of them connected after a break, especially next morning or been out for the day, it would knock over the whichever band it connected to for everyone, only a reboot would bring it back.

    Spent ages searching my network for a 'bad' device or something in the setup and Googling kicked up nothing until I chased the date back to when it started and then searched for December update and wifi problems and found a whole host of people with similar stories of hair pulling, don't know why it didn't get any proper coverage in the press, XDA missed it completely.

    The January update cured it instantly.
    phalkon30 and slidermike like this.
  36. phalkon30

    phalkon30 Reformed Router Member

    Aha, my 6P is still on 8.1 beta, November update. I'll have to sideload the December update (nobody from the beta is getting updates). Thanks for the suggestion

    And slidermike, most of my devices connect to the 2.4ghz network, but I have one Google Home and one chromecast that connects to 5ghz. I noticed those two don't skip... I figured it was being on the different bands. I guess I'll have to play with moving devices around more if the software update doesn't fix it

    Sent from my Nexus 6P using Tapatalk
  37. b1ggles

    b1ggles Network Newbie Member

    No probs, my 5X was stuck on the beta as well and I was so fed up with the dreadful battery life I opted out of it which did an auto factory reset of the phone back to 8.0 but then offered the update to 8.1 stable within a couple of minutes. My battery life is now better than it's ever been and I'm a happy chappy again.
    phalkon30 likes this.
  38. yecarrillo

    yecarrillo Network Newbie Member

    Thanks to vortex for this great sw. I´m using it a long time ago and get the best from my r7000. I have a question:
    A friend of mine will bought Netgear r6700. Theorethically, if i change BoardID of r6700 to make appears as R7000 using this procedure, XWRT-vortex could be installed?

    dd-wrt com forum viewtopic.php?p=1059610#1059610
  39. Makaveli

    Makaveli Networkin' Nut Member

    If you would have read the thread the answers are within.

    This issue has been covered on numerous firmware versions in this thread a simple search would have found this.

    Automatically posting the firmware is broken because you have a problem is not fair and is not that helpful to those looking to try it.

    I did also ask for details as did numerous people.

    I'm glad you got it sorted out.

    I believe its been confirmed the firmware will work on the R6700 because its the same thing minus a usb port.

    yecarrillo likes this.
  40. Fungyei

    Fungyei New Member Member

    Can I save the setting and restore them after "reset to default"? Just don't want to edit the DHCP, VPN, and other settings one by one. I mean what kind of settings are saved in "Settings_R7000.CFG"? and will the Guest Wifi setting (if faulty) also be saved and restored?

    Thanks for your suggestion but that doesn't work for me.
    Last edited: Jan 11, 2018
    Patrick Walden likes this.
  41. Jan2708

    Jan2708 New Member Member

    I'm using the same version 380.69 and having exactly the problems that are discribed by Fungyei for setting up WiFi guestnetwork. I tried also using Firefox in administrator mode, that didn't work for me also.
  42. slidermike

    slidermike Networkin' Nut Member

    Yes you can save your settings and restore them but by restoring your settings you will be restoring without a guest wifi.
    Reset to factory.
    See if you can configure the guest wifi.
    If not, you can restore your backup.
  43. harrybuckman

    harrybuckman Reformed Router Member

    On a new install on the AC68u you have to flash a previous version before you go to 380.69. Is the nessesary on the R7000. Quote " The RT-AC68U and RT-AC56U need to be at least on firmware 378.55 (or the last 378.xxx version from Asus) before you can flash 380.xx, due to the partition size change."

    If it needs to be done where can 378.55 be found?
  44. slidermike

    slidermike Networkin' Nut Member

    no, that extra step is only for the Asus routers because Asus instituted a change after a certain firmware ver that will not allow loading 3rd party firmware.
    Not applicable to the R7000 / XVortex fork.
  45. harrybuckman

    harrybuckman Reformed Router Member

    Thanks slidermike for the quick answer!
  46. Patrick Walden

    Patrick Walden Network Newbie Member

    Same issue here, except it's been going on since earlier builds. It's not broken per se, but only certain wifi devices (generally newer, but not always) will see the 5G band. They all see my fios modem's 5G that I let my guests use (I have the channels set far apart and both are US codes). I've just come to deal w/ it, but just wanted to let you know it's not just you. Some people have everything working and assume we're doing something wrong because we don't, but that's only human nature :)
  47. slidermike

    slidermike Networkin' Nut Member

    Its good when you report issues & what revision you noticed it begin in if possible.
    Because until last week I don't recall seeing a single comment about guest wifi not working.
    Now there are multiple users reporting... Probably something to it beyond one users situation.

    I am unable to TS myself because my r7000 is in AP mode behind my pfSense FW.
  48. yecarrillo

    yecarrillo Network Newbie Member

    I had this issue with my Alexa device: unexpected disconnections when out of home. Somewhere I found 5g devices are not seeing allchannels. I needed to set a fixed channel for 5g (trial and error) to allow all my 5g divices get connected all time.

    Currently, I´m on vortex 380.69 without 5g issues.

    *** Using NetGear R7000
    phalkon30 likes this.
  49. b1ggles

    b1ggles Network Newbie Member

    Have you definitely tried all the other bands, my UK Samsung Tab won't see all the official UK 5g bands and it's not an issue with this router as it was the same with my C9.
    Last edited: Jan 12, 2018
    slidermike likes this.
  50. b1ggles

    b1ggles Network Newbie Member

  51. tekbar7522

    tekbar7522 New Member Member

    Is there a way to set the DNS server that is sent when using openvpm with xwrt-vortex? I have a pi-hole setup and want to forward DNS queries over vpn to pi-hole.
  52. Makaveli

    Makaveli Networkin' Nut Member

    I'm am also the same I've not had a single issue with Wifi on any of these firmware's and I've been using them for almost 2 years now.

    However I'm in Canada/USA region.

    Going back through pages of this thread the people that I've seen with problems are outside of North America with region issues.

    And yes using fixed channels instead of auto does seem to make it more stable for some.
    slidermike likes this.
  53. VoYaGeRTM

    VoYaGeRTM Serious Server Member

    Hi all,

    Just a comment about the 5ghz channels.
    I have the same problem if i dont set it fixed on a range that works. Tho thats only for the control channel. The rest doesnt matter.
    As some already said it probably has to do with it being setup for north America.
    Mind you its not just this firmware.
    I have had several on my r7000 before.
    So far i like this one the best.
    Running it for a year now and as long as i use a fixed control channel (one i can see ofcourse here in europe) there is nothing wrong.
    All my devices work over 5ghz that have it.
    Several devices from America, Europe and China :D

    Edits: stupid phone using dutch spelling on english words...

    Verstuurd vanaf mijn MI 3W met Tapatalk
    Makaveli and slidermike like this.
  54. Imperial

    Imperial Serious Server Member

    Hi folks, does anyone know of a permanent fix to the missing UI screens(parental/dns etc..) in our routers? Thanks
  55. slidermike

    slidermike Networkin' Nut Member

    No fix needed, it's not a break.
    How to enable the screen has been discussed multiple times.
    Makaveli and b1ggles like this.
  56. Makaveli

    Makaveli Networkin' Nut Member

    Last edited: Jan 15, 2018 at 8:14 PM
    Imperial and slidermike like this.
  57. Imperial

    Imperial Serious Server Member

  58. Hypnosis4u2nv

    Hypnosis4u2nv Network Newbie Member

  59. wgblondel

    wgblondel New Member Member

    Hello everyone,

    I installed with no issue Xwrt-Vortex on my Netgear R7000 (R7000-100PES).

    Everything works correctly except the 5Ghz wifi. In the admin panel I see both SSID, one for 2.4Ghz and one for 5ghz. In the wireless settings, both bands are enabled. Both leds for 2.4Ghz and 5Ghz are on on the router. "Hide SSID" is set to "No".

    However I do not see the 5Ghz SSID on my devices (computers / phones / etc). I could see it with the stock firmware.

    Is it a bug? Or maybe I forgot to do something?


    EDIT : I may have found a solution. I'll set the router region to EU and see if it does something.
    EDIT2 : Ok, I don't know if it changed something. I can't see the 5Ghz SSID on my phone (Honor 8 Pro, which is dual band), but I can see it with an Aukey AC1200 Dual Band USB Adapter...
    EDIT3 : Ok, found it. Changing the router region to EU didn't do anything I guess, because on the Wireless settings, the "Control channel" was set to "Auto", and the router chose "Channel 149" which is a USA/China only channel. I could choose other channels, including USA/China only channels.
    When I choose a channel that is OK for europe, eg. channel 140, and apply, it doesn't do anything as it reverts back to "Auto"...
    EDIT4: Ok, the ccode-eu.sh script I downloaded is wrong... it actually set the router region to US...
    EDIT5: I used the ccode-gb.sh script and it works now! Finally!
    Last edited: Jan 17, 2018 at 1:11 AM
    Stimpy88 and slidermike like this.
  60. Almighty1

    Almighty1 Serious Server Member

    Does anyone know what the default settings for these two are:
    Under System Log - General Log

    Default message log level
    Log only messages more urgent than

  61. wgblondel

    wgblondel New Member Member

    The default settings are notice and debug, accordingly.
    Almighty1 likes this.
  62. b1ggles

    b1ggles Network Newbie Member

    I never cease to be amazed how many people will do something as drastic as flashing a perfectly good router, that can potentially turn an expensive bit of kit into a bookend, without reading any of the mountain of info located in the same place as the files they downloaded to do it.

    Most of the new user questions are answered multiple times no more than a few pages back from where they posted their issue and often on the same page.
    Makaveli and slidermike like this.
  63. Almighty1

    Almighty1 Serious Server Member

    Thanks, just trying to narrow down on what is causing the NETGEAR R7000 running the latest XWRT and NETGEAR R8000 running both the latest stock and now latest koolshare ASUS RMerlin ported with a Arris Surfboard SB8200 DOCSIS 3.1 modem on a 250Mbps down/10Mbps up profile connected to a Arris E6000 CMTS that runs normally at 298Mbps/13Mbps but then slows down to 50Mbps-144Mbps down/13Mbps up. Turns out that the CTF enabled is fine but CTF enabled with FA also enabled is a problem which was solved by turning FA off using the shell command prompt of the router. Read more about it here:
  64. cybrnook

    cybrnook Addicted to LI Member

    That is a record run on sentence :)

    Try connecting directly to the modem. Rule out the easy stuff first. If it's doing it on three different routers/firmware(s), I think it's safe to rule out the router.
    slidermike and Makaveli like this.
  65. Almighty1

    Almighty1 Serious Server Member

    I already know that connecting directly to the modem doesn't have the problem and connecting wired to the LAN ports don't have the problem since that was the first thing I did on both routers when I first factory reset and tested it except on the R7000, the last time I enabled FA by enabling jumbo frames as that's covered in greater detail on the thread on the other link. It's the FA (Flow Acceleration) that is causing the problem which on the R8000 with koolshare is fixed simply by issuing in the shell:
    nvram set ctf_fa_cap=0
    nvram commit
    and once it works, I can then:
    nvram unset ctf_fa_cap
    nvram commit
    and it will still continue to work.

    Before doing the first nvram set ctf_fa_cap=0.
    nvset get ctf_fa_cap would return a blank which means the variable wasn't set to begin with.
    The other difference is on the R8000, koolshare in the LAN - Switch Control - NAT Acceleration which is also on Auto would only say CTF Only enabled even if I enable Jumbo Frame which on the R7000 would make CTF Only change to FA. Tools - SysInfo - HW Acceleration would only say Enabled unlike the R7000 which would mention either CTF Only or CTF and FA. The R8000 also is blank when one does a "nvram get ctf_fa_mode".

    On the R7000 with XWRT, it's slightly different as:
    nvram get ctf_fa_cap returns as a 1
    nvram get ctf_fa_mode returns as a 2

    I just did a factory reset and basically configured everything as usual and did the LAN section last from left to right.

    LAN - Switch Control - NAT Acceleration would say CTF Only enabled for everything as I left the enabled Jumbo Frame disabled.

    At this point in time, the speedtests were still doing 298Mbps down/13Mbps up on Wi-Fi.

    then I configured as it's needed for my Oppo BluRay BDP-105D Player to work with their app:
    LAN - IPTV

    Lan Port section
    Select ISP Profile None (Default)
    Choose IPTV STB Port None (Default)
    Special Applications section
    Use DHCP routes RFC3442 & Microsoft
    Enable multicast routing (IGMP Proxy) Enable
    Enable efficient multicast forwarding (IGMP Snooping) Enable
    UDP Proxy (Udpxy) 0

    so I hit apply and then:
    LAN - Switch Control - NAT Acceleration would say CTF (Cut Through Forwarding) and FA (Flow Acceleration) accelerator are enabled.

    The speedtest now does up to 240Mbps down/12Mbps up and this is the good side of it since it can be stuck at 50-150Mbps on the downside most of the time. Does anyone know how to turn off the FA (Flow Acceleration) as that will fix the problem since the method that works on the AC-68U/R does not work on the R7000 but works on the R8000 running koolshare ASUS RMerlin.

    I am not the only one with this problem either as even in this thread, post #3161 mentions the problem and it's mentioned here as well:

    The only way to fix it is to disable FA while keeping CTF enabled as it's FA that is causing performance problems while on Wi-Fi. Wired doesn't have the problem as mentioned before. I haven't tried the NETGEAR stock firmware yet on the R7000 because the ipv6 compatibility with Comcast is flakey as DHCP-IPv6PD is not supported. I might give Tomato Shibby a try in a few days. I would use DD-WRT except it lacks hardware acceleration which is needed, CFT only without FA.

    Since currently:

    admin@NETGEAR-R7000:/tmp/home/root# nvram show | grep ctf
    size: 52383 bytes (13153 left)

    I even tested using iperf/iperf3 between wifi devices on the WLAN and the speeds were the same locally as it was to the WAN to rule out the Wireless NICs on the notebook and the Mobile phone's wifi being defective as the speedtests were the same.
    Last edited: Jan 18, 2018 at 8:29 AM
  66. cybrnook

    cybrnook Addicted to LI Member

    I think the R7000 can hit 300Mbps without CTF, have you tried? You may be able to just turn it all off and still reach your CAP, just at higher CPU load.

    I read it twice, and still maybe I missed it. But I don't see where you issued:

    nvram set ctf_fa_cap=0
    nvram commit

    On the R7000.
    Last edited: Jan 18, 2018 at 3:38 PM
    slidermike likes this.
  67. Koruneko

    Koruneko Network Newbie Member

    Hello !
    I think there's a bug with the dual WAN management since the 380.68. and 380.69 with double WAN conf.

    Setting that works :
    Primary WAN : 'standard' WAN using the ISP box plugged on the WAN socket of R7000.
    Secondary WAN : USB with an Android phone using tethering mode.
    Mode failover.

    Setting that doesn't work anymore :
    Primary WAN : USB with an Android phone using tethering mode.
    Secondary WAN : 'standard' WAN using the ISP box plugged on the WAN socket of R7000.
    Mode failover.

    In this last mode, without plugging the phone on USB, the R7000 is using the secondary WAN ; but the LAN devices can't see devices, nor internet throught the WAN.
    I'd like to use this second setting because most of the time I'm using my ISP box, but when I need a better transfert rate I just have to plug my phone to swap on USB/tethering in 4G+ mode. Failover just automaticaly swap to the primary ...

    With 380.65, both of these settings works fine.

    Thanks for considering it :)

Share This Page