1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Asuswrt-Merlin / XVortex on Linksys EA6900 (Supports Tomato / DD-WRT)

Discussion in 'Other Firmware Projects' started by cybrnook, Sep 24, 2015.

  1. cybrnook

    cybrnook Addicted to LI Member

    USB 3 can generate noise that can interfere with 2.4GHz signals (that's why there is 'Reduce USB3 interference' setting on the 2.4GHz Professional page to run USB3 as USB2).
     
  2. vr2062

    vr2062 New Member Member

    I just bought an EA6900 v1.1 from newegg. The router has 1.1.42.172191 firmware. I am not able to downgrade it to an earlier firmware using web GUI.

    I successfully uploaded linksys_ea6900_webflash.bin using TFTP. But the firmware does not change when the router is rebooted. I tried the TFTP procedure with 158863 and 161129 versions of linksys firmware. In all cases transfer to router is successful but the firmware does not get loaded after the reboot. Same 172191 version of linksys keeps coming up after the reboot.

    I would appreciate any suggestions on how to correct this.
     
  3. FlatEarther

    FlatEarther Network Newbie Member


    Did you try a reset using the reset button both before and after firmware flash?
    Disconnect all ethernet cables.
    With power connected hold down reset button for one minute, release and allow five minutes to fully reboot. Reboot PC, connect and see if that helps...
    Good luck.
     
    Last edited: Aug 4, 2017
  4. FlatEarther

    FlatEarther Network Newbie Member

    Did you try a reset using the reset button?
    Disconnect all ethernet cables.
    With power connected hold down reset button for one minute, release and allow five minutes to fully reboot.
    Also use the site survey and then select a wifi channel (dont use auto) for each freq, and use WPA2 Personal password...

    Can't help with the USB as I don't use it.
    I used xVortex v380.65 on EA6900v1 and EA6500v2.
    5.0, 2.4, and guest wifi all work good.
    Recently updated EA6500v2 to v380.67 and all wifi still good.
     
    Last edited: Aug 4, 2017
  5. vr2062

    vr2062 New Member Member

    See below
     
    Last edited: Aug 6, 2017
  6. Leonardo MOrales

    Leonardo MOrales New Member Member

    Has anybody tested tomato 140 using this procedure?
     
  7. vr2062

    vr2062 New Member Member


    I followed instructions on dd-wrt forum.

    http://www.dd-wrt.com/phpBB2/viewtopic.php?t=309593

    Those instructions worked pretty much exactly as written.

    I successfully loaded the CFE and used the instructions on the post #1 of this thread to load XVortex FW 380.67.

    Thanks for the detailed guide.
     
    Last edited: Aug 6, 2017
  8. DaxTraj

    DaxTraj New Member Member

    Managed to get Advanced Tomato 3.4.140 running on EA6900 v1.1 thanks to this guide

    I need to return box to Linksys - which is best method to put Linksys firmware back on? I notice from the linksys website its an .img file. Can this be loaded by the CFE mini-webserver?

    Any help would be gratefully received.
     
    Last edited: Aug 8, 2017
  9. collider

    collider New Member Member

    I'm trying to load XVortex to my EA6900 router and seems the router is locked for 3rd party firmware and downgrade. Thanks. for this guide, but I'm not sure how to merge this guide with the instructions on the post #1. I mean, by following the guide you provided, at which step, I should back to the instructions on post #1 for loading XVortex.

    Thanks.
     
  10. collider

    collider New Member Member

    I followed the steps, but after 1 or 2 minutes using miniweb server to upload the XVortex. The webpage said This page can't be displayed. Tryed multiple times, but with same results. What should I do?
     
  11. XVortex

    XVortex Networkin' Nut Member

    XWRT 380.68 has been released.

    As Merlin says:
     
    apvmtan and cybrnook like this.
  12. cjapeterborough

    cjapeterborough New Member Member

    Slightly off topic but I have just used this guide to flash an EA6700 to XWRT 380.68 and seems to work well.
    Had to flash an earlier 380.64 from the web server first and then upgraded to the latest version.
    No issues with wireless ...AC is supported ,both USB's seems fine.
    The only issue is the port mapping LAN1 changes to WAN and the original WAN changes to LAN4.
    Think I will just change the labels around on the back!

    Not sure I will use it much in anger as the EA6700 800MHz seems very hot CPU wise approx 85C at stock speed compared to the EA6900 55C at 1200MHz
     
  13. Leonardo MOrales

    Leonardo MOrales New Member Member

    Hello,
    I've installed the version 380.68_1, but it seems that it's not supporting anymore QoS, is it right? the menu isn't appearing anymore :(

    Thank you!
     
  14. diskeeper

    diskeeper New Member Member

    Same here. No QoS so I downgraded firmware to 380.67. But I think QoS is there, only the link missing.
    Try to open with this link on new firmware. your.router.ip.adress/QoS_EZQoS.asp
     
    Last edited: Aug 29, 2017
  15. Xkwizt

    Xkwizt New Member Member

    @XVortex @cybrnook

    When I first flashed this it was working fine, I flashed the latest EA6900_380.68_1 firmware. I rebooted the router this morning, now nothing works. I can get into the web interface but nothing else works, basically all I have is web interface access. I tried doing a factory reset, reconfigured the router and still not working.

    I also tried to TFTP back to stock, didnt work. Tried the 30/30/30 reboot, tried erasing NVRAM, tried to enable SSH... i also got into the rescue mode (ping with TTL 100) tried numerous ways but i cannot get this thing to work.

    Is there a known bug?

    Is there a way to reinstall/reformat the firmware or go back to stock? Is there a way to switch between boot partitions?

    Please help!

    Update, I think the custom CFE was not installed properly which is now causing problems.
     
    Last edited: Sep 3, 2017
  16. cybrnook

    cybrnook Addicted to LI Member

    It is a critical step in the instructions to flash the custom CFE for the EA6900. If you did not do this part, and flashed only the firmware, then you have no real way back, sorry.
     
  17. dslabby

    dslabby Networkin' Nut Member

    Just followed your excellent guide and have Xvortex on my EA6900 v1.1 Had to restore to previous firmware first but after that it all worked as advertised. I especially liked the points where you urge patience and waiting instead of instinctively hitting keys because it looks like nothings happening. Saved me from a faux pas or two along the way. Can't wait to swap this one out for my stock 6900 currently running the home network. I have used Merlin's Asus firmware for years and loved it. Thanks again for your guide and all the help you have provided the other members, which I gladly used and didn't have to ask again. This was fun. All you have to do is read and don't stray from the path. :D
     
    cybrnook likes this.
  18. JoeBlack

    JoeBlack Network Newbie Member

    Gentlemen

    Just got onto the bandwagon LOL. Was on a EA6900 V1.1 was successfully able to follow the process to flash the merlin image. An awesome guide for anyone. So thumbs up.

    Having said that, I managed to flash - 380.68_2. One issue though 5gz shows up but am unable to connect. I read from previous few posts that someone was able to upgrade to 380.67 and did not have any issue.

    Any help is greatly appreciated. Thanks in advance.
     
  19. Xkwizt

    Xkwizt New Member Member

    Fixed, i RMAed the router and obtained a replacement this time i ensured the CFE was installed first. I cant believe i missed that step when i originally flashed it.

    This router is a BEAST with this firmware.

    Thank you.
     
  20. cybrnook

    cybrnook Addicted to LI Member

    HAHA, I can't see how you missed that step, it's basically what the whole guide revolves around ;-)

    Anyways, enjoy.
     
  21. bayard0

    bayard0 Serious Server Member

    I just got the router v1.1 today and i was setting it up, got to the mini webserver and got as far as you, it looked like it was uploading but then it would go to the 'page can't be displayed' on both firefox/ie11. I then decided to try uploading Tomato 140 fw and that one uploaded without a hitch on the first try. I don't know if the xvortex fw file size was too big, but it's running on Tomato now.

    Would have liked to try xVortex.
    Is there a easy way to upgrade from Tomato to xVortex?
     
  22. Verlaek

    Verlaek New Member Member

    Protecting the 5Ghz wifi makes the 5Ghz access point unable to login with this software. (2.4 Ghz and 5Ghz-Guest with protection is working).

    After some experiments with the router I decided to flash my 3 linksys EA6900 routers with EA6900_380.68_2 firmware. All seems to work well, although activating a 5Ghz password protection makes the system unaccessable for a 5G connection. Unprotected access is working, but that's insecure so no option.

    First I thought there was an issue with the channels as I could not see the wifi popping up in wifi analyzer on my android, so I forced the channel to a free one (52) but also tried others. Also checked with 20, 40 or all bandwiths. I have the same issue with all wifi devices. So it's not on the computer/iPhone/Android side.

    My setup is pretty straightforward as I am using the router in access Point(AP) mode as another dhcp server is generating the ip addresses. The quick setup does it all.
    • Ethernet is working
    • 2,4Ghz protection wpa2-personal wifi is working
    • 5Ghz wifiis not wordking: protected access is denied (definately with the correct password as identical to 2,4 Ghz) using LINKSYS and LINKSYS_5G defaults. I checked with both wpa2-personal and wpa-auto-personal

    (Before you ask: I had the same issue in router mode).

    First I checked MAC addresses, these are all correct and different (Eth + 2,4Ghz identical, 5Ghz different)
    I also checked the dhcp server and made sure this is correct also.

    Manually setting ip addresses for this wifi still does not make it connecting.

    Then I made 5Ghz open, and created a 5Ghz-guest network with wpa2 protection, next to the already protected 2.4Ghz.

    Strangely this protected guest 5Ghz network works and accepts that same protection and password.

    So, what can I do? as this happens with all my 3 routers, so not a hardware problem I think.
    I see the router trying to connect and verifying on my windows 10 box. It seems to do that 3 times before giving up with an unable to connect message
     
  23. JoeBlack

    JoeBlack Network Newbie Member

    I'm in the same boat. But I believe somewhere in the thread there were recommendations to restore to factory defaults atleast once which resolved the issue for someone. I'm going to try is over the weekend. But perhaps if you have a chance, you can attempt to see if that resolves your issue with 5Ghz.
     
  24. cybrnook

    cybrnook Addicted to LI Member

    I assume both of you are located in the U.S. and have a static channel selected for 5Ghz, like 149?
     
  25. cjapeterborough

    cjapeterborough New Member Member

    Bit of an amateur but I have successfully cross flashed a number of EA6900/R7000 and an EA6700 and am very happy with the results......however.....has anyone successfully flashed back the stock CFE?

    Dont be too hard on me............

    I would like to raise an issue I have observed with the CFE backup process.....it could be me but I don think so!

    As an exercise I tried to revert back to stock (unlikely but hey) and hit a brick wall unable to flash back the original saved stock_cfe.bin.

    I have observed the file size is 512kb for stock_cfe.bin versus 227kb for the edited cfe_ea6900.bin
    (32 line entries versus 196 despite the file size?)

    Looking at the saved stock_cfe.bin from two EA6900 and the EA6700 they all have the same mac address with no entry for the WPS password...basically they are all the same???

    Trying to flash back using the command lines within the tutorial seemed to complete (ie command line returns with no error) but the CFE is not loaded.(I guess thank goodness for that!)

    As the stock_cfe.bin is not used after its initial save this may not have been noticed previously?

    In a nutshell I think there is a problem with the backup procedure for the stock_cfe.bin
     
  26. JoeBlack

    JoeBlack Network Newbie Member

    Correct.
     
  27. cybrnook

    cybrnook Addicted to LI Member

    The CFE you back up originally is just a "recovery" CFE copy. You need to use XVortex's tool to add your router specific entries back in, WPS, MAC etc.....

    The Stock unit relies on "generic" values in the CFE in conjunction with the router specific values that live in NVRAM.
     
  28. cybrnook

    cybrnook Addicted to LI Member

    I can check on my brother in laws sometime soon. He is on 68_2 and has no issues with 5GHZ, and has no issues using the MAC process I have outlined.

    I personally haven't owned this router in some time, so can only really support "in theory".
     
  29. JoeBlack

    JoeBlack Network Newbie Member

    Ok. That would be awesome.
     
  30. cjapeterborough

    cjapeterborough New Member Member

    Thanks for the reply I guess that makes sense as I assumed the backup would contain the full set of variables.
    How do you know what the stock_cfe.bin should contain........do all the NVRAM variables have to be line entered back in,and does the order matter?
     
  31. cybrnook

    cybrnook Addicted to LI Member

    Just the important ones, same as you did when converting the XVortex CFE.

    However, if you are looking to go back to stock, I have a big red message on first line that I have not developed a way to do that.

    If I would have to try and do it, what I would do is "script" the nvram setting of all the variables you backed up when converting over, and while still on AsusWRT run that script to "set" all the variables back to what they were when you were on DD-WRT, making the backup. THEN, I would load the stock firmware again through the recovery webserver. Not sure we can juggle a way to flash the stock CFE back on prior to flashing the linksys firmware, since we need the asus cfe to cross flash.
     
  32. cybrnook

    cybrnook Addicted to LI Member

    No promises on a time frame though. Has been weeks since I have been over there last.
     
  33. JoeBlack

    JoeBlack Network Newbie Member

    Sure I understand. I can live without 5gz for the time being. Also going to try factory defaults and see if that helps. I will keep you posted :) Thanks again
     
  34. JoeBlack

    JoeBlack Network Newbie Member

    Ok couldn't wait till weekend and got to factory reset and still unable to connect using 5ghz. Only works if kept open no security. Appears to be a bug. I suspect folks who have had 5ghz working and upgraded to the most recent are not seeing any issues. Anyone starting at the current version is running into this challenge. Can someone suggest the version that works fine from getgo and how do I downgrade? Using the firmware webUI or need to boot into mini server and then upload the image? Thanks again.
     
  35. cjapeterborough

    cjapeterborough New Member Member

    Thanks again....I probably have too much time on my hands messing with this stuff and with limited knowledge.
    The motivation for going back was based on a 3 year warranty on one of the EA6900's ie in case of return.
    They are cheap enough now to be a disposable item in reality and the Xvortex/Merlin firmware is superb!

    No reason to go back really.
     
  36. cybrnook

    cybrnook Addicted to LI Member

    @JoeBlack can you read me your mac addresses?

    What do you have for:

    nvram get et0macaddr
    nvram get 0:macaddr
    nvram get 1:macaddr
     
  37. JoeBlack

    JoeBlack Network Newbie Member

    Once again appreciate your continued support. @Work now. Once I hit home, I will get you the details. Noob question - should I get the above from the updated CFE bin file which was uploaded or from WebUI?
     
  38. cybrnook

    cybrnook Addicted to LI Member

    You will be logging onto the OS layer of your router and running the commands I wrote out for you.
     
  39. JoeBlack

    JoeBlack Network Newbie Member

    Got it. I will update you.
     
  40. alphabet

    alphabet New Member Member

    Thanks for the EA6900 guide cybrnook.

    I am also unable to connect using the 5GHz wireless after enabling WPA2-Personal security.

    Currently using latest xwrt version 380.68_3.

    I have factory reset after enabling WPA2 security and still no go.

    When I flash the EA6900 to advanced tomato the 5GHz works perfectly with WPA2 enabled.

    My mac addresses are:

    nvram get et0macaddr=xx:xx:xx:xx:20:B0
    nvram get 0:macaddr=xx:xx:xx:xx:20:B0
    nvram get 1:macaddr=xx:xx:xx:xx:20:B1

    Cheers
     
  41. JoeBlack

    JoeBlack Network Newbie Member

    Here is what is looks like :
    nvram get et0macaddr=xx:xx:xx:A7:B3:34
    nvram get 0:macaddr=xx:xx:xx:A7:B3:34
    nvram get 1:macaddr=xx:xx:xx:A7:B3:35
     
  42. cybrnook

    cybrnook Addicted to LI Member

    Try:
    nvram set et0macaddr=xx:xx:xx:xx:20:B0
    nvram commit
    nvram set 0:macaddr=xx:xx:xx:xx:20:B1
    nvram commit
    nvram set 1:macaddr=xx:xx:xx:xx:20:B2
    nvram commit && reboot

    Try:
    nvram set et0macaddr=xx:xx:xx:A7:B3:34
    nvram commit
    nvram set 0:macaddr=xx:xx:xx:A7:B3:35
    nvram commit
    nvram set 1:macaddr=xx:xx:xx:A7:B3:36
    nvram commit && reboot

    Of course filling in your "xx" values with the correct substitutions. We will try one step at a time, so hold off on the CFE questions until we test this.
     
  43. alphabet

    alphabet New Member Member

    I am unable to save this to nvram. It keeps defaulting after a reboot to the original xx:xx:xx:xx:20:B0.

    After reboot I have in nvram:

    nvram get et0macaddr=xx:xx:xx:xx:20:B0
    nvram get 0:macaddr=xx:xx:xx:xx:20:B0
    nvram get 1:macaddr=xx:xx:xx:xx:20:B2

    Still the problem persists on the 5GHz wireless.
     
  44. cybrnook

    cybrnook Addicted to LI Member

    Do you have the ability to modify the CFE once more with the above values, flash, then factory reset and test again?

    In my guide, last post on the last step is some quick steps to flash the CFE from within asuswrt.
     
  45. alphabet

    alphabet New Member Member

    Success! :)

    5Ghz wireless with WPA2-Personal enabled now working.

    I added and flashed these values to CFE:

    et0macaddr=xx:xx:xx:xx:20:B0
    0:macaddr=xx:xx:xx:xx:20:B1
    1:macaddr=xx:xx:xx:xx:20:B2

    Interestingly, nvram still is showing 0:macaddr=xx:xx:xx:xx:20:B0 after factory reset and CFE edit.

    Thanks for your help cybrnook.
     
    JoeBlack and cybrnook like this.
  46. cybrnook

    cybrnook Addicted to LI Member

    Yeah, it's a strange one. Originally when I put the guide together that (what you are using now) was the format I used. And as you can guess, there were pocket cases of users appearing stating the same, that 5GHZ did not work.

    So after some troubleshooting and testing, we all agreed that the working solution was to go back to the standard formula of et0=et0, 0=et0 and 1=et0+1, and that seems to have worked well......until now. So now the reverse is appearing, putting us back to the standard process I had before.

    So all in all, who freaking knows :) It could be tied to region, or just pickiness on how the firmware is calculating.

    Either way, glad it's sorted out.
     
    alphabet and JoeBlack like this.
  47. JoeBlack

    JoeBlack Network Newbie Member

    @alphabet Thanks for trying the suggestions by @cybrnook and confirming the fix. So probably, will have to go thru the same process all over again after having corrected the macaddr values.

    Would you mind sharing your steps to modify and reflash the bin or are these same steps what I originally followed. Thanks
     
    Last edited: Sep 16, 2017
  48. cybrnook

    cybrnook Addicted to LI Member

    You can do it all right from within XVortex. Just take the already modified CFE you created the first time, open it back up with the XVortex CFE tool and modify the MAC's once more. Save it out as something like new_cfe_1.bin or whatever, just so you know this is the updated one. Copy it up to your router, along with the mtd-write tool and follow those steps in my last post last lines of the guide (then factory reset after your done):

    MISC:
    #Flashing CFE from within XVortex/AsusMerlin:
    chmod +x ./mtd-write
    ./mtd-write -i new-cfe.bin -d boot
     
    JoeBlack likes this.
  49. JoeBlack

    JoeBlack Network Newbie Member

    Greatly appreciated. I should have read the last sentence properly @work so less focussed on other things LOL.
     
  50. JoeBlack

    JoeBlack Network Newbie Member

    Update : I can confirm now that 5Ghz is working as expected. Thanks a bunch @cybrnook. Your work and continued help is commendable.
     
    cybrnook likes this.
  51. monoton

    monoton Network Newbie Member

    The koolshare dudes seems to do it like this:
    et0macaddr -> router mac address
    0: macaddr -> router mac address +1 (some say +2, because 5G encryption Rom issue)
    1: macaddr -> router mac address +4

    That is if I understood the google translation correctly.

    https://translate.googleusercontent...1.html&usg=ALkJrhi1_ArpeOyS7fm1JJdsOjufALsGcg
     
    Last edited: Sep 18, 2017 at 11:02 PM
  52. Samael

    Samael New Member Member

    Hello everyone,

    First of all a big thanks for the constant work of @XVortex and to the beautiful host of this conversation: @cybrnook.

    Soon I'll be getting my new EA6900 and after reading this whole thread and a few others I think I'm ready to lose some hours of my life working on it.

    Beside all the encountered problems, reported here, the only thing that is making me hesitant is the functionality of QoS in Xwrt-Vortex.. searching a bit on the internet I could find only some basic/shallow information on it.

    I have approached the world of router's custom firmware with the sole intention of having more control over my home network: setting up groups of devices, dividing the bandwidth equally to please everyone on the network or reserving a tot amount of bandwith to a single interface.
    In all this, stock firmware isn't soddisfying me as it should..

    With this in mind my questions are.. how is the QoS of XVortex?
    Is it personalizable enough to my taste?
    Which are the QoS features provided by XVortex?

    Thank you all for taking the time to read a newbie's question.

    Have a nice one!

    PS: Forgive my english.
     
  53. Get-Routed

    Get-Routed New Member Member

    First timer here - I've used this guide with success but not "great" success.

    Some information on my network, I have 150/150 Mbps connection and a Cisco switch doing some light QoS and limiting to about 125/125Mbps. I'm currently trying to expand my coverage so that I have better reception in further areas of my property.

    I have an Asus RT-AC66U running Asuswrt-Merlin in AP mode and it achieves full upload/download.

    I would like to know if others have experienced the same issues as I.

    I flashed 2 separate EA6900's with the Asuswrt-Merlin/Xwrt-Vortex and have had less than consistent results.
    I've put these in AP mode and in the same position as the AC66 tested from the same spot, about 15 feet away through 1 wall.

    1st EA6900 in AP mode has half the Download speed than Upload speed. (~56Mbps/95Mbps)
    2nd EA6900 in AP mode has half the upload speed than Download speed. (~99Mbps/44Mbps)

    The 1st EA6900 I updated the CFE to have sequential MAC addresses as some of the latest replies in thread recommend.
    The 2nd was flashed with the recommended CFE MAC address settings given in OP.

    Are there others experiencing this asynchronous throughput? Is there a setting I should be flipping (H/W acceleration)?

    (I also apologize if this has been discussed previously but it's a very long thread, and reading 700+ responses is more time consuming than I have, I've tried some Googling and some of these posts but not all)
     
  54. cybrnook

    cybrnook Addicted to LI Member

    LAN -> Switch Control. Turn on NAT acceleration if it's not already.
     
  55. Get-Routed

    Get-Routed New Member Member

    Thank you for the prompt response. Because I'm using this in "AP" mode and not "Wireless Router mode" I don't see this option.
    However, I have continued to do speed tests since my last post and the speeds have balanced out more and are closer to the peak. 118/100.

    So I believe my problem is actually only with the "1st" AP. Which is the one that has all the MAC addresses in sequential order instead of having the "standard" from OP.

    I'm going to redo the MAC's as "standard" and flash it once more and try again. Will post any updates.
     
  56. Get-Routed

    Get-Routed New Member Member

    I think the full reflash with MAC entries as OP states corrected the issues I was seeing.
    Getting much better DL/UL consistency and closer to synchronous speeds.
     
    cybrnook likes this.

Share This Page