1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

asymmetric link performance between wired (switch) and wireless comp

Discussion in 'Tomato Firmware' started by sponge_bob_128, Oct 28, 2007.

  1. sponge_bob_128

    sponge_bob_128 LI Guru Member

    I have a WRT54GL and tomato 1.10 and I am getting ~3X slower on the wired (switch) computer to wireless (laptop) direction.

    wireless --> wired : +2000KBytes/sec
    wired --> wireless : ~700KBytes/sec

    Is this normal and why does it happen?
  2. u3gyxap

    u3gyxap Network Guru Member

    Don't know why is happening, but it is a Windows problem, not related to the router or the firmware. Had id for a while, then after reinstall on both stations it got fixed.
  3. mstombs

    mstombs Network Guru Member

    Can just be a TCP/IP config issue with RWIN much smaller on the wireless connection plus a bit more latency on wireless. See what http://www.speedguide.net/analyzer.php says about each connection and try tweaking!
  4. sponge_bob_128

    sponge_bob_128 LI Guru Member

    Played around with RWIN already and tried DD-WRT.
    From a little google-ing it may be an issue with the Intel 3945abg wireless chipset. Interestingly when I do run at 3mB/s pushing data off the laptop, the machine goes sluggish (randomly ignoring keyboard/ mouse jumping around), so this throttling may be a preventative measure.
  5. azeari

    azeari LI Guru Member

    sounds like a processor or ram problem there. -points to sluggish mouse and keyboard-

Share This Page