1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[B]PRoBLEMS RESET MY WRT54G V2.2. FIRMWARE CORRUPT!![/B]

Discussion in 'Cisco/Linksys Wireless Routers' started by avic5410, Sep 30, 2005.

  1. avic5410

    avic5410 Network Guru Member

    Hello,

    2 days ago, I bought a WRT54G and I upgrade a corrupt firmware. Since then I can't go to the web configuration http://192.168.1.1/. I try to reset the router with hard reset, I follow the next indications that can I reach in an other mail but I can't ping my router and obviosly I can't upgrade the new firmware. The indications that I can follow are the next: (sorry are in spanish):


    Aqui les posteo unos Comentarios Interesantes acerca de la Recuperacion de un WRT54G de Linksys por Flasheo Corrupto.
    Estos comentarios se los agradecemos al Ing.Luis M. Lopez Herrera,de Atotonilco, Jalisco, Mex.

    Mi WRT54G es version 2.2, y les voy a comentar como solucione el problema despues de una serie de intentos (fallidos casi todos), ya que en las sugerencias que econtre en la red no hablan acerca de los indicadores del panel frontal los cuales es importante interpretar lo que nos indican.

    Si el AP muestra reseteos continuos (cada 4 segundos aprox. y se nota en los indicadores del panel frontal encendiendose todos y despues de unos parpadeos del indicador de power, vuelve a realizar la secuencia y asi sucesivamente) esto se debe a que el firmware que utilizaste para la version del linksys no es la adecuada, cada version de AP linksys tiene problemas de funcionamiento con algunos firmwares, algunos se resetean y otros no puedes entrar a la pagina web de configuracion via ethernet, solamente por via wireless.

    En este caso procedi de la siguiente manera:
    1.- Abrir (Inicio) (Configuracion) (Conexiones de red) (Conexion de area local)
    2.- Con el boton derecho hacer click y abrir (Propiedades).
    3.- Se abre una ventana y en el menu GENERAL escoger
    en "Esta conexion utiliza los siguientes elementos" (Protocolo Internet TCP/IP y hacer click en(Propiedades)
    4.- Se abre otro menu y en el menu GENERAL, hacer click en el circulo "Utilizar la siguiente direccion"; colocar en DIRECCION IP: 192.168.1.10; en MASCARA DE SUBRED: 255.255.255.0 y hacer click en ACEPTAR.

    Esto para asignar una IP fija al adaptador ethernet

    Despues de esto utilice un programita muy util "TFTP" que no es el que incluye Windows XP, ya que este corre bajo Windows y abre una ventana donde tenemos que indicar la direccion del AP que generalmente es 192.168.1.1; el PASWORD: generalmente "admin" o el que hayas utilizado durante tu ultima actualizacion de firmware si es que lo modificaste, y por ultimo la ubicacion del archivo firmware, aqui yo utilice inicialmente el EWRT-0.2 ya que con varios que probe no logre cargarlo en el equipo, si se logra detener los reseteos constantes con este firmware, de aqui en delante ya es mas sencilla ya que se puede accesar por via ethernet o por wireless. Si no es asi entonces prueba con el Hiperwrt 2.0b2 G a mi me dio resultado con este ultimo ya que repito mi WRT54G es ver2.2 (lo indica la etiqueta inferior del equipo). Si aun con estos no te da resultado prueba con varios hasta que logres que se estabilice el equipo, lo cual sucede cuando el led de power y el indicador de conexcion al puerto ethernet (1,2,3,4) permanezcan encendidos. Si por algun motivo con los firmwares que tengas no lo logras (en mi caso fueron casi 10 diferentes), tendras que realizar un reseteo de la memoria RAM del equipo, (tienes que abrirlo lo que indica perder la garantia) desconectandolo de la alimentacion y haciendo un puente con un desarmador pequeño en los pines 15 y 16 (la memoria se localiza facil ya que tiene una etiqueta amarilla y se alcanza a leer Intel), sosteniendo el puente tienes que conectar la alimentacion y esperar unos segundos hasta que veas que el led siguiente al de power se enciende y apaga a razon de cada 2 o 3 segundos ( esto indica que esta en espera de que se cargue nuevamente el firmware que desees).
    (NOTA de Patula WiFi: al final agregue fotos para que localizen el chip de memoria en otras versiones del WRT)
    Si tienes buena paciencia lograras meter el firmware adecuado y hacer que los leds se queden encendidos.

    Despues de esto hay que entrar a la pagina web de configuracion del equipo, ya sea por medio de wireless o por ethernet y antes que nada realizar un reset de fabrica en el menu del administrador. (Para asegurar que la RAM este libre de remanentes de algun firmware mal cargado) Yo realice esta operacion 4 veces, tu sabes cuantas lo realizas.

    Ahora si tienes tu AP listo para cargar el firmware que desees siempre y cuando tomes en cuenta la version de tu equipo, ya sea 1.1, 2.0, 2.2, etc.. ya que como repito no todos los firmwares son adecuados para todas las versiones de equipo, en algunos no te deja cagarlo y te da mensaje de error, pero en otros te provoca que nuevamente tengas parpadeos en el led de power o que se resetee continuamente y por ende no te deja entrar ni por ethernet ni por wireless a la pagina de configuracion y tendras que volver a realizar todo el procedimiento de nuevo. Suerte y si tienen alguna duda pueden escribirme a (Omitido por cuestiones Eticas).com, cuento con algunos firmware que me encontrado, otro detalle que se me pasaba era decirles que tambien depende de donde bajen el firmware ya que en algunos lugares tiene errores y eso provoca fallos en los equipos al cargarlo, siempre bajalos de un lugar confiable y no de kazaa o emule, etc. porque puede que tengan defectos.

    Que tengan buena suerte en la tarea de revivir a nuestro querido equipo


    Finally, I open the router and reset it manual how the description indicate. But the ping to 192.168.1.1 don't response and the TFTP application inform me "Unable to get responses from the server".

    I change the configuration of my LAN in a Static ip 192.168.1.10 (I try too 192.168.1.1) and I charge in the menu Start>Execute> arp -s 192.168.1.1 and my MAC (provided in the router).

    I did the process 5 o 6 times but nothing. The router have the 4 leds light on and permanently but don't respond at pings!!!

    I need help!!!!!!!!!
     
  2. Toxic

    Toxic Administrator Staff Member

    can you connect via a wireless connection?
     
  3. avic5410

    avic5410 Network Guru Member

    Solution and firmware for V2.2 hardware version WRT54G

    Hi,

    Finally I resolve the problem. The problem was that I didn't the bridge to reset (slice 15 and 16) only a moment and it's necesary that the bridge is doing about various seconds. Thanks,

    Now I charge the firmware correctly by ftp.

    To do WDS I recommend de firmware Tarifa for hardware version V.2.2 (WRT54G) and for Client or WDS try de DD-WRT firmware.

    PD: in my V2.2 hardware don't go the Alchemy (all versions)

    C-you
     

Share This Page