1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Backup sftp server on Asus 520 gu

Discussion in 'Tomato Firmware' started by Urko, Aug 14, 2009.

  1. Urko

    Urko Network Guru Member


    May be some can help me....
    I have installed Victek USB tomato mod on my Asus 520gu roter. I think that the firmware is great work.
    I want to use router with 4GB usb key for my sftp backup. 1 partition is ext3 for optware(128MB), one for my documents
    Here is my USB configuration.
    I have installed sftp according dd-wrt wiki site http://www.dd-wrt.com/wiki/index.php/SFTP_with_DD-WRT and rsync
    on router and on my ubuntu computer.
    When i run rsync
    rsync --delete -azvv -e ssh /home/uros/Documents/ root@myip :/home/root/documents/current_doc/ 
    I get error for some of files.
    rsync: readlink_stat("/home/root/documents/current_doc/work/compy/seznam.txt") failed: Input/output error (5)
    But for some i get file is updated.
    Note that all that is on my usb drive i copied directly from my computer to usb, so partitions must be ok.

    And one more problem. When I sftp to router with Nautilus and trie to copy files to my disc i get error: There was an error copying the file into /home/uros. Unknown reason
    Is it anything wrong with sftp-server ?
    Thanks for any tip.
  2. Urko

    Urko Network Guru Member

  3. gawd0wns

    gawd0wns LI Guru Member

    My suggestions are really basic, but here goes:

    - Dropbear runs as user nobody, if I am not mistaken... Are the folders readable/writable for everyone, or just root?

    - Try another usb drive... Your drive may be on its last legs. I personally don't like USB drives. I have had bad experiences with them over the years. They are great for quick use, but I tend not to leave them plugged in for long. I once had a usb 1.1 drive which stopped responding after being plugged in for over an hour. No power saving features were enabled... I find the newer drives to be more reliable, but I still tend to avoid long term use. You might want to try a hard drive connected with a USB adaptor (like a Bytecc BT-205 -> greatest adaptor ever conceived).... These could be issues for you to consider.
  4. Urko

    Urko Network Guru Member

    First of all. Thank you for your answer.
    I check it out and dropbear runs as root.
    For the USB key. I think that there is nothing wrong with it, because when i pluged it directly to my ubuntu computer, the file copying works with out any errors.

    Any other idea?
    Did anyone tried to use sftp optware?

Share This Page