1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bad Flash when Upgrade DD-WRT to Tomato

Discussion in 'Tomato Firmware' started by addheat, Dec 26, 2011.

  1. addheat

    addheat Networkin' Nut Member

    Hello,

    I just bought Asus RT-N10, first thing i want to do is flash it into Victek's Tomato using: tomato-K26-1.28.9006MIPSR2_RAF-VPN-NOCAT.trx. But now i can't even go to web GUI.

    This is what I do:
    - Go to Recovery Mode (hold reset while plug in power)
    - I can't flash using Asus Firmware Restoration Utility (said: "No Wireless Device in Recovery Mode is Found")
    - Then I use TFTP2.exe, and it works flashing: dd-wrt.v24-16789_NEWD-2_K2.6_mini_RT-N10.trx
    - From there, I go to Firmware Upgrade from DD-WRT, and it's starting to flash with countdown until 300s.
    - When the countdown is finish, there's still Upgrading Firmware, and still no reboot.. (I wait about 5 minutes)
    - After more than 5 minutes, I try to unplug the power and plug it in again
    - But now, I don't get nothing. I can't access to web GUI, or flash it again using TFTP or Asus Utility.
    - I have try the 30/30/30 reset, but nothing changes..

    This what happened when I try to recover:
    - When I try to ping to 192.168.1.1, i got reply with TTL=100.
    - When I go to recovery mode, and try to flash with TFTP, I got "Erasing flash", but always retrying.
    - Still the same message when using Asus Utility.

    Is my router bricked? Is there anyway to bring it back to life? Please help me..

    Thanks..
     
  2. Catalin

    Catalin Addicted to LI Member

    Have you checked that the build is even compatible with N10?
     
  3. addheat

    addheat Networkin' Nut Member

    Yes, I take it from here:
    Tomato RAF 1.28.9006.. ONLY FOR 4MB Flash (MIPSR2.Kernel 2.6) No USB + Captive Portal + VPN. Updated June 25th.2011. For Asus RT-N10, RT-N12, Linksys E1000 v1, WRT160N v1 & v3, WRT310N, WRT320N.
     
  4. addheat

    addheat Networkin' Nut Member

    Update:
    Looks like the problem is on my laptop. When I try with my brother's laptop, the Asus Utility works flawlessly..
    Now I can restore to original firmware, and flash it again to DD-WRT..

    But there's another problem now. When flashing Tomato from DD-WRT (using Internet Explorer 9), before the countdown finish, the web gui is reload into blank page. When i try to ping, it said: "Destination host is unreachable".

    What's the best solution to flash RT-N10 into Tomato?

    Thanks.. :D
     
  5. Toastman

    Toastman Super Moderator Staff Member Member

    Give your router a fixed IP (192.168.1.100 etc) and set gateway to 192.168.1.1. Flash directly with the ASUS firmware restoration tool. Erase NVRAM immediately after flashing and then reconfigure.
     
  6. mvsgeek

    mvsgeek Addicted to LI Member

    Check out Lassik's instructions here. Worked for me on a RT-N16. I got the 33% hang, and ignored it as described.
     

Share This Page