Bandwidth and IP Monitoring not working with OpenVPN client enabled

Discussion in 'Tomato Firmware' started by glees5, Sep 24, 2016.

  1. glees5

    glees5 New Member Member

    I am using Tomato Shibby tomato-Netgear-3500Lv2-K26USB-1.28.RT-N5x—138-AIO for my Netgear WNR3500L v2 and Bandwidth and IP Monitoring was working perfectly before I enabled OpenVPN client. Whenever I started OpenVPN client, Bandwidth and IP Monitoring will not update anymore and it will return to normal after I stopped the VPN. I am using Cyberghost VPN. I am following the setup as suggested by Cyberghost for Tomato USB and VPN is working fine.

    Your help is most appreciated!
     
    tulear likes this.
  2. jerrm

    jerrm Network Guru Member

    Any rules allowing access to/from the VPN need to be placed after the account rules in the FORWARD chain.

    Most tutorials and even Tomato's own "automatic" rules take the dumb/easy out and just insert an ACCEPT at the top of the chain.
     
  3. glees5

    glees5 New Member Member

    Thanks for your hints! I have inserted the following rules as Cyberghost suggested to add for dd-wrt routers to the firewall script but it still behave the same.

    iptables -I FORWARD -i br0 -o tun11 -j ACCEPT
    iptables -I FORWARD -i tun11 -o br0 -j ACCEPT
    iptables -I INPUT -i tun11 -j REJECT
    iptables -t nat -A POSTROUTING -o tun11 -j MASQUERADE

    BTW, the Bandwidth & IP Monitoring is not totally frozen, Upload data continue to update and only Download data is not updated after VPN is started. VPN works fine. It is just that I can't keep track of the Internet usage anymore.
     
  4. tulear

    tulear New Member Member

    Hi Glees5, did you finally find out a solution (I'm facing the same issue) ?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice