1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Batbox on tarifa

Discussion in 'Tarifa Firmware' started by stedy6, Nov 11, 2005.

  1. stedy6

    stedy6 Network Guru Member

    i wonder if i could install a new webserver on the WRT54G when using tarifa b009.

    do any one know what im doing wrong?

    edit: 25.11.2005
    removed text.. to long for a forum post.

    for a soloution: look at the next post in this thread.
  2. jchuit

    jchuit Network Guru Member

    Telnetd and scripts

    To Stedy6

    I think you can,

    Telnetd is allready loaded, the telnet deamon can be enabled in the webpages, .

    The rest of the script can be put in the rc_startup, this you can find in the Administration-managment Wepage.

  3. stedy6

    stedy6 Network Guru Member


    I have made a description on how to enable a web server on wrt54 whit tarifa b009 and batbox.
  4. jchuit

    jchuit Network Guru Member

    Very nice!

    I compiled the full (allmost) busybox, this means that the links should allready be available.

    In Tarifa b010 (release medio december), I will make more space avialable for scripts.


    Ps: The reboot button will then be included too.
  5. bdm_module

    bdm_module Network Guru Member

    Thanks, waiting as a christmas present on your next release, the version B009 is working quit well, the reset button wil be handy, from time to time the connection is lost, 3 per week, I have put in a reboot script as you mentioned in your exellent pdf file, every 24 hours, this helps but not always, for some reason I believe the lease time (value is still zero) will trigger this event.

    Is it not possible to make the lease time forever, fixed.
  6. jchuit

    jchuit Network Guru Member

    To bdm_module

    I have some questions about your problem, maybe I can do something about it:

    Which connection is lost?
    Client to router?
    Router to internet?
    Client to Internet?
    Lan and/or Wireless?
    Is this a static dhcp client, or not?

  7. bdm_module

    bdm_module Network Guru Member

    Well the connection between the router and the modem (Internet) is sometime lost, all the adresses are there but no connection, lokal network etc is working fine.

    Two ways by releasing and refresh or by resetting the router it works again.

    So I put the restart script in and it is less but not quit gone.

    The modem is a Motorola surfboard (Cable) setup is automatic DHCP.

    So if you have an idea to fix this I'l by an happy man.
  8. jchuit

    jchuit Network Guru Member

    Is the motorola working as a bridge?

    If not, better is it to switch the motorola from Router to bridge mode, then the WRT54G will have direct acces to the internet.

  9. bdm_module

    bdm_module Network Guru Member

    It is working as a bridge.
  10. jchuit

    jchuit Network Guru Member

    This week I did some testing, but I was not able to get the same problem here.

    Maybe there is a kind of timeout issue, something like the routers asks an ip-adress and this adress is not send within a given time frame.

  11. stedy6

    stedy6 Network Guru Member

    out of ram?

    I have notice the same problem, its seams like the router run out of RAM.. I think this problem might have a connection to the incoming and outgoing log file. I don’t know for sure, but this is my hypothesis.
  12. jchuit

    jchuit Network Guru Member

    I have seen it one time now, after checking the free ram space, I saw there was allmost 2 Mbyte available.

    An other problem is that the http deamon (original linksys) has a small memory leak, each time you visit the routers internal webpages the free memory will decrease.

    Maybe the dhcp-deamon can't be restarted after a dhcp renew of the ISP, due to less memory available.

  13. bdm_module

    bdm_module Network Guru Member

    I solved the problem with the Motorola Surfboard, well it blowed itself up. There was a bad powersupply so they (provider) send me an brand new one and the problem is solved.

    Nice to now.
  14. stedy6

    stedy6 Network Guru Member


    I wonder why the WRT54G's free memory goes from over 5MB to around 2MB.. this happens on only 24 hour. and i don’t have entered the web interface once...

Share This Page