1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BEFSR41 V3 firmware

Discussion in 'Cisco/Linksys Wireless Routers' started by Pingelmonster, May 11, 2005.

  1. Hello,

    One month ago my BEFSR41 Vr with firmware 1.05.00 stopped functioning because of an failure...because of warranty I got a new one from my local computerdealer. It's a V3 again but with firmware version 0.05.03. This version looks very special...

    But it haves one problem..:
    The router loose every time his connection for 1-2 minutes and after de drop it's working properly. Sometimes the router is up for one-two days without problems but sometimes the router will drop his connection every hour!

    I thought my internetconnection was the problem (it's a 10/10Mbit fiberglassconnection) but the router's manual says it has 100Mbit support...

    Is there anyone who can help me?
    p.s. Sorry for my bad English...
  2. Sebastian_1

    Sebastian_1 Guest


    Update to the Newer Firmware 1.06.01 from this site, than the problem can be correct!!

    Test it!

    [sorry for my bad english]
  3. dbuske

    dbuske Network Guru Member

    Does it work and not toast the router
  4. cyborgen

    cyborgen Guest

    I installed the new Firmware 1.06.01 and this router is finally behaving like it should have when I bought it !!!

    No more disconnects... this piece of equip is finally decent !

    This thing should have been recalled !

Share This Page