1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Beware of the WRTP54G!!

Discussion in 'Cisco/Linksys Wireless Routers' started by CountBlah, Jun 11, 2005.

  1. CountBlah

    CountBlah Network Guru Member

    Unfortunately, I just bought this router because I wanted to start using VOIP and I needed a new wireless router:

    But the firmware is absolutely horrible! It keeps choking up with pings going into 400-500ms. To make sure it's not just my connection, I try reconnecting my old Netgear router and everything's fine again. Also, changes that you make in the router don't take effect unless you unplug it and plug it back in. And some changes don't take effect at all! (port forwarding, for example).

    When I contacted Linksys tech support, the guy just kept asking me, "Are you sure you typed in the right product number?"


    Unless anyone knows if there's an open source firmware project that fixes a lot of the problems, I'm taking this piece of junk back to BB.
  2. vanduker

    vanduker Network Guru Member

  3. RangerBob

    RangerBob Guest

    WRTP54G Firmware

    You can get the latest version of the firmware for the WRTP54G from Vonage. The original verison was 1.00.18. I had them upgrade me to 1.00.25. This version seems to cure the problem I was having with the wireless signal dropping for one second and then trying to restore.
  4. can we get as many people as possible to comment on this router/phone adapter. I really want it to be a good router. i want to replace my 2 boxes with one, and be able to take that 1 box on the road with me for work.

  5. tdube

    tdube Network Guru Member

    The router is excellent!!! I chatted with Linksys and they gave me a work around until I get the firmware from Vonage. Change your MTU 1472 if this does not solve your problem decrement by 10 each time.

    I did the default 1472 and this corrected my problems instantly.
  6. hero2zero

    hero2zero Network Guru Member

    I picked up this router (WRTP54G) at BB last week. I've had some quirky problems like serious lag or slowdown in throughput. I normally have to power down the router to get it to work again. You say that you were able to get update firmware from Vonage...did you telephone customer service for this? In other words, how to I get my hands on it?
  7. tdube

    tdube Network Guru Member

    I've not called Vonage yet. Assumed this from previous post. I'm calling them this afternoon and will let everyone know in this forum.
  8. hero2zero

    hero2zero Network Guru Member

    Called Vonage and got VERY good customer service. The rep sent me a firmware update (1.00.29). I'll gladly send the firmware and some instructions if anybody needs it. The rep said that the firmware version shipped with the WRTP54g is "very buggy". No sh....... Email me at hero2zero@gmail.com
  9. drakcap3

    drakcap3 Network Guru Member

    New vonage deal has a catch.

    This deal is not as good as it sounds. The hidden costs to keep this free router are:

    send in your old router
    pay shipping
    pay a $40 termination fee

    The disadvantage of owning this router is it is locked down by Vonage. (you can't hard reset, change the admin password - you do get a user password, though, the firmware is not user upgradable, the device will not work with any other VOIP provider)

    The fine print:

    *The Linksys WRTP54G router is free after rebates. Vonage rebates require 90 days enrollment in a Vonage service plan and return of old router. Allow 12 weeks for processing after receipt of application and 90 days enrollment. Broadband Internet connection and Credit Card required. Monthly plans from $14.99. Termination fee may apply. Satellite TV and alarm systems may require land line connection. Dialing 911 requires activation and operates differently than traditional 911. See Vonage website for details regarding 911 dialing. Other restrictions may apply. See www.vonage.com for additional details.

    Note "termination fee may apply". The $40 termination fee does not apply if you return the router after you cancel your Vonage service. (I have contacted Vonage twice via email to confirm this. I did not confirm whether or not you pay shipping when you return the new router.)

    I feel cheated.
  10. vanduker

    vanduker Network Guru Member

    Maybe I'm just easygoing but I don't know what more you guys expect.

    For 130.00 you get (at the BB B&M) this device, 80.00 worth of rebates and a 50.00 Gift Card. This makes it a wash other than the rebate hassles.

    Then if you are attached to your current wireless router, spend 10.00-20.00 for a no name WAP and shipping to send it in for 50.00 more rebate. Net another 40.00 to 50.00.

    So even if you have to buy a device to trade you still have a new device and 30.00 to 40.00 worth of store credit (after rebates and Gift Card).

    If you don't want Vonage phone service it isn't much of a deal but if you do what more do you expect them to do - give you the device, 50.00 and then let you cancel after 30 days and keep the device?
  11. danman48

    danman48 Network Guru Member

    had to return mine


    So after spending all day on the phone with vonage, they finally said return the router. I did. Plugged the new one in, and it went and got 1.00.29 (after all day of my old 1.00.18 trying to get 1.00.25), so far, everything is happy.

    My suggestion if that if your router doesn't automatically update itself within 10 minutes after provisioning it on Vonage's website to 1.00.29 take it back and get a new one. I want my day back.

  12. hero2zero

    hero2zero Network Guru Member

    So far I've sent the WRTP54G firmware upgrade to several people as requested. Could you please post your results? Mine is still humming along. Granted, it hasn't been 24 hours yet...
  13. vanduker

    vanduker Network Guru Member

    I did the upgrade according to the instructions and it went flawlessly. Seems to have fixed the flaky/long ping times.

    Thanks much for the hookup.
  14. danman48

    danman48 Network Guru Member

    It's been 18 hours so far with no problems. Usually I'd have to unplug in the morning. My Wireless is worse though in this firmware build. I was getting 32Mbits at a location and now i'm down to 5.5Mbps. Any suggestions?

  15. tdube

    tdube Network Guru Member

    I got 1.0.20 from vonage last night. Router has behaved better, but still had an issue this AM. I've emailed our friend @ hero2zero@gmail.com to get the latest and try it out.

    I'm also going to get back on the phone tonight with Vonage and get 1.0.2x or whatever is the latest.
  16. tdube

    tdube Network Guru Member

    hey - danman48
    how did you get them to provision off the site once you've already provisioned?
  17. blakeypoo

    blakeypoo Guest

    I gave up on my WRTP54G...3 hours over 2 days with Vonage tech support was enough, and no results. Among my problems:

    * no dial tone for 5-10 seconds after picking up the phone
    * people I called reported a distracting "rushing air" noise while they talked up until about 1/2 second after they stopped talking
    * after 24 hours or so, router started telling clients that it was the DNS server instead of the ISP
    * web configuration page usually took <u>forever</u> (5-10 minutes!) to load...even though internet traffic was working fine.
    * long latency about 1 day afterwords, an extra second or two bring up webpages.
    * unable to upgrade the firmware even after 3 hours on the phone w/ vonage. I was making calls and surfing the web, but the tier 2 guy insisted RF interference over the wireless was preventing the firmware upgrade?!

    I went back to Best Buy, picked up a WRT54G and PAP2 instead, it provisioned immediately and flawlessly, and it's working great w/ Comcast. Unless you want to volunteer on the Vonage test team, I'd wait a few months on the WRTP54G until it stabilizes.
  18. hero2zero

    hero2zero Network Guru Member

  19. jamima69

    jamima69 Network Guru Member

    yep,sure sounds like you guys are doing free testing for linksys on this one.....i could never figure out why anyone would want to buy ver 1.0 of anything having to do with hardware or software-ya get screwed most every time.
  20. jatfill

    jatfill Guest

    I just updated the firmware on my router using the instructions above. Everything on my router (internet, wireless) has been working fine, the phone would stop working after about 1 or 2 calls... lag in dial tone, etc with the 1.00.18 firmware.

    A word of caution: I did not get to 75% progress as the instructions described. I got to 45-50% of the upgrade process when the "page cannot be displayed" came up on my browser. On my third upgrade attempt, I noticed that the router lights were still "busy," so I left the page open. Sure enough, eventually the router lights went steady again and I logged back in to see 1.00.29.

    The phone has worked great for about 5 calls now... I will update if anything stops working or changes. Thanks to h2z and Toxic, I might be able to keep this router after all. :)

    No thanks to Vonage... only 2/5 reps I talked to even acknowledged that they are having problems with this router... the second one said "give us a couple of weeks" lol.. we're paying them to test their hardware for sure!
  21. hero2zero

    hero2zero Network Guru Member

    jatfill, what happened to you during your upgrade happened to me as well. It took several attempts before I was successful. The tech later advised me that I could disconnect internet cable from the router and then do the upgrade. This way, no soft/hardware is trying connect to it via inbound/outbound traffic. Either way, the upgrade went *ahem* "smoothly" and my connection was restored. But, for fun and giggles, I tried it again the next day just to see of the tech was right and, yup, I got a successful upgrade with the correct screens loading and everything. Funny, aye? Maybe not...
  22. copritch

    copritch Guest

    I have installed the 1.00.29 firmware and everything seems to be working GREAT. But one thing that I have nothiced is on the Voice Info Page. It says "Provisioning Status: Provisioning failed". I didn't notice what it said before. But is this correct or is something not working correctly. Thanks for the new firmware.
  23. hero2zero

    hero2zero Network Guru Member

    Yeah, I posted this question on the Vonage forums AND I sent an email to the Vonage customer service rep that sent me the firmware. I've gotten responses from other users that also say their routers show "Provisioning failed", but have not yet heard from Vonage. I won't hold my breath...
  24. tdube

    tdube Network Guru Member

    Upgraded 1 1.0.29 - been running over 30 hours with out issues... THANKS everyone!!!

  25. zenfar

    zenfar Network Guru Member

    I got one

    Well I got one of these thinking it would solve my vonage problems. I have the latest firmware 1.00.29 and it works except I keep getting internet and voice packet loss or loss of connection.

    Are there any QoS settings that have been tried or other settings that help with this router?


    BTW this site rocks.
  26. linksystodd

    linksystodd Network Guru Member

    A brand new problem with WRTP54G!!!

    Ok, here's one I haven't seen posted. I spent several hours on the phone yesterday with Vonage service both from India and here in the States. Both were courteous and helpful, but couldn't resolve the problem:

    For some reason, the WRTP54G could not download the latest firmware from the Vonage site. The tech on the phone tried time and again to force it, but it would always time out. Not sure why, because I have very reliable cable modem service with good download and upload speeds. I know, I've tested them numerous times.

    So we decided to upgrade the firmware directly. He emailed me the firmware file (v1.00.29). I logged into the WRTP54G via admin / admin and then went to the update.html page as directed. There he had me enter user / 7756112, which failed. Then he had me entered user / tivonpw and it succeeded. I browsed to the firmware file on my C: drive and hit upgrade. As many on this forum have stated, it went to 75% and gave me the error "Upgrade are failed". I assumed it was no problem, as it hasn't been for others. But it would automatically refresh the page, it just stayed at 75%. So after several minutes, I went back to the admin page ( and logged in (admin / admin). It was reacting VERY VERY slowly at this point. The tech told me to reboot and I did. I was able to login again and to my surprise it reported v1.00.20 still. Arghhh!

    So we tried again, with no success. Afterward, the tech had me restore it to defaults via the administration page.

    Here's where the real fun began. After doing so, I was able to login as admin / admin again. I went to the update.html page and tried logging in with user / 7756112 and user / tivonpw and about 50 other combinations (admin / admin, Admin / admin, Admin / Admin, etc., etc., etc.). None were accepted. So we decided my WRTP54G was fried and I should get a replacement.

    So that's what I did. I went and bought a brand new, shrink wrapped WRTP54G from Office Depot. I plugged it into the AC and my computer directly, with NO internet connection. I logged in as admin / admin and, as expected, saw a firmware version of 1.00.20.

    I then went to the update.html page and tried to login as user / tivonpw. It gave me an error of "User not enabled to login into the system", same as with the other WRTP54G. So I began to think it was my PC! Maybe I had a cookie or something cached that was causing the problem.

    So I then plugged in a second computer, my laptop, and repeated the login steps. Same error.

    So at this point I've "tested" 2 WRTP54G routers for Linksys and Vonage. I can only GUESS how many people have had similar problems, given I had these problems with BOTH WRTP54Gs I purchased. This indicates it is a very prevalent problem.

    I suspect Linksys knows how to fix this in the field via a workaround. Maybe a tftp put to the router or something. But they haven't communicated this to Vonage. This is sad, because I am now reconsidering the whole Vonage experience altogether (after almost a year of using it). It would be a shame for Vonage to lose customers due to poor Linksys routers.
  27. Bargain_Bob

    Bargain_Bob Network Guru Member

    Re: A brand new problem with WRTP54G!!!

    I also got this message. If you first login as admin/admin, and then go to the update.html page, you should be able to login as user/tivonpw. Worked for me anyway.
  28. linksystodd

    linksystodd Network Guru Member

    I've got the problem fixed...

    Unfortunately, Bargain_Bob, I had done that. Oh, do I wish it were that simple!! :)

    So I figured it out: you have to allow the device to attempt to provision itself after any hard reset before you can login with user / tivonpw or user / 7756112 at the update.html page. It appears those accounts are setup or enabled during the provisioning process. So many WRTP54Gs out of the box will not have those accounts enabled. Don't even try to upgrade until you've had it go through the process of initial provisioning, even though it will most likely fail! (It seems it doesn't ENTIRELY fail, only MOSTLY fails.)

    So after allowing it to attempt to provision, I still noted the upgrade of firmware had failed. Still 1.00.20, not .29. But, this time I was able to login as user / tivonpw at the update.html page. AND I was able to successfully upgrade the firmware to .29. Wooohoooo! I'm done!

    Well, not so fast. :-( It still couldn't provision, and I couldn't dial out or receive calls. I would get a dial tone, but that was it.

    So I spent another 2 hours on the phone with Vonage tech support in India, and was teetering on the verge of a homicidal episode. Then my tech transferred me to "Rebecca", still in the India support center. However, she was a much bigger help. She enabled my Phone 2 line, and it worked. Then, for some reason, she set me back to Phone 1, and IT WORKED! What the !@#$? Sometimes, technology really does defy logic.

    So I'm back with both phone and internet service, plus wireless, all through my single Linksys box. And I didn't kill anyone. A good day for all.

    The end.
  29. hero2zero

    hero2zero Network Guru Member

    Well, I finally gave up on this router. I tried to hold out and long as I could, but just couldn't take it any longer. I started to have the same problems as before (with the original firmware 1.00.20). I ended up getting a WRT54G with a PAP2 and have no problems. With the WRTP54G, I thought my problems were solved with the upgrade; however, I quickly learned that I was mistaken. I again started experiencing slow downloads, one-way phone calls, "provisioning failed" messages, etc.--and no solutions from Vonage. To somebody else's credit who started this forum, he warned me (i.e. the topic of this thread "BEWARE"). I can't say you didn't tell me so... :cry: Return this piece of garbage...NOW!!!
  30. dwright530

    dwright530 Network Guru Member

    I think the lag problem (network lag, dial tone lag) may be related to the wireless functionality with the router. Everything seemed to work fine for me with the default firmware (1.00.18) until I accessed the network with my laptop (wirelessly) for some time (over an hour). Typically by the next morning, the dial tone will lag and the router will no longer be connected (thus requiring a re-boot). I just recently applied the latest/greatest firmware patch (1.00.29), but have not tested it out yet.

    This may be an option (disable wireless) until the issue is addressed with a proper firmware update from Vonage...

    Anyone else experience this???
  31. FocusSVT

    FocusSVT Guest

    My observations getting to 1.00.29

    After experiencing almost all of the bad things descibed by others I was able to install 1.00.29. However before the upgrade a work around for the slow dial tone and other issues appears to be a change to the MTU setting mentioned in another forum thread. I configured a maual setting of 1440 bytes (happens to be what you would use to allow room for an IPsec tunnel) and dial tone, slow perfromance and other maldays seemed to be gone.

    As for the upgrade:
    - with wireless enabled upgrade failed error message was "unsupported request method"
    - disable wireless and upgrade failed based on file CRC error
    - used file from this site rather then the one from Vonage and upgrade worked

    As for the support
    - 3 phone calls with no recognition of the real problem
    - found Vonage forum thread refering to this site to get the firmware
    - 3 emails referencing the vonage forum thread and I was sent the firmware from Vonage, but the file had a bad checksum

    With the rebate of $100 + $20 (I turned in an old wireless router) making my net cost $10 + tax I can live with what happened.

    I intend to let Linksys and Vonage management know this was not an acceptable product introduction.
  32. dwright530

    dwright530 Network Guru Member

    Firmware upgrade steps...

    BTW... here is how I got the downloaded firmware to install properly. I added my notes in bold....

    1. Download the appropriate firmware update file (*.img) and save it to a memorable location.
    2. Reset router by pressing the reset button on the back of the router for at least 30 secs. 3. Login to router - username: admin password: admin
    4. Go to url: ( is the default ip address after a hard reset)
    5. Login as - username: user password: tivonpw

    6.5 At this point make sure the router is disconnected from the internet (pull the ethernet cable out).
    6. Browse to the location of the firmware file (*.img) you downloaded.
    7. Click upgrade.
    8. The progress bar will get to about 75% completed then return to 0%. It will then get to 75% again and likely give you an error message in poor English (i.e. "Upgrade are not completed"...or something like that)

    8.5 With the cable plugged out you will not see the progress go to 75% and back up again as above. You will see it progress, then the browser will go blank. Notice that the light on your router will still be blinking as it is still upgrading the firmware. Give the router a good 10 minutes and do not close the blank browser. The router will light will stop blinking, and your upgrade will have been completed at this point. Reboot (power down) the router at this point.
    9. According to the rep, this was okay because everything worked. The new version of the firmware was displayed in the upper right-hand corner of the Setup screen.
    10. Then, for good measure, the rep had me power down the router for about 20 secs (during which I ensured that everything was connected properly).
    11. Now, login again and customize accordingly (i.e. change username, password, enable wireless encryption).
  33. Randy

    Randy Network Guru Member

    I was looking to purchase one of these over the weekend and decided to stop in and see if any of you had looked at this deal. After this thread (Thanks for all the posts) I think I'll wait a few months.
  34. chaco

    chaco Guest

    Upgraded firmware and bought a fan

    I am no longer having any problems. Upgraded the firmware to .29 and bought a fan at radio shack to cool the router off.

    Seems to have helped
  35. Bargain_Bob

    Bargain_Bob Network Guru Member

    Re: Upgraded firmware and bought a fan

    You could fry an egg on mine.

    I have had only one problem so far - an intermediate slowness issue which goes away when "filter proxy" is turned off. This defaults to off, but I turned it on because my old BEFSX41 had it turned on.

    My Voice Info screen also shows "Provisioning Status: Provisioning failed" but this has not caused me any trouble, and I was able to ugrade to 1.00.29 with it this way.

    Any other problems I thought I had turned out to be unrelated to the WRTP54G.
  36. ziddey

    ziddey Network Guru Member

    Could someone shed some more light on the setting the MTU to 1440? I'm running a pptp vpn server behind this wrtp54g on the dmz. I can't seem to connect very well to it from the outside world. It seems that I have to try about 15 times to finally be able to get in. When I had the server in front of everything, it all worked just fine.
  37. hox-ii

    hox-ii Network Guru Member

    Ah, this router just seems to be having more and more problems...

    As CountBlah and I have stated in a different thread, this router isn't even starting up for us anymore. I personally only had the thing for 4 days, and have absolutely no idea what happened - just one day, the router just will not stay booted. After 4-5 seconds from the final boot stage, the router just resets. Over and over and over and over again.

    I don't know if Vonage tried upgrading my firmware for me, or what, but this router seems to be a worthless energy burner at the moment.
  38. dwright530

    dwright530 Network Guru Member

    Same thing happened to me.... I had successfully upgraded to 1.00.29 firmaware. Last weekend, I came home to no dial tone, re-booted the router and it continued to re-boot continuously....

    I was able to (barely) get into the Linksys admin web site and discovered that Vonage had pushed down a firmware upgrade to 1.0.37. After talking to India for a good hour, manually resetting the modem several times, it never stopped re-booting and I had to return the unit for a full refund to Best Buy. Unfortunately, I had already sent in my 'good' router for the wireless 'g' for free rebate.... but am now semi-screwed...

    At this point I had a few options:
    1. drop vonage
    2. get another wrtp4g router
    3. get a PAP2 and a seperate wireless router (WRT54G).

    I went for option 3 as my phone number has already been transfered to Vonage, yet I don't trust the wrtp54g combo router after dealing with it the last few weeks...

    My 2 cents..............
  39. hox-ii

    hox-ii Network Guru Member

    There has to be a way for you to get that old router back. Basically, they provided you with a piece of hardware that slightly worked, and after you sent in your "old" router, Vonage forced an update on you that caused your hardware to not work at all. It is Vonage's fault, and they should be the ones to deal with it.

    My router now will not ever work. It is impossible to get a firmware downgrade on it or to do anything with it. I know that I can just return it and all will be well, but this is the type of thing that is affecting MANY people. It's the type of thing that turns into class-action lawsuits in extreme cases.

Share This Page