1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Brand new 54gl fails to upgrade to tomato!

Discussion in 'Tomato Firmware' started by D2149, Mar 4, 2010.

  1. D2149

    D2149 Addicted to LI Member

    This is a first for me...

    I just received this new 54GL to replace one of three other 54GLs that has gone defective.

    Much to my surprise, I CAN NOT Flash Tomato onto it! The upgrade fails every time. I have tried flashing DD-WRT and even tried to upgrade using the identical Linksys firmware file the unit already has on it, but they all fail.

    Tried using multiple computers just in case it was something with my MacBook Pro, but even the Mac Mini that I used to flash Tomato onto the our second and third 54GL also fails. I am going to have to assume that this is a defective unit and have requested an exchange from Amazon.

    Never had a problem like this before. All three of our 54GLs we bought previously upgraded perfectly on the first attempt. The last unit was purchased about 3 months ago. Has there been some kind of recent change to the 54GL that may be causing this firmware upgrade problem? Compared the version numbers on all of our units here and this new one is identical to the others that flashed just fine.

    Is there something I am missing here? Has something changed in the 54GL hardware in the last few months?

    Strange. :(

    Hope the replacement works when it gets here!
  2. ringer004

    ringer004 LI Guru Member

    Tomato image too big?

    The only time I ever had an issue was when the image I wanted to upload was >3M (when starting from the base Linksys firmware).

    There used to be (not sure if the GL still has this) a limit of a 3M .bin file that was uploaded. I had to load a smaller version of Tomato (like non-ND which was about 2.8M) first, then I could upload the full version I wanted.

    Just an idea...
  3. Toastman

    Toastman Super Moderator Staff Member Member

    I have bought many WRT54GL's recently and no problems with them, I don't think there has been any change.
  4. Trunkz

    Trunkz LI Guru Member

    Install the micro version of dd-wrt first, then flash tomato afterwards. Should work a treat :) Make sure you do a factory reset after flashing tomato obviously.
  5. D2149

    D2149 Addicted to LI Member

    Thanks for all the tips...

    I figured out what was going on.

    The problem with flashing Tomato onto the new GL was the fault of the OSX version of Safari and not the hardware! This replacement unit that arrived today had the same problem with the upgrade failing, even with a new version of the Linksys firmware, so I called Linksys and they informed me that the latest version of Safari is not playing nice with their routers for some reason.

    I had not heard about this anywhere on the web, so it was all news to me and something I didn't consider since I had flashed all of my previous 54GLs with Safari and never had a problem.

    This explains why I had no problem 3 months ago when I upgraded the last 54GL. That version of Safari obviously didn't have this problem that must have been introduced in the most recent update of the browser.

    Found similar issues when trying to change some settings on my recently flashed 54G v8 that I just installed DD-WRT v24 micro on. Saving settings doesn't always work with Safari, and now I know that Firefox is the browser to use to do that with or to upgrade firmware on either a Tomato or a DD-WRT 54G.

    Once Tomato is installed, Safari works fine for making changes, but DD-WRT still has problems with saving any changes if Safari is used.

    So... Mystery solved. Hopefully, my story about this little episode will save someone else from wasting all the time on this that I have the last couple of days.
  6. pfoomer

    pfoomer LI Guru Member

    Safari problem


    Please can you post the version of safari and osx that you are using?


  7. D2149

    D2149 Addicted to LI Member


    Safari: Version 4.0.4 (6531.21.10)

    OSX Snow Leopard 10.6.2

    I used Firefox 3.5 to run the upgrade and it worked like a charm.


    Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
  8. pfoomer

    pfoomer LI Guru Member


    Thanks, I am on the same as you, the latest safari version as far as I know.

    I am also still on tomato 1.25, but I do remember a couple of occasions where saving settings seemed not to work.

  9. D2149

    D2149 Addicted to LI Member

    I would guess that if anyone attempts to flash a Linksys router with Tomato or ANY firmware update using the current version of Safari, the update will fail every time.

    Not sure what version of Safari broke this ability, but it happened since the last time I successfully flashed a 54GL with that browser last year. Thank god we have Firefox to use instead, otherwise this would have been a HUGE problem!
  10. pfoomer

    pfoomer LI Guru Member


    looks like someone took this problem seriously!!

    (though this info I cannot find on Apples site, broken link to support page, got this from macupdate)

    Performance improvements for Top Sites
    Stability improvements for 3rd-party plug-ins
    Stability improvements for websites with online forms and Scalable Vector Graphics
    Fixes an issue that prevented Safari from changing settings on some Linksys routers

Share This Page