1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bridging two WRT54G Routers

Discussion in 'Cisco/Linksys Wireless Routers' started by TheLastUnicorn, May 20, 2005.

  1. TheLastUnicorn

    TheLastUnicorn Network Guru Member

    Hello all,

    is it possible to establish a wireless bridge between two WRT54G Routers which uses WPA-TKIP encyyption? I am intensively searching for an adequate hardware replacement that is capable to manage the following situation:

    Internet -- DSL Modem -- WLAN Router <> WLAN Router -- Switch -- PC

    -- wired
    <> wireless

    I would like to use two WRT54GS Routers, but I am not sure if they support bridging functionality with WPA encryption. Another unanswered question: Can I connect wirless to the WLAN Router when operating this way? Or should I better use two WRT54C Routers or a combination of WAG54G and WRT54G instead?

    Any help appreciated!!!

    With very best regards,

  2. DevilStick

    DevilStick Network Guru Member

    Bridging two WRT54GS


    Seems that you have the same problem like me. First I wanted to bridge a WRT54GS and a WAP54G, but the official WRT54GS firmware does not support any other mode than AP mode.

    Then I found this page with its lots of firmware modifications and so it should be not problem to build a wlan bridge.

    But for any reason everybody seems to prefer connecting two WRT54G/GS instead of using a WAP54G (Maybe anybody reading these lines may explain me the advantages of using 2 WRT54G/GS).

    Maybe this link will help you:

    Linksys WRT54G/GS WDS

    Why do you need a switch behind your 2nd router? Do you need more than 4 ports inside? This built-in switch would be at the moment the only argument in using two router, instead of an access point.

  3. JohnWayne

    JohnWayne Network Guru Member

    I'm in the same situation, I have two small networks on oppisite ends of the house, after some research, I went with two WRT54GS's and installed the talisman firmware on one of them, but now have a problem.

    Rather than retype, I'll describe my problem here.
    Thanks, and here's hoping that my problem isn't a show-stopper for the both of us

Share This Page