1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Broadcom 802.11a/b/g WLAN Driver updated to v4.10.40.0...

Discussion in 'Other Linksys Equipment' started by somms, Nov 30, 2005.

  1. somms

    somms Network Guru Member

  2. matthiaz

    matthiaz Network Guru Member

    Nice! Thx for sharing! :cheering:
     
  3. SteelersFANinMA

    SteelersFANinMA Network Guru Member

    I'm not sure what the problem is, but this version doesn't want to work on my Linksys WPC54G v1.2. I've had great success with all previous drivers from Linksys, Dell and Broadcom. I have a WRT54G v2 router running tofu10 Hyperwrt and an XP Home SP2 laptop.

    When I install the driver after a hard reset of the router, the driver works fine. It still works after applying a static IP and cloning the MAC Address, but once I make changes in Wireless_Basic.asp, which includes changes to: G-Only mode, SSID, channel 3 and disabling SSID Broadcast, I lose wireless connection to the router. I tried it a few times and each time at the same point I lose connection.

    For now I'm sticking with Broadcom 3.140.16.0. I'll assume that the new driver is too advanced for my WPC54G v1.2. However, if anyone has any ideas as to why this driver isn't working for me I would greatly appreciate them. Thank You. :)
     
  4. somms

    somms Network Guru Member

    Could be...although this latest driver is compatible with the Dell TruMobile 1370 & 1470 Mini-PCI's found in the couple of notebooks I own.

    [​IMG][​IMG]

    Advanced properties now listed for the TrueMobile 1470 w/this driver...
     
  5. Klaus_1250

    Klaus_1250 Network Guru Member

    Does anyone have an alternate location do download these drivers from? I cannot access Windows Update v4, only v6, and I cannot find the drivers there (it shown an ancient version of LinkSys drivers)
     
  6. onesolo

    onesolo Network Guru Member

    Hello,

    Can anyone post here that driver? cause I have WMP54G installed on a win2k machine with the Broadcom 3.140.16.0 installed and windows update doesn't give me that new driver...
     
  7. somms

    somms Network Guru Member

    http://go.microsoft.com/fwlink/?LinkId=8973

    Use the above link and look under hardware drivers updates, Networking then select Broadcom and XP....
     
  8. HiSpeed

    HiSpeed Network Guru Member

    Sorry, I don't understand why to replace the Broadcom 3.140.16 by the MS 4.10.40 !?
     
  9. somms

    somms Network Guru Member

    Its a newer version w/bugfixes and enhancements for the latest Broadcom WLAN chipsets... :thumb:
     
  10. HiSpeed

    HiSpeed Network Guru Member

    OK, but I don't understand why this driver comes from MS and not from Broadcom with the Broadcom monitor !?
     
  11. onesolo

    onesolo Network Guru Member

    Because sometimes hardware companys send their drivers to M$, then M$ test them and if they are aproved they go into win update. I have on my acer, a Inprocom chipset for the wifi and only winupdate has a good and updated driver that supports wpa2.

    By the way, thkx somms for the driver. :thumb:
     
  12. Klaus_1250

    Klaus_1250 Network Guru Member

    Tried it on my LinkSys WMP54G v2, but not much of a success. For some bizarre reason, DHCP, DNS and most other services stopped working. I was able to receive incoming packets, but it seems outgoing packets were lost somewhere.

    A rollback of the driver fixed the issue.

    I'm not sure what to make of it though. Radio-connection was fine, I received incoming packets (checked with Ethereal), but that was about it?
     
  13. HiSpeed

    HiSpeed Network Guru Member

    Thanks Klaus, you give me a good reason to don't change my 3.140.16 working very well... :thumb:
     
  14. darthmalak

    darthmalak Network Guru Member

    Will these drivers work for the WUSB54G adapter also?
     
  15. SteelersFANinMA

    SteelersFANinMA Network Guru Member

    I'm not sure, but I can tell you that the name of the driver file mentioned here is, bcmwl5.sys located at C:\WINDOWS\system32\drivers. If the driver for the WUSB54G has the same name, you could try to manually add the driver to the correct folder and see if it works. If it doesn't, revert back to your current driver.
     
  16. darthmalak

    darthmalak Network Guru Member

    Thanks... Not sure what chipset the WUSB54G uses.. I have a hard time getting a connecting on bootup though. Every time I boot I have no connection. I have to unplug and plug the adapter. Once I have a connection it is rock solid and "excellent"...

    I'll figure it out! :)
     
  17. ronco

    ronco Network Guru Member

    WUSB54G issue

    I had exactly the same issue with my WUSB54G v4. I found that I had to set the Linksys service to start manually, then call it from the Startup folder with Invokesvc2.exe. I've now switched to Windows Zero Config, hoping that works better.
     
  18. darthmalak

    darthmalak Network Guru Member

    But it seems the WUSB54G isn't detected on boot up so I am not sure how invokesvc2 would help there. This is really weird. Also absolutely no reference on linksys' site.
     
  19. somms

    somms Network Guru Member

  20. SteelersFANinMA

    SteelersFANinMA Network Guru Member

    The original version you posted didn't work with my WPC54G v1.2 as I mentioned in a previous post. I now have a WPC54GS v2 that it also doesn't work with. Both cards have Broadcom chips. Maybe this new .EXE will work?
     
  21. SteelersFANinMA

    SteelersFANinMA Network Guru Member

    I ran the EXE for the driver and got a message during the install saying that no compatible hardware was found. So, I guess this one won't work for me.
     
  22. itsmeohmy

    itsmeohmy Network Guru Member

  23. somms

    somms Network Guru Member

  24. SteelersFANinMA

    SteelersFANinMA Network Guru Member

    Awesome somms! This one is working with my WPC54GS v2. Thank you! :rockon:
     
  25. somms

    somms Network Guru Member

  26. SteelersFANinMA

    SteelersFANinMA Network Guru Member

    Sorry guys, false alarm. :( At first I manually dropped the bcmwl5.sys into the drivers folder and it was working. Then I decided to do the actual install. After installing and setting up the advanced options, it connected to the router, but I couldn't access the internet. I tried a couple of times, but with the same results. So again, back to 3.140.16.0. Maybe oneday Linksys will update their old drivers for their latest WPC54GS adapter. Anyway, thanks to somms for his updates! :thumb:
     
  27. HiSpeed

    HiSpeed Network Guru Member

    Hi Guys,

    4.10.40.1 ( from here ) works fine on my WMP54G 2.0, except one thing : the channels 12 and 13 are no more available (US channels) ! :sadbye:
     
  28. Saber

    Saber Network Guru Member

    I downloaded the drivers and they work great on my WPC54GS v1 and v2 cards. These new drivers fixed the problem I was having with both cards constantly slowing the connection to a crawl when transferring data over my network.

    Thanks for the updates!!!
     
  29. qBot

    qBot Network Guru Member


    Sorry for bumping up this thread. I have the 4.10.40.0 driver installed and I can't get channels 12 and 13 working either . In advanced driver properties I can't change location to anything bar "United States" I'm Europe so this is a bit of an issue. Anyone have success with this? Could it be that the latest 4.10.74.0 has this ability. If so could anyone wrap up the three important files in a zip and give it to me.
     
  30. HiSpeed

    HiSpeed Network Guru Member

    I didn't see any difference in installing 4.10.47.0 and when I saw the files dates older, I prefered roll back to 4.10.40.1...

    Nevertheless, even without channel 11 and 12, this monitor/driver is the best I've ever seen...
     
  31. qBot

    qBot Network Guru Member

    Thanks for the reply. Was just thinking after though... I downloaded the big file then deleted everything bar the three files that make up the driver. Is there a utility bundled with the big package that could change the country region for me?
     
  32. Toxic

    Toxic Administrator Staff Member

    i doubt it the information should be be in the *inf file. and some allow selection of country in the dsettings of the driver in device manager.

    what country were you wanting it to be changed too? there is no real benefit and deferences is minor...most have 1-11 or 1-13 channels available for selection except for japan.
     
  33. qBot

    qBot Network Guru Member

    I don't really care what country I set it to. It's just that I want channels 12 & 13 included and possibly even 14 :D I was looking through the .ini earler and it does make reference to different countries. Unfortunately the .ini is so long and I don't have much knowledge of em that i couldn't figure it out.
     
  34. qBot

    qBot Network Guru Member

    Ok, not an issue anymore. I downloaded the version 40.1 off the microsoft site and now my driver install with the correnct country location. would mind the 47.0 version though. But you say there isn't much of a difference HiSpeed?
     
  35. HiSpeed

    HiSpeed Network Guru Member

    Take care, I was just comparing the 2 full packs of my french link !

    Into these 2 packs, 4.10.47.0 is the version of monitor which is very userfriendly compared to the Windows tool, and 4.10.40.1 is the driver version (bcmwl5.sys dated december 17th, 2005)...
     
  36. qBot

    qBot Network Guru Member

    Fair enough. I have the latest driver so. I'm not a big fan of 3rd party tools for wifi. I like to run my system as minimal as possible. Thanks for your help.
     

Share This Page