1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Buglist: Tomato 0.03

Discussion in 'Tomato Firmware' started by Disman_ca, Sep 7, 2006.

  1. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    WRT54GS v1.1

    I attempted an upgrade from Tomato 0.02 and got "Error erasing MTD block Please wait while the router reboots..." The router appeared to be okay and returned me to the main status page but the flash wasn't succesful. I had a quick look around and everything seemed to be running okay. I then clicked reboot and waited until I could click continue then nothing (flashing power LED). A power recycle cleared the problem and it returned to normal.

    Second attempt "Image successfully flashed" no issues.

    Note: This is a buglist only. Off topic posts will be forked from this thread.
  2. RTSAnime

    RTSAnime Network Guru Member

    54g V3
    Error Connection reset by server when using Firefox on Win XP Pro SP2

    Access through IE works fine
  3. tofu

    tofu Network Guru Member

    Actually, if you find a bug, please email me (see Tomato's homepage) since it's a little more convenient that way. :)

    disman_ca: Were you using JFFS2? It may not have unloaded properly. I should probably put some additional checks...

    RTSAnime: When you get that, close the browser completely and open it again. There are times when a browser will (I think) repeatedly retry a dead connection for some reason. If closing doesn't work or if you get this frequently, then it's something else more serious.
  4. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Yep, using JFFS2 was enabled at the time of flash.
  5. Reiper

    Reiper LI Guru Member

    Logout Button doesn't seem to work??? Asks for a user name a password which apparently is not the same as the login ones.

    (Already e-mailed to Mr. Tofu!)
    Response from Tofu...

    It's a little weird, but that's actually how it's supposed to work. The only way to force a browser to forget what was entered is to tell it that the username/password is wrong. I'll try a few things and see if I can make it a little better... But just hit cancel and the browser should forget its cached information.

    Firmware Rocks!
  6. RTSAnime

    RTSAnime Network Guru Member

    Yep it appears to be working now. Not sure why it happened in the begining but now everything works.
  7. myersw

    myersw Network Guru Member

    See my posts in Tomato Firmware. Looks like there may be a problem with WRT54G v1.1 routers. I cannot get the Tomato firmware to run. Upgrades without error. My posts in Tomato Firmware gives more. Also have given info to Tofu via email.
  8. Reiper

    Reiper LI Guru Member

    Now on the official Tomato website...

    Requires: WRT54G v2-v4, WRT54GS v1-v4, WRT54GL v1. This is not for v5 or newer G/GS routers. Warning: There seems to be a problem with WRT54G v1 routers - do not use with a v1.
  9. ka9yhd

    ka9yhd LI Guru Member

    What about the WRT54GL v 1.1 ?
  10. Reiper

    Reiper LI Guru Member

    Actually the Tomato firmware is based on the WRT54GL code so you should be fine with the WRT54GL v1.1 (really no difference between the 1.0 and 1.1 that I'm aware of). That is what I'm running it on and it works great!
  11. skoub

    skoub LI Guru Member

    i also have the WRT54GL v1.1 and everything works correctly.
  12. LAGMonkey

    LAGMonkey Network Guru Member

    WRT54G v2.2, so far so good. no problems rendering pages with FF on my laptop (XP SP2)

    DNSMasq works, QoS is doing its magic (this will be tested further) uPnP works.
  13. redcow

    redcow LI Guru Member

    the mtd-unlock/erase... package shipped with tomato doesn't work for me, gives always errors like Error unlocking MTD and so on, but the openwrt mtd package works and is able to erase/unlock .. affects also tomato v.04
  14. redcow

    redcow LI Guru Member

    another probably bug report, regarding QoS settings or maybe a mistake on my site dunno, but i set a rule for, dst ip any port , class hightes, tcp/ip, ipp2p and layer7 disabled and set it on the top of the rules but its always shown as Unclassified traffic = client ip/ethernet = WRT54GL/tomato router

    My idea was to get the Unclassified log entries away.
  15. GoldServe

    GoldServe Network Guru Member

    I noticed this when the traffic was going to the local router or subnet and not going out to the internet. All other traffic seems to be classified correctly. Cheers!
  16. NateHoy

    NateHoy Network Guru Member

    I don't think QoS works in the local subnet. In fact, I'm almost certain it would not.

    The WRT54G has a processor that could not POSSIBLY attach QoS priorities to 10/100 mbit connections. Even the simplest QoS filter would rapidly overwhelm a 200 Mhz processor when running a 4-port-plus-wireless 100 mbit switch and trying to prioritize all that traffic. You might get 16 mbit or so of throughput on a good day, shared among all of your connections. People would be turning QoS off left and right. ;)

    QoS, as far as I know, works on outbound packets only when they are sent to your modem. Inbound QoS, if implemented, is of very limited value. LOCAL QoS would cause far more problems than it could solve. Tofu's a clever dude, but he can't make a 200 Mhz processor do THAT sort of work...
  17. mescator

    mescator LI Guru Member

    some notes on GUI and functions

    1) The WOL
    a) WOL GUI does not work. Clicking the row with device entry does not cause WOL packet to be sent.
    b) When some MAC is put into the manual entry, pressing both a row or WakeUP button cause sending the same packet
    2) Port forward triggering. This is what I am not sure, but in original linksys the entries were IP independent while tomato require entering IP besides triggered and forwarded range. Is a purpose for that? Can I put ANY ( there?
    3) I worry a little about memory consumption. With 1 emule running with ~300 connections and two more machines using ~100 more connections, the remaining memory on 0.3 was only 10%. Will it (the router) survive more load?

    The other things about tomato seen to be great, specially the QoS!
    - wrt54g3.1/tomato 0.4

Share This Page