1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot connect to transmission web gui

Discussion in 'Tomato Firmware' started by alazyworkaholic, May 6, 2013.

  1. alazyworkaholic

    alazyworkaholic Serious Server Member

    Transmission running on my Linksys E3000 router with Shibby's Tomato Firmware 1.28.0000 MIPSR2-108 K26 USB Big-VPN has quit working - mostly.
    I was running an older release (104, I think) with no problems at all. Then I needed to temporarily repurpose the USB flash drive. I tried to clone the drive using dd, then clone back. Everything seemed to work again (samba, files were there, etc.) except transmission.
    Giving up, I upgraded to Shibby's 108 Big-VPN release. I reformatted the usb drive with OPTWARE, swap & STORAGE partitions, then started over. I mostly followed these instructions:
    http://uk.nyclee.net/2012/04/28/installing-optware-in-tomato-usb-shibby/
    I added this to Administration -> Scripts -> Init Tab

    echo "#device Mountpoint FStype Options Dump Pass#" >> /etc/fstab
    echo "LABEL=SWAP none swap sw 0 0" >> /etc/fstab
    echo "LABEL=OPTWARE /opt ext2 rw,nodev,noatime 1 1" >> /etc/fstab


    I then ran

    wget http://tomatousb.org/local--files/tut:optware-installation/optware-install.sh -O - | tr -d '\r' > /tmp/optware-install.sh
    chmod +x /tmp/optware-install.sh
    sh /tmp/optware-install.sh


    I added this to the "run after mounting" section of USB Support

    if [ -d /opt/etc/init.d ]; then
    for f in /opt/etc/init.d/S* ; do
    [ -x $f ] && $f start
    done
    fi


    Next I ran via telnet ipkg install transmission, transmissiond, which completed successfully.
    If I telnet into the router I see that there are several transmission binaries at /opt/bin/
    I then enabled bittorrent & its GUI, & set the download directory to /tmp/mnt/STORAGE. The binary path was automatically set to /opt/bin/. Other configurations are left at defaults.
    At one point I tried a thorough reset (clear nvram) to default configuration.
    I can access shared files on the USB drive & navigate through them with telnet with no problems.

    So what happens?
    It's strange. When I restart the router, or if through the tomato web GUI I disable then enable transmission, I can <sort of> access transmission's web gui at :9091. Sometimes the normal page will load, sometimes only fragments that sort of look like a bulleted text file of various configuration options in the page (like total download/upload rates 50kB, 100KB...). In any case, if I try to add a torrent or refresh the page, or do basically anything at all after the 1st connection, either the browser cannot connect, or (rarely) I get a 403 forbidden error. Subsequent connection attempts fail similarly.

    I suspect transmission is crashing for some reason.
    I ran transmission-daemon -V, it's 2.77.
    ps | grep transmission yields no processes.
    I don't know what else to do.
    Transmission on the router was my favourite feature.
    If someone can help, or just suggest what else to look at (&
     
  2. leandroong

    leandroong Addicted to LI Member

    I'm running entware optware transmission and using Shibby 108-AIO FW. No issues. I suggest that you switch to entware optware. No issues with transmission.
     
  3. alazyworkaholic

    alazyworkaholic Serious Server Member

    Thanks for the reply. Optware was working so well for a while. I'd like to figure out what the issue was with transmission before nuking it. I may give entware a try if I don't get this fixed by the time shibby's next firmware update comes out.

    I have a little more info.
    I ran this to see what my settings were:
    ./opt/bin/transmission-daemon -g /tmp/mnt/STORAGE/.settings -d
    With this result:
    Code:
    {
        "alt-speed-down": 50,
        "alt-speed-enabled": false,
        "alt-speed-time-begin": 540,
        "alt-speed-time-day": 127,
        "alt-speed-time-enabled": false,
        "alt-speed-time-end": 1020,
        "alt-speed-up": 50,
        "bind-address-ipv4": "0.0.0.0",
        "bind-address-ipv6": "::",
        "blocklist-enabled": false,
        "blocklist-url": "http://list.iblocklist.com/?list=bt_level1",
        "cache-size-mb": 4,
        "dht-enabled": false,
        "download-dir": "/tmp/mnt/STORAGE",
        "download-queue-enabled": false,
        "download-queue-size": 5,
        "encryption": 1,
        "idle-seeding-limit": 30,
        "idle-seeding-limit-enabled": false,
        "incomplete-dir": "/tmp/mnt/STORAGE/.incomplete",
        "incomplete-dir-enabled": true,
        "lpd-enabled": false,
        "message-level": 2,
        "peer-congestion-algorithm": "",
        "peer-limit-global": 150,
        "peer-limit-per-torrent": 30,
        "peer-port": 51515,
        "peer-port-random-high": 65535,
        "peer-port-random-low": 49152,
        "peer-port-random-on-start": false,
        "peer-socket-tos": "default",
        "pex-enabled": false,
        "port-forwarding-enabled": true,
        "preallocation": 1,
        "prefetch-enabled": 1,
        "queue-stalled-enabled": true,
        "queue-stalled-minutes": 30,
        "ratio-limit": 1,
        "ratio-limit-enabled": false,
        "rename-partial-files": true,
        "rpc-authentication-required": false,
        "rpc-bind-address": "0.0.0.0",
        "rpc-enabled": true,
        "rpc-password": "{289c7ae5a035aea3194ee7188c5dff46947733df48dtn/dR",
        "rpc-port": 9091,
        "rpc-url": "/transmission/",
        "rpc-username": "admin",
        "rpc-whitelist": "127.0.0.1",
        "rpc-whitelist-enabled": false,
        "scrape-paused-torrents-enabled": true,
        "script-torrent-done-enabled": false,
        "script-torrent-done-filename": "",
        "seed-queue-enabled": false,
        "seed-queue-size": 5,
        "speed-limit-down": 248,
        "speed-limit-down-enabled": false,
        "speed-limit-up": 64,
        "speed-limit-up-enabled": false,
        "start-added-torrents": true,
        "trash-original-torrent-files": false,
        "umask": 18,
        "upload-slots-per-torrent": 10,
        "utp-enabled": true
    }
    I also got a log file.
    After starting the daemon as below I tried to access the web GUI. I got the garbled 1/2 page as before. Reloading the GUI led to a 404. I then tried to kill transmission via ssh, but the process was already dead.
    Code:
    root@E3000:/# /opt/bin/transmission-daemon -g /tmp/mnt/STORAGE/.settings -e /tmp
    /tlog
    root@E3000:/# cat /tmp/tlog
    [23:45:49.325] Transmission 2.77 (14031) started (session.c:722)
    [23:45:49.326] Couldn't read "/tmp/mnt/STORAGE/.settings/stats.json": No such file or directory (utils.c:445)
    [23:45:49.326] Couldn't read "/tmp/mnt/STORAGE/.settings/stats.benc": No such file or directory (utils.c:445)
    [23:45:49.326] Cache Maximum cache size set to 4.00 MiB (256 blocks) (cache.c:262)
    [23:45:49.326] RPC Server Adding address to whitelist: 127.0.0.1 (rpc-server.c:803)
    [23:45:49.326] RPC Server Serving RPC and Web requests on port 127.0.0.1:9091/transmission/ (rpc-server.c:997)
    [23:45:49.327] Bound socket 12 to port 51515 on 0.0.0.0 (net.c:377)
    [23:45:49.327] Bound socket 13 to port 51515 on :: (net.c:377)
    [23:45:49.327] UDP Failed to set receive buffer: requested 4194304, got 229376 (tr-udp.c:77)
    [23:45:49.327] UDP Please add the line "net.core.rmem_max = 4194304" to /etc/sysctl.conf (tr-udp.c:82)
    [23:45:49.327] UDP Failed to set send buffer: requested 1048576, got 229376 (tr-udp.c:88)
    [23:45:49.327] UDP Please add the line "net.core.wmem_max = 1048576" to /etc/sysctl.conf (tr-udp.c:93)
    [23:45:49.328] Using settings from "/tmp/mnt/STORAGE/.settings" (daemon.c:517)
    [23:45:49.328] Saved "/tmp/mnt/STORAGE/.settings/settings.json" (bencode.c:1738)
    [23:45:49.328] Couldn't read "/tmp/mnt/STORAGE/.settings/resume/ubuntu-13.04-desktop-amd64.iso.f41989f9797a8850.resume": No such file or directory (utils.c:445)
    [23:45:49.328] ubuntu-13.04-desktop-amd64.iso Couldn't read "/tmp/mnt/STORAGE/.settings/resume/ubuntu-13.04-desktop-amd64.iso.f41989f9797a8850.resume" (resume.c:686)
    [23:45:49.328] Loaded 1 torrents (session.c:1943)
    [23:45:49.328] Port Forwarding (NAT-PMP) initnatpmp succeeded (0) (natpmp.c:72)
    [23:45:49.329] Port Forwarding (NAT-PMP) sendpublicaddressrequest succeeded (2) (natpmp.c:72)
    
    I saw the bit about UDP & adding a line, but my router doesn't have a sysctl.conf file in /etc. What gives?
     
  4. leandroong

    leandroong Addicted to LI Member

    change your FW with built-in transmission, use BT-VPN. You are using optware transmission and not built-in.

    In my case, i'm using nightly built transmission, therefore, I use entware optware.

    Installation of entware is same, except that you use "entware_install.sh" instead of "optware-install.sh".
    For optware installation, you use "opkg" instead of "ipkg".

    If still you wanted to run optware transmission, use Shibby repository for that, http://tomato.groov.pl/repo/
     
  5. leandroong

    leandroong Addicted to LI Member

    You problem might be due to download folder. I can see that you partition your USB flash drive into 2, namely, swap and optware. Where is this directory, "/tmp/mnt/STORAGE" ?
     

Share This Page