1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot enter port = 1194 in Tomato VPN v1.25vpn.

Discussion in 'Tomato Firmware' started by freedom4kids, Nov 11, 2009.

  1. freedom4kids

    freedom4kids Addicted to LI Member

    I am setting up site to site vpn with Tomato VPN v1.25vpn3.4.4a8380cb. It works exceptionally well here in the lab.

    Now the real world, i.e. sit to site across the wild internet from my work lab to my home Tomato VPN v1.25, i.e.

    Lab = client VPN server
    Home = main VPN server.

    However with my home setup I cannot enter VPN Server Configuration/Server1/Basic/Port = 1194, i.e.

    1. Enter port = 1194.
    2. Click on save and it seems to apply.
    3. Click on Start Now.
    4. Port = 1194 parameter disappears/clears.
    5. Port GUI field switches to a yellow color.

    I have rebooted several times but it seems to be "stuck". Is this a known issue, i.e.

    Nov 11 11:42:58 ? daemon.err openvpn[821]: Options error: Bad port number: 0
    Nov 11 11:42:58 ? daemon.warn openvpn[821]: Use --help for more information.
    Nov 11 11:42:58 ? user.info init[1]: VPN_LOG_ERROR: 732: Starting VPN instance failed...
    Nov 11 11:42:58 ? user.info kernel: br0: port 3(tap21) entering disabled state
    Nov 11 11:42:58 ? user.info kernel: br0: port 3(tap21) entering disabled state
    Nov 11 11:43:07 ? user.info kernel: device tap21 entered promiscuous mode
    Nov 11 11:43:07 ? user.info kernel: br0: port 3(tap21) entering listening state
    Nov 11 11:43:07 ? user.info kernel: br0: port 3(tap21) entering learning state
    Nov 11 11:43:07 ? user.info kernel: br0: port 3(tap21) entering forwarding state
    Nov 11 11:43:07 ? user.info kernel: br0: topology change detected, propagating
    Nov 11 11:43:07 ? daemon.err openvpn[839]: Options error: Bad port number: 0
    Nov 11 11:43:07 ? daemon.warn openvpn[839]: Use --help for more information.
    Nov 11 11:43:07 ? user.info init[1]: VPN_LOG_ERROR: 732: Starting VPN instance failed...
    Nov 11 11:43:07 ? user.info kernel: br0: port 3(tap21) entering disabled state
    Nov 11 11:43:07 ? user.info kernel: br0: port 3(tap21) entering disabled state
    Nov 11 11:43:14 ? user.info kernel: device tap21 entered promiscuous mode
    Nov 11 11:43:14 ? user.info kernel: br0: port 3(tap21) entering listening state
    Nov 11 11:43:14 ? user.info kernel: br0: port 3(tap21) entering learning state
    Nov 11 11:43:14 ? user.info kernel: br0: port 3(tap21) entering forwarding state
    Nov 11 11:43:14 ? user.info kernel: br0: topology change detected, propagating
    Nov 11 11:43:14 ? daemon.err openvpn[857]: Options error: Bad port number: 0
    Nov 11 11:43:14 ? daemon.warn openvpn[857]: Use --help for more information.
    Nov 11 11:43:14 ? user.info init[1]: VPN_LOG_ERROR: 732: Starting VPN instance failed...
    Nov 11 11:43:14 ? user.info kernel: br0: port 3(tap21) entering disabled state
    Nov 11 11:43:14 ? user.info kernel: br0: port 3(tap21) entering disabled state
     
  2. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    Sounds like an NVRAM problem. You should erase (thorough) your NVRAM and set it up again.
     
  3. freedom4kids

    freedom4kids Addicted to LI Member

    Thank SgtPepperKSU for the almost immediate reply.

    Again my apologies for the forthcoming double post. Do you have a link handy regarding clearing NVRAM thoroughly?
     
  4. freedom4kids

    freedom4kids Addicted to LI Member

    I found it in the Administration/Configuration. Thanks again SgtPepperKSU for the great mod.
     

Share This Page