1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot install 3rd party firmware

Discussion in 'DD-WRT Firmware' started by dennz, Mar 25, 2007.

  1. dennz

    dennz LI Guru Member

    Hi,

    I'm trying to install 3rd party firmware on my WRT54G 2.2 with little success.

    When trying to upgrade, I get the "Upgrade are failed" error. I've tried several different firmwares, turned off Anti-Virus, Firewalls, reset to factory settings etc, nothing helps.
    After an hour of googling and reading, I'm guessing that the Linksys firmware I'm running now, v4.20.8, blocks me from installing 3rd party firmware. Is this the case? If so, how do I get around it? Can I download an older linksys firmware somewhere and use that?

    I'd really like to switch to DD-WRT for many reasons...

    Thanks,
    Dennis
     
  2. Toxic

    Toxic Administrator Staff Member

    try using the _mini version when upgrading from original Linksys firmware.
     
  3. dennz

    dennz LI Guru Member

    I used this one, vxworks_prep_v03.bin. I also tried dd-wrt.v23_micro_generic.bin, which I assume is the "mini version".

    Any more hints?
    Thanks!
     
  4. fastpakr

    fastpakr Network Guru Member

    You don't have a VXWorks based device, so that certainly isn't necessary. Have you tried using TFTP?
     
  5. dennz

    dennz LI Guru Member

    Yes, TFTP gives me a different error, "Wrong Code Pattern".
     
  6. dennz

    dennz LI Guru Member

    I got it to work now that I found the WRT54G specific versions :rockon:
     

Share This Page