1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot setup WPS54G, unreliable

Discussion in 'Other Linksys Equipment' started by Cluster2k, Jun 11, 2008.

  1. Cluster2k

    Cluster2k Addicted to LI Member

    Hi,

    I have just purchased a Linksys WPS54G and have found it very difficult to configure. The devices freezes when I access the setup web page and requires a power cycle to see the next screen! Cannot add the connected printer to Windows either.

    Device: WPS54G, version 2, 6050 firmware

    Network: standard 10/100 switch, and a wireless router, 192.168.30.*, static IP for print server

    Printer: DYMO LabelWriter 400

    Computer: WinXP Pro SP2

    The setup wizard proceeded normally and installed the printer driver. My wireless network uses WPA2 encryption instead of WEP, so I could only enter the wireless SSID into the wizard and would have to visit Setup to enter the WPA2 key later.

    After much experimentation and a long session with online Linksys tech support, I found that the WPS54G can be pinged OK when first powered up, but if I open the Setup and click on any link (to see the Wireless screen, System info, etc), the device freezes and no longer responds to pings. If I power cycle the device, sometimes I can hit refresh in the browser and see the next setup screen! On one occasion the WPS54G played nice after power cycles and let me see all the Setup screens, but attempting to save any settings froze the device.

    Whether using a wired connection or trying to use wireless, I cannot see the connected printer on my Windows box.

    Attempting to access Setup and change settings requires 5 minutes of fiddling each time, power cycling the device to try to get it to work. Despite best efforts it still doesn't work.

    This is the most frustrating device I have used in a long time.

    The BI-Admin program crashes instantly on startup.

    Linksys tech support offered a firmware update, but they only have updates for version 1! The techie was confused by my V2 device and even asked me for the FCC ID to try track something down (he/she failed).

    I think I have grounds to RMA this device to Linksys, but I fear they may just plug it into their test bench, try a few simple diagnostics and declare it to be 100% functional.

    Any help greatly appreciated.
     
  2. DaveMcLain

    DaveMcLain Network Guru Member

    I've been using one of those print servers in our shop for the last couple of years without any problems with the device but mine is a v1 too so that could make a difference. About the only problems I've had was trying to use it with a printer that was not compatible(HP 1012 Laser). But with an HP or Canon inkjet it's been flawless.

    Could be that you just got a bad one.
     
  3. Cluster2k

    Cluster2k Addicted to LI Member

    The product has been sent back to the retailer together with Linksys's case ID number. Hopefully they'll exchange it quickly.

    To get the case ID, I had to speak to tech support over a very scratchy and lagged phone line. Everything had to be repeated at least twice to be understood. Very frustrating, Linksys.
     
  4. Bird333

    Bird333 Network Guru Member

    I know this thread is old but I just had to chime in. Yes, this thing sucks. I had the same problems of freezing. Thankfully, I was able to configure my router with a USB port to use as a print server.
     
  5. motocrossmann

    motocrossmann Network Guru Member

    This device is JUNK, as is Linksys support for it. They released a firmware update in August 08, which the device refuses to accept (webif, TFTP, BiAdmin, etc). The worst part is that Linksys has known about the issue dating back to August and there is still no resolution.

    I strongly advise against buying Linksys, if you think you may need support. They are the worst IMHO.
     

Share This Page