1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot upload with Tomato 1.19 and WRT54GL

Discussion in 'Tomato Firmware' started by mjyoung, Apr 28, 2008.

  1. mjyoung

    mjyoung Addicted to LI Member

    Ok, I recently purchased a WRT54GL v1.1 and loaded it with Tomato v1.19. Everything runs great, no dropped connections, etc, except for ONE VERY ANNOYING THING (ahhh!) - I cannot upload. I can't send files through AIM, nor can I send attachments through Gmail, nor can I upload files via my webhost's file manager. However, uTorrent does seem to be able to upload correctly.

    I'm connected wirelessly via my laptop. I've taken a look at my settings and I'm baffled. I cleared my NVRAM upon installation of Tomato. I have tried enabling and disabling QoS, I've tried DMZ, etc. I'm not sure what the problem is. Admittedly, I don't know what a lot of the technical features are and how they may affect this such as MTU and some of the other stuff. I've also tried resetting to default Tomato config and still no luck.

    I've tried to do a sweep of this forum's topics but couldn't find anything that works. Has anybody else ever run into a problem like this? Any help would be very much appreciated!
  2. LLigetfa

    LLigetfa LI Guru Member

    What is the WAN port connected to? Cable? DSL?
    Are you getting a public IP on your WAN port?
  3. mjyoung

    mjyoung Addicted to LI Member

    My WAN port is connected to my Comcast Cable. Yes, I am getting an IP and am able to access the internet just fine except for the upload issues.
  4. bigclaw

    bigclaw Network Guru Member

    Sounds like some security or firewall software on your laptop. Your outgoing connections are apparently fine as otherwise you won't be to use the Internet at all.
  5. LLigetfa

    LLigetfa LI Guru Member

    Of course you are getting an IP or you wouldn't be able to do anything. I wasn't asking if you could get just any IP, I asked if you get a PUBLIC IP. It helps to determine if you are double NAT'ing.
  6. TexasFlood

    TexasFlood Network Guru Member

    Some might not be familiar with what IP space is private. Anyone who is, move along, :) For those who are not, here is a Wikipedia page describing it.
  7. LLigetfa

    LLigetfa LI Guru Member

    Sorry, made the assumption someone that can flash a router with Tomato would know the difference. I thought of asking the OP what their WAN IP is. Well... the first two octets anyway.

    i.e. 200.16.yy.zz
  8. TexasFlood

    TexasFlood Network Guru Member

    I'm not sure if OP of this thread knows or doesn't, but I noticed in another recent thread that the OP of that thread didn't seem to. So just thought I'd throw it out there as an FYI for anyone who didn't. Believe it or not, I know quite a few folks who can flash a router (through the GUI anyway) but really have no idea why the default subnets on home routers tend to be 192.168.x.x or and some who don't really know what NAT or port forwarding is. I constantly have to fight my tendancy to assume too much at work as it causes communication problems, :-D Guess I'm trying to do the same here.
  9. InfX

    InfX Addicted to LI Member

    Try lowering your max MTU on your PC. You can use this utility to do this on xp/2k, google it up if you are on a different OS. Set the MTU to something as low as 1300 and see if it still happens.

    PS: i really doubt its all about NAT problems, sounds more like MTU problem to me. What the hell Gmail attachments got to do with NAT ? Come one ppl.
  10. mjyoung

    mjyoung Addicted to LI Member

    @ bigclaw: No, I have no firewall software installed. Windows firewall is off.

    @ LLigetfa: 76.102.yyy.zzz is the WAN IP. However, I do plead newbieness. What does double NATing mean?
  11. mjyoung

    mjyoung Addicted to LI Member

    This seems to have worked for me. Thank you so much InfX! Can you elaborate a bit on what MTU is and why that affects me? Will lowering it to 1300 as I have now done decrease the quality of my connection in any way?

    Additionally, do I need to set every computer's MTU to 1300? Or will changing the MTU settings in the Tomato firmware to 1300 do the trick for everyone?

    Edit: I tried sending a file through AIM which did not work, so seems some functionality is still missing? But imageshack, google, 2shared.com (file upload site) worked fine...
  12. InfX

    InfX Addicted to LI Member

    MTU - Maximum Transmission Unit

    It sets the maximum IP packet size your PC is allowed to send. The default for a regular ethernet is 1500, yet, keeping it at that default can create 'unwanted effects' you describe when those packets have to go through some place that can't handle them, such as a PPPOE connection.

    BTW, if this helps, lower the MTU on the router as well, this will ensure fragmentation in case a different, unconfigured, PC tries to send a larger packets.

    Decreasing it to 1300 will decrease the upload efficiency, you should experiment and set it as high as possible. To find the max possible value you can use this method - http://www.dslreports.com/faq/695

    EDIT1: AIM probably needs some ports mapped, i don't know exactly what ports, take a look at it's config, it should be there.

    EDIT2: BTW, 76.102.yyy.zzz is a normal external comcast IP, you are NOT double NAT-ed.
  13. InfX

    InfX Addicted to LI Member

    Sorry, i missed this part...

    The answer is - while it would probably do the trick, it would cause the router to fragment the packets, impacting the network efficiency more than lowering it on the PCs would, so i'd recommend reconfiguring all the PCs as well, or at least the PCs that supposed to be permanently connected to that network.
  14. LLigetfa

    LLigetfa LI Guru Member

    I thought that may have been a distraction unrelated to the other problems. I had one user on my hotspot complain that he couldn't attach files in gmail but yet I could.

    I was going to get around to the topic of MTU, really. :rolleyes:
  15. mjyoung

    mjyoung Addicted to LI Member

    Ah yeah, sorry, neglected to mention before that the problem occurs on all 3 computers that are connected to the network.

    Thanks again for all the help everyone (Infx!!). Everything's working great now =)
  16. jersully

    jersully LI Guru Member

    Double NATing is when your provider is NATing you (giving you a private address such as 10.x.x.x) and then your router NATs your internal network (162.168.x.x.) It confuses some protocols, jacks up port forwarding, etc.

    You are not double NATed. They are giving you a public, routable IP address. You are behind one NAT like all of us. Can you upload tiny files?

    So, no double NATing, you're sure you're not behind a firewall... I suppose MTU could be the culprit but I'm pretty stumped.
  17. mjyoung

    mjyoung Addicted to LI Member

    Yeah, the troublemaker was my MTU rates. Thank you all for your help =)
  18. jersully

    jersully LI Guru Member

    Sorry, I missed the entire second page of the thread, so this was a redundant post. :redface:

Share This Page