1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't restore configuration on different router

Discussion in 'Tomato Firmware' started by dtango2010, Jan 1, 2014.

  1. dtango2010

    dtango2010 Reformed Router Member

    Hello All.
    I have two RT-AC66U with latest Shibby 115.
    The configuration of first AP was a bit tricky , so I decided save it and restore on second AP to continue test.
    I was fail with this process. I mean, The restore of configuration on different AP gave an error - "Cant restore configuration on different router".
    Is that a bug?

    I'm asking because if I use standard firmware, then I can restore configuration on same model AP without any problem.
  2. jerrm

    jerrm Network Guru Member

    Short answer - no using the GUI. You could backup/restore manually using nvram export/import with the --force option, but I wouldn't.

    Standard firmware has the luxury of knowing what hardware it is running on and making necessary adjustments when restoring. There are a lot of settings that you do not want restored between different models or even two of the same model. Outside of the initialization code 99%+ of tomato doesn't know or care what model it is running on.

    The nvram restore check is only looking at the mac address to determine if it is the same unit. If you really want to try it, you could manually set "et0macaddr" to match the router the backup came from and then try the gui restore.

    Better option would be to backup and restore only the settings that matter. Several threads here discuss the use of nvram export --set as an option.
  3. Toastman

    Toastman Super Moderator Staff Member Member

  4. dtango2010

    dtango2010 Reformed Router Member

    Thanks a lot! You've saved my time.

Share This Page