1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Complete Uninstall Help

Discussion in 'Sveasoft Firmware' started by pinkysmallz, Nov 15, 2004.

  1. pinkysmallz

    pinkysmallz Network Guru Member

    I tried installing the Satori 4 firmware on my WRT54G a little while back and loved the functionality of it but for some reason it would not let my TiVo's communicate with each other over my network. I decided to re-flash my router with the Linksys firmware. However since I have done this I have been experiencing serious problems with my router, such as the connection just basically dying and it not being able to load some web sites. I know it is not a problem with my internet connection because if I plug a computer directly into the connection, all is well and very fast.

    Is there a certain way to completely uninstall the Satori from my WRT54G? Or if I just change the firmware like I did when I installed the Satori originally should that do it. I am just curious if it left something in there that it shouldn't have. Any help is really appreciated as this is kind of getting on my nerves and making me want to buy a new router (even though I'd prefer not to).
     
  2. Lazybones

    Lazybones Network Guru Member

    After changing to or from Sveasoft firmware to another firmware you MUST do a 30s REST to flush the router settings to factory defaults.

    If you didn't not do a 30s REST this could explain your problems with Satori and defiantly explains problems going back the the Linksys firmware.
     
  3. pinkysmallz

    pinkysmallz Network Guru Member

    I have done the 30sec reset many times, that was my first thought. I just feel as though there is some sort of the Sveasoft software still in there because when I use, for instance, the Linksys automatic flash to update to the latest, it can't detect the current firmware on the router (whereas before I installed the Sveasoft, it did). Maybe I'm just going crazy, I don't know but if anyone has any ideas I'd really appreciate it. Thanks for the tip though!
     
  4. Morpheus

    Morpheus Network Guru Member

    I always do a full re set Before Upgrading and again after the Upgrade any Firmware
     
  5. Anonymous

    Anonymous Guest

    You may want to try the following - upgrade to Satori again, login and run "nvram erase" (DO NOT run "nvram commit" or anything else after this), upload the Linksys firmware immediately after via the web interface.

    Perform a full reset upon reboot.

    This will bring your router back to the original factory settings.
     

Share This Page