1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Confused about TCP/UDP view details w/ Azureus & Tomato

Discussion in 'Tomato Firmware' started by Sunspark, Jun 6, 2007.

  1. Sunspark

    Sunspark LI Guru Member

    Hi I am confused about something, I don't know if this is a bug in Azureus, Tomato, or just my misunderstanding..

    I can transfer just fine with port forwarding, DMZ and upnp.. (though upnp is a little flakey).

    I have the same port set for both TCP and UDP in Azureus..

    In Tomato when I look at the details in classifications, etc.. it lists the same port all with UDP say 55555 as the listening port/source port.. but anything that is TCP it uses something other than 55555 which confuses me.. because if I have 55555 set as my TCP listening port why would the list be showing a source port of 44928 or whatever for example on my end??

    This is annoying because I cannot make a simple rule for all source ports to be 55555 in QoS from a MAC address to have a specific priority because for some reason it's using TCP with random port numbers..

  2. Sunspark

    Sunspark LI Guru Member

    Ok it seems as if the non-listening TCP ports are outgoing ports because most programs can't stuff a bunch of ips on the same socket.
  3. digitalgeek

    digitalgeek Network Guru Member

    Try utorrent and see if you get the same results. I remember when I used to use Azureus, and listening port problems... with utorrent and tomato things quite well. Remember if you are using BT encryption you can not use the L7 filters... set you rule to trigger both UDP and TCP... and everything should work fine...
  4. dolly_oops

    dolly_oops Network Guru Member

    You might want to try binding all your outgoing connections to a specific port (it's one of the advanced options in the Connection section, I think)

Share This Page