1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Connect to WAG54G Wirelessly but no Internet?

Discussion in 'Other Linksys Equipment' started by DinoCarlton, Oct 16, 2005.

  1. DinoCarlton

    DinoCarlton Network Guru Member

    Newbie to the forum - but not to trouble with my WAG54G.

    Have been using 10m ethernet cable running up the stairs, but now need to get this sorted! :)

    Have Win XPSP2 connecting wirelessly via WUSB11 adapter just fine.

    Another machine W2KPro fully patched connects via WUSB54G, gets IP allocated but cannot see the internet.

    WAG54G-UK on firmware 1.00.7
    WUSB11 v2.8 on driver 2.9.8.335
    WUSB54G on driver 1.0.8.0, v2.0 WLAN monitor 2.0

    WAG54 constantly drops internet connection needing disconnect / connect via admin panel or often a reboot.

    I am about to throw the towel in on the WAG54. I have seen all the posts on this forum, and am not sure I want to fight it!

    I reckon I should probably try a firmware upgrade before I do get rid of it, but have no idea which way to go (have upgraded firmware on my trusty old linksys router, so am not afraid to do it, just confused as to what version!).

    Any pointers please?
     
  2. 7ttman

    7ttman Network Guru Member

    WAG54 constantly disconnecting?

    if you are having problems with the gateway connetcing to the internet, indicated by the red/green LED's and notified in the admin/status page, then it's more likely to be a problem with you telephone cables.

    I've noticed that a number of people have reported problems after upgradeds from 512 to 1 or 2 mb.

    In order to prove whether or not it's your telephone cables, or a device conencted to your internal telephone cable network, disconnect everything by disassembling the BT master socket and plugging your adsl filter into the internal connector inside the socket. then connect your WAG54. If you get a constant green light and can browse the internet, then you'll need to discover what's causing the problem on your internal telephone cable network. You can do that by attaching one thing at a time and then checking to see if the disconnects occur. It could easily be a pinched cable inside the walls of the house, so don't assume that your cable network is 100% perfect. Analoguie voice is very forgiving wwhen it comes to poor or bad cables as indicated by the aluminum crap cables that BT installed in my neighbour 40 years ago and expected to deliver ADSL!
     
  3. DinoCarlton

    DinoCarlton Network Guru Member

    Will try that....

    ....thanks!

    However, that still leaves the other issue of connecting wirelessly via WUSB54G.

    That scenario sees me online (internet access works fine) with one PC connecting via WUSB11 and at the same time, another PC connecting wirelessly via WUSB54G to WAG54G no problem (getting IP allocated by DHCP), but then not seeing the internet.

    So - one works at the same time that the other doesn't....

    WAG54G running in Mixed mode, SSID not broadcast (though have tried doing that to no avail), access limited by MAC address (tried it open too), no WEP (whilst trying to solve this).

    Sometimes see IP address allocated outside the range I configured - in fact, nothing like what I configured! I assume that is a spurrious connect through a neighbours box?

    Any ideas?

    Cheers!
     
  4. 7ttman

    7ttman Network Guru Member

    IP configuration error

    sounds very much like you have an IP configuration problem on your second machine.

    Try running IPCONFIG on both machines to check the settings. Each machine should have different IP addresses but the subnet mask and defualt gateway should be the same.

    Go to control panel "Network connections", your network adapter, "PROPERTIES" and "Internet protocol". make sure that the machine causing the problem is set to the same parameters as the one that works, i.e. "obtain IP address automatiucally (if you are using the DHCP server capabilities of the WAG54)" and "Obtain DNS auto". Also check the "advanced" settings to make sure there isn't anything set in there wrongly!
     
  5. Quiver

    Quiver Network Guru Member

    I have the exact same problem, almost.

    It's a WAG54Gv2 router, with stock firmware (though I might upgrade that tonight), no security whatsoever whilst it's being setup, and with four other machines in this house (two XPSP2, two gentoo-linux 2.6.14), all with wireless adapters of different brands, and none of the machines can see *beyond* the router wirelessly...

    Though with a 30m cable and a bit of running around, they can all connect and see/browse the web via ethernet, using the same configuration (either DHCP or static with the router as the default gateway). So it's not my network settings...

    One of the adapters is in fact a Linksys WMP54Gv4 (RT2500), running on XPSP2 with wireless hotfixes, so even on the same brand and with the reccomended configuration, it's a no-show. Every machine can see each other machine and access the router, but unless it's wired, it can't see out.

    Bizarre? I thought so. And I know everyone who uses a forum believes they're an expert, but as a video engineer, which in this day and age just means a glorified network engineer, I'd like to think I was rather network-savvy, but this one has me stumped. I'll up the firmware on the router tonight, but from how little I've found on every forum I've looked at so far, I'm not getting my hopes up.

    Cheers,

    -Tad
     
  6. booly

    booly Network Guru Member

    I've a WAG V2 with 3 pc (1 wired Pc Fix IP ; 1 Wireless notevook Fix IP ; 1 wireless PC DHCP IP) and still have no problem ( even with To pc running P2P)

    I use the 1.01.22 EU firmware
     
  7. Quiver

    Quiver Network Guru Member

    I upgraded the firmware last night to the latest Australian release, the 1.01.25, still no improvement. :| I really can't get my mind around this issue... Any ideas folks?
     

Share This Page