1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Connecting WAG54G and WRT54G

Discussion in 'Networking Issues' started by Silberfuchs, Mar 26, 2005.

  1. Silberfuchs

    Silberfuchs Network Guru Member

    Hello,
    I'm new here and i have the following problem:

    I have a WAG54G (Firmware 1.01.6) in my 2nd floor with Internet Access. To connect some devices in the ground floor I have an WRT54G(Firmware 3.03.2). Is it possible to connect them via W-LAN?

    Best Regards
    Silberfuchs
     
  2. jazzydnb

    jazzydnb Network Guru Member

    Hi,

    I don't have an answer to your question but I would be very interested in finding out how this is done.

    I have a WAG54G (v1.2) running firmware 1.02.7 with WDS configured with WRT54G wireless MAC address and the WRT54G (v2.0) running with HyperWRT 2.1b1, again with WDS configured, with the WAG54G wireless MAC address.

    They're both using the same wireless channel, same SSID and network mode but unfortunately I can never get the two to talk wirelessly. Of course, as soon as I put a cable between the two it's all good.

    I've tried using standard Linksys firmware and the Satori firmware for the WRT while working with 1.02.7_03 and 1.02.9_04 on the WAG54G and still no go.

    There doesn't seem to be a definitive article that details if and how WDS is established between the WRT54G and the WAG54G. If someone could point us in the right direction, that would be greatly appreciated.


    Thanks.
     
  3. Toxic

    Toxic Administrator Staff Member

  4. Silberfuchs

    Silberfuchs Network Guru Member

    I'm sorry for my question again, but in my case the WAG54G is connected to the Internet. As far as I understood the Link above, I have to use the WRT54G to connect to the Internet??? But therefore I have to have another DSL modem... Am I rigth?

    Silberfuchs
     
  5. Toxic

    Toxic Administrator Staff Member

    not from what i read from the thread no. this is only meant a guide line.
     
  6. jazzydnb

    jazzydnb Network Guru Member

    Hi,

    Just wanted to post an update to some success I've had...

    I think it's all about a misunderstanding with network topology and how wireless repeating works.

    I now have WDS working between the WRT and the WAG. What I have done is stopped using static IP to set an internet address and then set the local IP to be on the same subnet as the WAG. WDS is set up with same SSID, channel and operating mode on both devices. As long as the default gateway is set to the local IP of the WAG, all wireless client PC's can talk to each other, both linksys devices and Internet hosts. This is something I've been trying to sort out for quite some time. Rather happy it's now finally working.

    Now, I was thinking that all this was happing through the WAG and the WRT was out of the picture. To test this I disabled wireless and enabled LAN only on one of the PC's directly connected to the WRT via CAT5. From a wireless host I can still work with the LAN PC, so comms definitely has to be happening via the WRT.

    I was a bit confused about how the WRT behaves once it's placed into this repeating mode and how it should be configured. The link posted by Toxic got me thinking about how the WRT should be set up (thanks Toxic!).


    Cheers
     
  7. Silberfuchs

    Silberfuchs Network Guru Member

    @jazzydnb:

    can you tell me please what firmware you are using on your devices?

    Silberfuchs
     
  8. jazzydnb

    jazzydnb Network Guru Member

    Silberfuchs,

    I'm running HyperWRT 2.1b1 (3.03.6) on the WRT54G and Linksys firmware v1.02.7 on the WAG54G.
     
  9. Silberfuchs

    Silberfuchs Network Guru Member

    Hi,

    I'm running the Satori Firmware of the database from here. If I switch the WRT54G in Client Mode it is possible to connect to the Internet, but I want to use the wireless connection in both directions.
    If I switch the WRT in AP-Mode nothing happens. I think the problem is that I don't know what to fill in in the fields in WDS???? I tried to fill in some adresses (where do they have to be connected - on which device??)but afterwards I can't do anything with the WRT54G => I have to do a reset.....

    Regards
    Silberfuchs
     
  10. jazzydnb

    jazzydnb Network Guru Member

Share This Page