1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Constant Blinking Power Light RT-N16

Discussion in 'Tomato Firmware' started by ladysman, Oct 19, 2012.

  1. ladysman

    ladysman LI Guru Member

    I've had this before a few times and a simple put in recovery mode and upload of firmware and it's fixed.

    However, this one will not stop blinking even when the Asus restore utility say the upload was successful. I just don't get it. THought I would ask here if anyone had suggestions?

    Thanks.
     
  2. lefty

    lefty Networkin' Nut Member

    hrm, have you tried just using TFTP to transfer the image?
     
  3. ladysman

    ladysman LI Guru Member

    I can't connect to the router via ip at all. Restore utility says it works but still blinks.
     
  4. mstombs

    mstombs Network Guru Member

    Have you been playing with clockfreq or 64kB nvram or loaded MIPSR1 firmware? Or running scripts that write to nvram every second?

    Flashing light proves CFE is running (a sign of life) and stuck in recovery mode, which can be due to corrupt or incompatible firmware.

    If you can't connect it may be in a reboot loop, so its only available to be tftp'd for 4 seconds every 20 seconds or so, but you should be able to hold 'recovery mode' by powerup while holding the black recessed "RESTORE" button. I would need to check to confirm, but I assume this also resets the nvram to default.

    Of course could be bad hardware, do check the 12V 1.25A PSU.

    If the router is out of warranty output from serial console would be helpful.
     
  5. ladysman

    ladysman LI Guru Member

    No overlcocking and always had the correct firmware. In fact, this isn't even mine, but I flashed it for this person over a year ago. he told me it got mistakenly unplugged from power then plugged it back in this caused this issue. I think he has a VPN script running at startup but i not 100% sure. i'll report back.

    What i've noticed if i hold the restore button and tftp, it does work and says it accepted the firmware but just goes back in the same blinking light loop.

    Router is for sure out of warranty and he has already replaced it but i wanted to see if i could bring it back to life.

    Thanks!
     
  6. Nitro

    Nitro Networkin' Nut Member

    I had this problem a while back and to resolve it I had to download a very old version of the ASUS firmare for the RT-N16 if i remember correctly it was the smallest file size one I chose (to make the upload faster). it seemed to work first time with an Asus firmware after numerous attempts to use the restore utility to upload toastman and shibbys firmwares.
     
  7. ladysman

    ladysman LI Guru Member

    Thanks for the tip! any idea on the version?
     
  8. Nitro

    Nitro Networkin' Nut Member

    I think it was version 1.0.1.9 on this page > http://support.asus.com/Download.aspx?SLanguage=en&m=rt-n16&p=11&os=8
    It was roughly 8.5Meg compared to the latest version which was around 19Meg so I gave it a try to see if it would work and it did and it was enough to then login in and upload a tomato firmware straight after.
     
  9. ladysman

    ladysman LI Guru Member

    Appreciate the help but nothing has worked. I'm not going to waste anymore time on it at this point. Thanks for the help!
     
  10. mstombs

    mstombs Network Guru Member

    The RT-N16 CFE doesn't require small firmwares, but maybe some tools do, I have tftp'd 18MB+ firmwares from Linux before. Look out for this one on a online auction website soon!
     

Share This Page