1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Corrupt Linksys firmware has bricked my WRT54GL?

Discussion in 'Cisco/Linksys Wireless Routers' started by fresh, Oct 28, 2007.

  1. fresh

    fresh Network Guru Member

    I have a WRT54G with tomato firmware upstairs. Downstairs, I want to set up a WRT54GL as a client to hook up my Xbox and HTPC to the internet/network.

    I've had the downstairs router for a while, have played with it before trying to get WDS to work, flashing many different firmwares many different times. I haven't touched it in about a year since I couldn't get WDS working properly.

    When I log into it now to try to install tomato on it, I am able to access 2 screens which are completely useless. I am greeted with this screen, and the only link on that page is the ampersand (&) that you see, which takes me to this screen. I have tried resetting the router by holding the reset button until the front lights flash, and cycling the power by unplugging it for 30 seconds and then plugging it back in.

    Is my router a brick? Is there any way to remedy this? TIA for replies, cheers.
  2. Toink

    Toink Network Guru Member

    Re-flash your router with the official WRT54GL firmware using the TFTP.EXE utility
    The default IP is and use admin (or your password), as the password, then browse for the firmware. That should fix the corrupt configuration page.

  3. fresh

    fresh Network Guru Member

    Well the flash said that it worked successfully, but now I cannot log into or even find my router. When I go to, I get a 'cannot load web page' in Firefox.
  4. Toxic

    Toxic Administrator Staff Member

    check your browser connection settings for any proxy cache you are using and make sure your lan connection is set to automatically assign an ip address from dhcp.
  5. fresh

    fresh Network Guru Member

    Everything is set correctly. I had no problem logging in before I flashed it with TFTP.

    Edit: I reflashed it, and got it to work. I've installed tomato on it, which is the same firmware as the upstairs router has. How do I now get it to act as a wireless adapter instead of a router? I set it to Wireless Ethernet Bridge and changed the ip to with as the default gateway (which is the same as the upstairs). It was giving me signal strength readings, but I couldn't connect to the internet. Thanks.
  6. fresh

    fresh Network Guru Member

    Ok I couldn't get it working with tomato, so I installed HyperWRT. I got it working, but for some reason didn't realize it and reset it. Now, I can't change the router's IP address. If I change it to anything other than, it won't let me reconnect to it (Limited or no connectivity BS) until I reset it to How can I change the IP?
  7. fresh

    fresh Network Guru Member

    Can someone please help me. I had it working somehow with HyperWRT (with no thibor, tofu etc., just straight HyperWRT) and I messed it up without realizing it. I don't remember what the settings were. I've installed HyperWRT +thibor, dd-wrt, tomato, and on every single one it won't work, and if I change the router's IP address outside of the gateway, I lose access to the router and have to reset it.

Share This Page