1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Counter Strike pause-resume problem with DD-WRT Pre5 (Jun,5)

Discussion in 'DD-WRT Firmware' started by bytes2000, Jun 10, 2005.

  1. bytes2000

    bytes2000 Network Guru Member

    Im experiencing a problem with this firmware, while im playing counter strike: source games suddenly pauses for 3 or 4 seconds (no movement just screen shakes) the it resumes it follows this pattern: it pauses exactly every 15 minutes.

    I was logging the time when this strange behavior was happening:


    This wasnt happening when I had Alchemy or latest official firmware.

    I have a WRT54GS v1.0 and im using DD-WRT Pre5 (Jun,5)
    My internet connection is PPPoE ADSL 512/128 and im using RP-PPPoE and Qos (correctly set at 85%), im the only one connected to the router.

    I think theres a cronjob set for every 15 min that is messing with my me.

    Can you fix this ?
    And btw, can you please update L7 protocols definitions ?
    Theyre a bit old (CS source, gnutella, Skype MSN, etc... )

    Brainslayer you are doing a really god job with this firmware, thanks!
  2. Jeffrccar

    Jeffrccar Network Guru Member

    mmm.... I would not use QOS if i'm playing CS:S and you only have DSL 512 connection.
    CS:S is very demanding.

    1) Turn on the console in CS:S.
    2) Type in net_graph 1, 2, or 3 in the console.
    3) See if the your computers ping is lagging or if your Computer has low FPS.

    4) Turn off QOS on the router.
    5) Try step 2 and 3 again.
  3. matthiaz

    matthiaz Network Guru Member

    Can't confirm. Using QOS with Pre5 5Jun and CS:S is running smoothly.

    I'm using PPPOE and a WMP54GS with newest Broadcom Drivers (Version 4.00B). Oh yeah, and WPA PSK.

    So maybe check out you WLAN drivers?
  4. bytes2000

    bytes2000 Network Guru Member

    Net_graph 3 shows: 0 packet loss and 0 packet choke
    btw, ive set Coutnerstrike service in QoS as Express priority

    it must be a firmware problem, because it wasnt happening with other firmwares
  5. _Shorty

    _Shorty Network Guru Member

    I don't know when DD's QoS patterns were last updated, but if they haven't snagged the latest patterns from the L7 website in the last 2 weeks or so then that counter-strike pattern doesn't even work. Doesn't catch CS 1.6, doesn't catch CS Source. If they are updated then you won't even have a counter-strike pattern, it has been altered to actually work and is now named counter-strike-source, and the quake-halflife pattern has also been changed and it will catch cs 1.6 among all the other stuff it catches.
  6. Jeffrccar

    Jeffrccar Network Guru Member

    Is it 0 packet loss and 0 packet choke the game pauses?
    what is your FPS when it does pause?

    Note: Steam doesn't support using QOS and wants you disable it.
  7. bytes2000

    bytes2000 Network Guru Member

    Still, no luck

    UPDATE> im getting the same behavior even with video streams!
    theyre indefinitely paused and wont go on. So this is not a CS specific problem.

    The connection is stalled for a few seconds, this is a very dramatic screenshot:


    Notes: This was a big pause!!! loooks like i got no data for a few seconds (Check net_graph graphic).
    I have tested on several servers, so i cant blame that server.

  8. matthiaz

    matthiaz Network Guru Member

    Alright. let's put it this way: your computer is fucked! :-p

    I bet you're using WZC? It does a search for new networks every 15? minutes and during that time your wireless connection is down. So that is what might hit you.
    There's some prgramm out there which disables that "service". Just cant remember the name...
  9. bytes2000

    bytes2000 Network Guru Member

    NO way! my computer isnt fucked!

    hardware: Prescott 3.4 GHz
    2 GB DDR2 @ 533 Mhz
    2x160GB Raid 0 (SATA)
    Ati radeon X800 SE

    XP PRO
    Wireless Zero Conf is DISABLED
    Im using Atheros Client utility v4.1.0.132 instead

    Im really sure this is a DDWRT pre5 (jun,5) firmware issue!
  10. Jeffrccar

    Jeffrccar Network Guru Member

    your ping seems a little high for a 512 connection playing CS:S.
    Make sure you have the steam internet connection setting to DSL>128.
    I have a 512 connection and I get about 50 to 70 ms.
    But this wouldn't cause the drop of service.
    Now i don't know what the problem is.
  11. kusotare

    kusotare Network Guru Member

    i have the same problem as this gentleman, but with different hardware.
    WRT54G v2, no mods, no firmware changes (firmware on router is latest linksys update)
    wusb54g wireless adapter on the computer.
    no line interference (out in the boonies and only have corded phones)
    i've tried adjusting mtu settings to 1492 and 1500, havent messed with qos.

    the basic problem is that every few minutes, theres a huge lag spike. no choke, no loss, FPS remains constant, but ping spikes to around 3000 for a period of 1.5-2.5 seconds. the issue isnt the computer as the problem doesnt exist when the router is hardwired to the computer with cat5. i'm running a standard cable connection and generally ping 30-40 on most east coast gaming servers.

    any advice you could give would be helpful.

Share This Page