1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CPU Load

Discussion in 'Tomato Firmware' started by landa, Mar 9, 2009.

  1. landa

    landa LI Guru Member

    My Tomato show me
    CPU Load (1 / 5 / 15 mins) 0.00 / 0.00 / 0.00

    What is the maximum value? When at 100%?

    Thanks!
     
  2. occamsrazor

    occamsrazor Network Guru Member

    I believe 100% CPU usage shows as 1.00
    So a figure of 0.10 would be 10%, for example
     
  3. landa

    landa LI Guru Member

    Thanks for the answer! However, I need a sure answer.
     
  4. der_Kief

    der_Kief Super Moderator Staff Member Member

    Maybe this is interesting for you.

    Extract:

    For example, a load average of "1.73 0.50 7.98" on a single-CPU system can be interpreted as:

    • during the last minute, the CPU was overloaded by 73% (1 CPU with 1.73 runnable processes, so that 0.73 processes were waiting for a turn)
    • during the last 5 minutes, the CPU was underloaded 50% (no processes were waiting for a turn)
    • during the last 15 minutes, the CPU was overloaded 698% (1 CPU with 7.98 runnable processes, so that 6.98 processes were waiting for a turn)


    der_Kief
     
  5. landa

    landa LI Guru Member

    Thanks for the answer! Now everything is very clear about it!
     
  6. occamsrazor

    occamsrazor Network Guru Member

    Thanks for clarifying... My router has never gone above about 0.50, I didn't realise it could show figures above 1.00
     
  7. jersully

    jersully LI Guru Member

    You can read up on the *nix command uptime for more information.
     
  8. Planiwa

    Planiwa LI Guru Member

    CPU queue length is a better measure than CPU utilization, since the latter cannot express values above 100%.

    IOW, a load average of 1 and of 8 will both have a utilization of 100%.

    The uptime command shows load average.
    The top command also shows CPU utilization.
     
  9. azeari

    azeari LI Guru Member

    heh the most i ever got on my wrt was 3.83 on my home network.. at tt level, the webgui was super unresponsive
     

Share This Page