1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DD-WRT v3.2 to DD-WRT v4 Warning.

Discussion in 'DD-WRT Firmware' started by XCOM7, Apr 21, 2005.

  1. XCOM7

    XCOM7 Network Guru Member

    I am sorry if the subjects is a bit off but there is a problem on these 2 firmwares that I think most WRT54G v3 users and other should know and Admin or BrainSalyer see these please make these sticky.

    If you have a WRT54G v3 and you are running DD-WRT v3.2 and try to upgrade to v4 you will brick the router as R0B0T posted before we brick 2 routers as a matter of fact we had to return one. If you want to go from 3.2 to v4 you should upgrade to v3.3 first and than to v4 we brick 3 routers making sure these was the problem. After all the attemps fail I tought about going to 3.3 and than to 4 and it Flash ok did it 3 times and all ok.
    Now on the GS is different we try going from 3.2 to tov4 and it upgraded ok and I think is due to having more memory.
    Any collaboration is welcome.
     
  2. XCOM7

    XCOM7 Network Guru Member

  3. BrainSlayer

    BrainSlayer Network Guru Member

    also if i can't reproduce it with my WRT54G here (i tested this upgrade procedure) i set this to sticky.
     
  4. tl511

    tl511 Network Guru Member

    THANKS!!

    Thanks for making this a sticky. I was about to try this very upgrade on my v.3 router. I will now upgrade to 3.3 first.

    Oh, one last question. Where can you download the prefinal 3.3 version? On dd-wrt.com it goes from 3.2 to 4.

    Thanks,
     
  5. aledr

    aledr Network Guru Member

    I can send by mail to you.. Send a MP for me with your mail.
     
  6. tl511

    tl511 Network Guru Member

    PM sent. Thanks
     
  7. aledr

    aledr Network Guru Member

    File sends!!

    You are welcome!!
     
  8. ppilate

    ppilate Network Guru Member

    I found that the v2.2 pre 3.2 doesnt allow the image.bin file to be uploaded and load it to the flashrom. I was able to use the linksys TFTP utility to flash the WRT back to the latest linksys firmware THEN upgrade to prefinal 4. Other than that the new firmware works great. keep up the great work BrainSlayer!

    - Pilate
     
  9. ghlu

    ghlu Network Guru Member

    So can we upgrade to other firmware that is not DD-WRT without bricking the router? Can't find pre-3.3 everywhere.
     
  10. tl511

    tl511 Network Guru Member

    What's your email address, I'll email it to you as someone did to me today.
     
  11. ghlu

    ghlu Network Guru Member

    PM sent. Thanks
     
  12. bashy

    bashy Network Guru Member

    looking for the 3.4 before upgrading to 4 can someone please hlpe with the link pleas.e thx
     
  13. XCOM7

    XCOM7 Network Guru Member

    Is actualy 3.3
    You will have a PM soon.
     
  14. shanmanz

    shanmanz Guest

    I am running Hyper-WRT can I upgrade to DD-WRT directly
     
  15. BrainSlayer

    BrainSlayer Network Guru Member

    my initial flashing procedure after a recovery is going out from satori always and its working well. but generally inform yourself about the recovery procedure to go the safe way
     
  16. MilesTEG

    MilesTEG Network Guru Member

    Hello,
    Can somebody Send me the 3.3 version of DD-WRT please...

    Thanks you
    ++
     
  17. t4thfavor

    t4thfavor Network Guru Member

    you all want me to just host the fricken file? or someone should post a direct dl link so that it isnt taking up space on the forum...

    since it is an issue i believe you can get it at the official website?
    i think there is an archive.
     
  18. MilesTEG

    MilesTEG Network Guru Member

    on the web site, there are only the version DD-WRT.V22-prefinal3.2, not the 3.3 ...

    So if you geve to me the file, I can host it on my site.
     
  19. akumulator

    akumulator Network Guru Member

    Is there this problem when I am flashing prefinal 4 directly from original Linksys? Or directly from other firmware (HyperWRT)?

    Can somebody send me prefinal 3.3, please? Or can somebody host it?

    Thanks a lot!
     
  20. XCOM7

    XCOM7 Network Guru Member

  21. MilesTEG

    MilesTEG Network Guru Member

    thanks
     
  22. XCOM7

    XCOM7 Network Guru Member

    Also never upgrade from the factory firmware to any of the new hacked firmwares it will also bricked the router.
     
  23. MilesTEG

    MilesTEG Network Guru Member

    ??
    I don't understand...

    What do you mean by "the factory firmware" ?
    And by "hacked firmwares" ??
     
  24. XCOM7

    XCOM7 Network Guru Member

    Ok Miles the Factory Firmware is the firmware that comes with the router when you first buy the router.
    And the hacked firmwares is the 3rd party firmwares.
     
  25. MilesTEG

    MilesTEG Network Guru Member

    Ok, but how can we upgrade the router to 3rd party firmwares, like DD-WRT, HyperWRT...
     
  26. XCOM7

    XCOM7 Network Guru Member

    You would upgrade to the Latest Linksys firmware and than to the 3rd party firmware.
     
  27. wesmoc

    wesmoc Network Guru Member

    So you are saying that the best method with a new router is to:
    1. Upgrade to the latest Linksys supported firmware
    2. then upgrade to the latest 3rd party firmware (such as Satori, dd-wrt, etc).

    Does that hold true for those that already have 3rd party firmware installed? It would seem kind of silly to have to 1. re-flash using the latest linksys firmware and then 2. flash using the latest dd-wrt if we were already running an older dd-wrt version...
     
  28. XCOM7

    XCOM7 Network Guru Member

    Read more carefully...
    Only if you have a stock firmware than upgrade to the latest linksys firmware other than that if you all ready have an old version of dd-wrt than go step by step.If you all ready have a 3rd perty firmware than you have nothing to worry about.
     
  29. beeblebrox

    beeblebrox Network Guru Member

    What if the latest stock firmware is newer than the firmware the third party firmware is based on? As the case with Sveasoft at least, most of the time older firmwares were used.
     
  30. XCOM7

    XCOM7 Network Guru Member


    Whats old is the drievr not the kernel.
     

Share This Page