1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DDWRT v23 Bug Reporting

Discussion in 'DD-WRT Firmware' started by Toxic, Oct 8, 2005.

  1. Toxic

    Toxic Administrator Staff Member

    Please report bugs in the same thread and do not open new threads of the same build.

    When reporting a new bug please put in the topic the Build number

    ie

    Title: Bug Report v23 Build 07-10-05 (or similar)

    if a new build comes out the please start a new thread., the latest Build thread will be sticky from now on once i am notifiied of a new release.

    Any thread that is opened up that already has a thread opened for that particular build will now be merged.
     
  2. SAPo57

    SAPo57 Network Guru Member

    DD-WRT V.23 SP1 mini (build: 16-05-06)

    this new SP1 version has many bugs, but im going to report the most consistent.

    1. It makes the router receive and transmit more interference and noise. Transmission errors occur when wired devices connect to it rather than wireless devices. The transmission rate isn't as accurate with the specified wireless mode and when there is interference on the receiving client it lowers the transmission rate.(this I never saw with other versions of DD-WRT)

    2. On the the Advanced Wireless Settings tab it says that you can change the noise reference from 0--100, but you can only put in -99. 1-3 characters can only be typed when actually 1-4 characters should be, so that you can put in -100.

    3. DNS servers don't respond as quick as before, some times this happens, but mostly occurs when interference is on the signal.

    4. The GUI webpage doesn't refresh so well before and after setting are saved. It takes longer to load, about 5-10 seconds more, after settings are saved(after saving I mean you would click on another tab right after). The DD-wrt v.23 mini is much faster.

    The SP1 version looks pretty cool, but the performance sucks, so I'd rather flash back to the regular v.23 mini,standard, or voip.
     
  3. sufrano63

    sufrano63 Network Guru Member

    I can't seem to get my Internet IP address to update from the Status/Router/Internet page. Tried releasing and renewing and still using the same old IP address. Checked dyndns and seeing the new IP address and ISP confirmed it. Using WRT54G v3.1 and running SP1 Final.
     
  4. d00zah

    d00zah Network Guru Member

    IP addresses are not assigned based your internet connection. That specific IP address is leased to the WAN MAC of your router. Until that lease expires (ISP determines lease time), it'll likely keep pulling the same IP address. I read in the other forum that you are switching between 2 routers and one is getting the "new" IP address". If you spoof the WAN MAC address of that router on the router that pulls the "old" IP address, then it, too, will pull the "new" IP address. The alternative is to just leave the router disconnected until the lease expires, at which point it'll get a different IP.

    Hope this makes sense?

    d-
     
  5. sufrano63

    sufrano63 Network Guru Member

    Great. Thanks for clearing things up. I'll try spoofing the WRT54G as its currently disconnect.

    Thanks again
     
  6. limesoft

    limesoft Network Guru Member

    buggy DD-WRT v23 SP1

    agree, the DD-WRt v23 SP1 verry buggy!!

    I'm having a Linksys ADSL2muE --> SMC7004VBR --> WRT54G loaded DD-WRt v23 SP1.

    SMC as a router with DHCP, and WRT54G as a AP, I already disable the DHCP in WRT54G and i take a connection to my WRT54G's LAN port. I always get disconnected ( to wan ) but i still can ping the smc router!! All the pc which is connected behind the smc router is fine. Btw, when i disconnect my wifi client and the lan client behind the WRT54G and reconnect back, it work again for awhile then it goes off again.

    WiFi part, it;s very unstable, get ping reply between 10ms to 90ms !!! Shock!!

    after all i down gread to DD-WRt v23 beta 1, it works perfectly!!

    Is that thier really final ? or getting worst from DD-WRT?
     
  7. SAPo57

    SAPo57 Network Guru Member

    Well, I think it's just something when you flash the SP1 and your NVRAM doesn't erase properly.

    So I flashed back to the regular DD-WRT v.23 mini, then to the original linksys firmware.

    Before and after each flash I resetted to factory defaults 3 times and holded the reset button for 30 sec. 3 times as well.

    Then I flashed back to DD-WRT v.23 mini and then to the SP1 version resetting 3-6 times each as well.

    The strangest thing that I saw was that during each flash the username and PW that I changed(I mean my own login info. not the firmware's) on each firmware before would pop-up in that connection box that usually comes up, in which you either type "root" or "admin". Then when I flashed to the DD-WRT firmware(not the SP1) it would load my old configuration settings. This was a problem with the NVRAM so I resetted again and everything loaded perfectly as it should be(the firmware's actual defaults).

    When I finally flashed to the SP1 version again everything worked now better than before, no network(wired and wireless) problems, interference, transmission errors, nor slow performance. All the settings work perfectly now.
     
  8. vincentfox

    vincentfox Network Guru Member

    I believe this thread was a place where Toxic intended to announce HOW to do proper bug reports. Not a place to lump the actual bug reports. I already created a sticky thread for that.

    Let me say without being too unkind, that most of your bug reports above are very poor. It's like walking in to a mechanic shop and saying "car is broken!"

    Well there is a lot more details that need to be filled in.

    What version of the hardware?

    What version of firmware (include date-code in top-right corner)?

    Exactly how you flashed

    Did you do the 30-second long reset after flashing?

    Did you manually reset all settings? You cannot load firmware config files from older versions and expect reliable results. This is inconvenient but a fact.

    Have you already been through the Wiki and troubleshooting guides on dd-wrt.com to see if you did the right step?

    Things like that. Otherwise people will assume this is operator error. I mean wouldn't you, if your setup worked perfectly?

    Here's some good reading (not a helpdesk!):

    http://www.catb.org/~esr/faqs/smart-questions.html

    Recommend to re-file bug reports under appropriate threads, not here in the Announcement posting.
     
  9. SAPo57

    SAPo57 Network Guru Member

    Brainslayer and his team will eventually figure out the bugs, but while he's doing that I can just buy a few heat sinks, bigger and better antenna, fan,etc. -until everything is set to normal operations. The four of us here are experiencing the bugs, while the thousands of others who have the SP1 firmwares are already figuring out the solutions.

    So if it's more detail you want well you can't because im not a bug tracker, I could wait until it's fixed for me. I'm just telling you guys what's wrong with the software, then others who read the posts will observe for the bugs and announce the real issues for brainslayer to fix.

    It's like a step-by-step equation. You can't always have everything at once, you just gotta wait, chill, everything will work out. OR TODAY I JUST SMOKED TOO MUCH. =SAP= ~out~
     
  10. limesoft

    limesoft Network Guru Member

    We apreaciate what DD-WRT team did for us~! Wonderfull job, btw we respon because everybody need the firmware to more stable, no harm to report, just don't take it too seriouse, anyhow we will always waitting for them to fix it. :)
     
  11. vincentfox

    vincentfox Network Guru Member

    Im not against anyone complaining about problems with the firmware.

    Let me re-iterate:

    1) This is not the right thread for bug reports. That woul be the sticky posts section, or even a new thread.

    2) Bug reports need to include details of your setup. Otherwise it is hard to distinguish a real bug from simply a misunderstanding or misconfiguration issue. Quite frequently what someone is certain is a bug actually is not.

    Let me give a clear and simple example:

    In v23-SP1 you now have to enter "root" as the username, not just leave it blank. Many people post about how the new SP1 is "broken" or has a "bug" when in fact it works just fine. Let me contrast 2 possible posts:

    User #1 - "I just loaded this DD-WRT firmware and now my router is bricked please help!"

    User #2 - "I just loaded DD-WRT v23-SP1 final firmware onto my WRT54GS v1.0 router and now I cannot login! Even resetting to defaults the password admin doesn't work!"

    See in the second case it's a lot easier to figure out what is going on because vital information is included that leads directly to a quick answer.

    In my own case I was trying to do a WDS bridge using WPA-PSK encryption and it wouldn't work. I thought it was broken. Once I posted my configuration settings someone pointed out I had disabled 802.1x which is essential for WPA to work. Once I re-enabled it the thing worked just fine.

    I am NOT trying to diss on you guys. Just explaining if you want better results, you gotta give more details in your posts.
     
  12. SAPo57

    SAPo57 Network Guru Member

    Alright, Alright... I get your point. You don't have to repeat your self. One thing I do know is that the DD-WRT SP1 v.23 mini for the WTR54GS v.4 doesn't flash properly some times even following the correct steps to flash these firmwares. Thus, leading to a misconfigured NVRAM or something, and looks as if its got bugs in the system.






    END OF DISCUSSION..............................
     
  13. AP0LL0

    AP0LL0 Guest

    Schedule reboot issue

    Hello,
    I was wondering if anyone had come accros the following issue.
    I am using the Firmware: DD-WRT v23 SP2 (08/03/06) micro
    Time: 11:59:05 up 1 day, 15:10, load average: 0.02, 0.02, 0.00 with a WRT54GS v5.0 (the crappy one) router, i have set the Schedule Reboot to Enabled and configured the Interval to 86400, e.g. 24Hrs., see attached image.

    As you can see by the up time the router did not reboot, should the Up value reset when the Schedule reboot is enabled?

    Looking forward for your replies

    AP0LL0
    "If builders built houses the way programmers built programs, the first woodpecker to come along would destroy civilization. "
    Gerald Weinberg
     

    Attached Files:

  14. zingo

    zingo Guest

    p2p and CLOSE_WAIT

    i'm noticing a lot of connections in CLOSE_WAIT state even though i followed the instructions on http://www.dd-wrt.com/wiki/index.php/Router_Slowdown#Extra_Information and added it to my startup. the connections should time out after 60 seconds, but they're not. i've tried several bittorrent clients and they all exhibit this problem.

    Code:
    netstat -an | grep -i close_wait | wc -l
          74
     
  15. kubanczyk

    kubanczyk LI Guru Member

    Hi,

    those instructions were long outdated. I hope that my update will solve your problem:
    http://www.dd-wrt.com/wiki/index.php/Router_Slowdown


    Edit: In your case those generic instructions may not work. I would try to place this on rc_startup:
    echo 60 > /proc/sys/net/ipv4/netfilter/ip_conntrack_tcp_timeout_close_wait
     

Share This Page